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Installation Overview
Thank you for purchasing ServiceCEO® and welcome to the Insight Direct family!
The Installation Guide is designed to walk you through installing ServiceCEO, including:
•

Installing the ServiceCEO Client

•

Installing the Database Management Tools

•

Installing ServiceCEO with SQL Server™ 2000 or SQL Server 2005

•

Configuring a ServiceCEO Network (Connecting Remote Users to ServiceCEO)

•

Managing your Database (Backing Up, Restoring, etc.)

•

Upgrading ServiceCEO

•

Training Materials

Depending on what version of SQL Server you will be using, it will take you around 30 to 45 minutes to
install ServiceCEO and setup its database.

Requirements for Installing ServiceCEO
Please disable any virus protection software you have running before installing ServiceCEO. Running such
software during installation may interfere with the installation process.
To install ServiceCEO, you must be logged onto the computer as the Windows® Administrator. If you are
running Microsoft® Vista®, you can be logged in as a regular user, but will need to enter the Administrator
credentials before ServiceCEO will be installed.

System Requirements
Any computer running the application should have or use:
•

The Windows XP®, 2003, or Vista operating systems. We recommend using Windows XP
Professional or Vista for optimal performance.

•

A processor of at least 2 GHz with at least 512 MB of RAM.
Tip:
For more on our computer recommendations, please see the System Requirements page of our
website, located at http://www.insightdirect.com/system-requirements/.
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What Do I Need to Install?
There are two ServiceCEO installers:
1.

The Client Installer.

2.

The Database Management Tools. This installer contains two tools:
1.

The Database Setup Wizard. The Database Setup Wizard configures the ServiceCEO
database. In addition, depending on your needs, it can also install SQL Server 2005
Express, the database engine that runs ServiceCEO.

2.

The Backup and Restore Utility. This utility lets you backup and restore ServiceCEO
databases.

If you are going to use one computer to run both ServiceCEO and the database server (SQL Server), you
should run both the Database Setup Wizard and the ServiceCEO Client installer. Run the Database Setup
Wizard before you run the ServiceCEO client installer.
If you are going to have at least two separate computers, they will be configured differently:
1.

The server computer. This is the computer that will host the ServiceCEO database. Run the
Database Management Tools and then the Client.

2.

The client computer(s). Any computer running only the ServiceCEO client, connecting to the
database on the server computer. Install only the ServiceCEO Client.

Connecting a client computer to the server will be covered in the Network Configuration Overview section.

Installing the ServiceCEO Client
The ServiceCEO client is the basic ServiceCEO software. All computers that will be running ServiceCEO
need to install the client.
If you are going to use one computer to run both the ServiceCEO client and your database server, please
install and run the Database Management Tools before you run the ServiceCEO client installer. For more,
see the Database Management Tools section.
To install ServiceCEO:
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1.

Log into the computer on which you want to install the ServiceCEO Client as the Windows
Administrator. Note that if you are running Microsoft Vista, you can be logged in as a regular
user, but will need to enter the Administrator credentials before ServiceCEO will be installed.

2.

Insert the ServiceCEO CD into your computer. A welcome page appears.
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Note:
If you do not have the ServiceCEO CD, but have instead have downloaded the ServiceCEO
Client Installer from the Member Center, double-click the install file and go to step three.

2.

Click Install the Client. The Welcome to the InstallShield Wizard for ServiceCEO page appears.
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3.

Click Next. The License Agreement page appears.

4.

Read the entire license agreement by scrolling down. You can print out the license agreement by
clicking Print.

5.

If you accept the conditions described in the license agreement, click the I accept the terms of the
license agreement option button. If not, you will not be able to install ServiceCEO.

6.

Click Next. The Destination Location page appears.
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7.

ServiceCEO's default installation location is C:\Program Files\ServiceCEO. If you want to
change the installation location:
o

Click Change.... The Choose Folder dialog box will appear.

o

Navigate to and select the folder on your computer where you want to install
ServiceCEO.

o

Click OK to change the location. The new location will appear on the Choose
Destination Location page.

8.

Click Next. The Setup Type page appears.

9.

Select the option you want to install. Your options are:
o

Complete. The wizard will install both ServiceCEO and any additional needed
components. Currently, the only extra component is QBFC5, which is a QuickBooks
Integration Pack that enables ServiceCEO to integrate with all of the supported versions
of QuickBooks.

o

Custom. You will be given a choice as to what you want to install.

10. Click Next. If you selected the Custom option, the Custom Setup dialog box appears. If you
selected the Complete option, skip to step 13.
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By default, two components are installed:
•

ServiceCEO. This is the ServiceCEO Client Software.

•

QuickBooks Integration. This component installs QBFC5, the QuickBooks Integration Pack that
will integrate ServiceCEO with QuickBooks. For more on QuickBooks Integration, see the
Accounting Integration Overview topic.

11. Select the components you want to install by clicking on the appropriate down arrow. The two
relevant options are:
o

This feature will be installed on local hard drive. Select this option to install the
component.

o

This feature will not be available. Select this option if you do not want to install the
component.

Select the appropriate option for each component.
12. Click Next. The Ready to Install the ServiceCEO Client page appears.

13. Click Install. The program starts to install. The installation progress displays on the Setup Status
page. When the installation finishes, the Installation Completed page appears.
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14. Click Finish. The InstallShield Wizard will close. The ServiceCEO Client is installed!
If you are not installing a ServiceCEO database, the installation is complete. If you are installing a
ServiceCEO database, continue to the Database Management Tools section.

The Database Management Tools
The Database Management Tools will help you configure your Server Computer. Running the Database
Management Tools will install two things:
•

The Database Setup Wizard. This tool will configure your database engine. See the Database
Setup Wizard section for details.

•

The Backup and Restore Utility. This tool enables you to backup and restore your database.

To install the Database Management Tools:
1.

Insert the ServiceCEO CD into your server computer. The Welcome page appears.

Note:
If you do not have the ServiceCEO CD, but instead have downloaded the file from the Member
Center, simply double-click the install file and go to step 3.

2.

Click the Setup a Database option. The Database Management Tools Installer appears.
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Note:
If you do not have .NET 2.0 installed, the Database Management Tools installer will load it
before continuing.
Both ServiceCEO 6.1+ and the ServiceCEO API require .NET 2.0.
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3.

Click Next. The License Agreement page appears.

4.

Read through the license agreement.

5.

Select the I accept the terms in the license agreement option button.

6.

Click Next. The Destination Folder screen appears.
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7.

The default location of the Database Management Tools depends if you have installed
ServiceCEO before.
o

If you had installed any version of ServiceCEO 6.0 or prior, the default location is
C:\Program Files\ServiceCEO\Database Setup Wizard.

o

If you are installing for the first time with 6.1 or later, the default location is C:\Program
Files\Insight Direct\Database Management Tools.

8.

If you want to change the installation location, click Change.... The Choose Folder dialog box will
appear. Navigate to and select the folder on your computer where you want to install ServiceCEO.
Click OK to change the location. The new location will appear on the Destination Folder page.

9.

Click Next. The Setup Type dialog box appears.

10. Select the option you want to install. Your options are:
o

Complete. Both the Database Setup Wizard and the Backup and Restore Utility will be
installed.

o

Custom. You will be given a choice as to what you want to install.

11. Click Next. If you selected the Custom option, the Custom Setup dialog box appears. If you
selected the Complete option, skip to step 14.
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12. Select the components you want to install by clicking on the appropriate down arrow. The two
relevant options are:
o

This feature will be installed on local hard drive. Select this option to install the
component.

o

This feature will not be available. Select this option if you do not want to install the
component.

Select the appropriate option for each component.
13. Click Next. The Ready to Install the ServiceCEO Database Management Tools screen appears.

14. Click Next. The Database Management Tools will be installed. This may take a few minutes.
After the installation is complete, the finish page appears.
15. Click Finish. The Database Setup Wizard will automatically run, displaying the Welcome page.
For details, see the Database Setup Wizard section.

10

Installation Guide

The Database Setup Wizard
The Database Setup Wizard configures the ServiceCEO database on your server computer. If you are a new
ServiceCEO user, or upgrading from using the MSDE (any ServiceCEO version 6.0 or earlier), it will
install SQL Server 2005 Express, ServiceCEO's database server. It will also configure your database so that
ServiceCEO clients can connect to the ServiceCEO database.

The Database Setup Wizard and Other Versions of SQL Server
Other database servers you may have been using to run ServiceCEO include:
•

Microsoft SQL Server Desktop Engine (MSDE)

•

SQL Server 2005 Express RTM (SQL Server Express without any of the service packs)

If you are currently using one of these database servers, running the Database Setup Wizard will force you
to upgrade to the newer SQL Server 2005 Express SP2.
If you are already using a full version of SQL Server (Workgroup or up), running the Database Setup
Wizard is optional, depending on two factors:
1.

If you have run ServiceCEO before. If you have already run ServiceCEO before, your database
is already configured on your server computer. If you have never used ServiceCEO, you need to
run the Database Setup Wizard.

2.

If you want to use ServiceCEO's Database Backup and Restore Utility. If you want to use the
Database Backup and Restore Utility rather then SQL commands, run the Database Setup Wizard.
If you use regular SQL commands to backup and restore your databases, you do not need to run
the Database Setup Wizard.
Caution:
With SQL Server 2005, Microsoft has released a new data access driver known as SQL
Native Client. ServiceCEO works with the existing SQL Server ODBC Driver; it does
NOT work with the SQL Native Client.

Running the Database Setup Wizard
The Database Setup Wizard can be run in two ways:
•

Immediately after installing the Database Management Tools.

•

Manually by selecting Start > All Programs > ServiceCEO > ServiceCEO Database Setup
Wizard.
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Regardless of how you run it, the Welcome page appears:

1.

Click Next. The Wizard will scan your system to see if you have a previous version of SQL Server
installed. Depending on what it finds, the Database Setup Wizard will perform different steps:
o

MSDE via ServiceCEO. If you installed MSDE during an earlier installation of
ServiceCEO (6.0 or earlier) or have the original version of SQL Server 2005 Express (the
RTM version, before any of the service packs were released), you will be upgraded to
Microsoft SQL Server Express 2005 SP2. Click Next to continue.

o

No SQL Server. If no version of SQL Server is installed, the Database Setup Wizard will
ask you where you would like to install Microsoft SQL Server Express 2005.
By default, Microsoft SQL Server Express 2005 will be installed at C:\Program
Files\Microsoft SQL Server\90.

o

Any other SQL Server. If you have another version of SQL Server installed - including
a MSDE that was not installed by ServiceCEO, or SQL Server 2005 Express SP1 - you
will be presented with the option to continue using this SQL Server or to install a new
instance of Microsoft SQL Server Express 2005. The option that you select will be the
version that ServiceCEO will use.

o

Other Versions of SQL Server 2005 or 2000. If you have a full version of SQL Server
installed (Workgroup or up), only the ServiceCEO Database Backup and Restore Utility
will be installed.

Caution:
Before you install Microsoft SQL Server Express 2005, you should be aware that it has specific
operating system requirements, and also needs at least 600 MB of free space. For a complete
listing of the system requirements for Microsoft SQL Server Express 2005, see Microsoft's
Installation Requirements for SQL Server Express SP2 webpage.
2.
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If you choose to upgrade the ServiceCEO MSDE to Microsoft SQL Server Express 2005, the
Database Setup Wizard will prompt you before you install it:
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Note:
If the Database Setup Wizard installs Microsoft SQL Server Express 2005, it will be installed as
a named instance.
If you have already installed at least one instance of SQL Server 2005, you will be prompted to
select the SQL instance you want to use. Select the instance and click Next. The Install Database
page appears; skip to step 5.
3.

Click Next. A warning dialog box appears, informing you that you will be installing SQL Server
2005 Express.

4.

Click Yes. Microsoft SQL Server Express 2005 will start to install. The installation will take a few
minutes; please be patient. You may see a series of prompts. When completed, the Install Database
page appears.
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5.

Select the name of the database you want to install. Your options are:
o

Blank Database. A new, blank database.

o

Demo Database. A database loaded with sample data. Note that this version can only be
installed from here if you have the ServiceCEO CD.

o

Use Existing ServiceCEO Database. If you already have a ServiceCEO database that
you've been using, select this option.

Tip:
A wide range of demo, starter, and industry-specific databases can be downloaded from the
Insight Direct member center. Click on the Training Databases link from the Member Center's
home page to see what's available.
If you want to use one of the databases from the Member Center, select the Blank Database
option in the Database Setup Wizard and finish running through the Wizard. Once the setup is
complete, you can restore one of Member Center's database in the usual manner.
6.

Click Next. If you selected the Blank or Demo Database option, a warning appears, informing you
that the existing database will be overwritten. Click Yes to override the existing database (if any).
If you selected Use Existing, skip to step 8.

7.

Click OK. A complete message appears when the blank or demo database is restored.

8.

Click OK. The Database Connection Information screen appears.

This screen displays your server configuration information. This information is useful for configuring your
network and troubleshooting any network problems. To print these settings, click Print Settings.
9.
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Click Finish. Your database is configured!
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Installing ServiceCEO with SQL Server 2000
If you have a full version of Microsoft SQL Server 2000 installed, you can configure ServiceCEO to use it
rather then SQL Server Express. For an explanation of the difference, read the Installing ServiceCEO
Overview topic.
Caution:
When installing SQL Server, your collation needs to be set to
"SQL_Latin1_General_CP1_CI_AS". If it is not, you will receive collation errors that will
require you to uninstall both ServiceCEO and the SQL Server on the server computer and
reinstall them using the correct collation.
To install a ServiceCEO database that will work with SQL Server 2000, please follow the following steps.
1.

Log into the computer as the Windows Administrator.

2.

Run the ServiceCEO Client installer. This file is located on the ServiceCEO Installation CD, or
you can download it from the Insight Direct Member Center. The ServiceCEO InstallShield
Wizard appears to walk you through the process. The steps for this process are located in the
Installing the ServiceCEO Client topic.

3.

When the installation is complete, reboot your computer.

4.

The next step is to install the Database Management Tools on the Server so that you can run the
Database Setup Wizard. When prompted to select the SQL Server instance you want to use, select
the existing ServiceCEO instance or the instance you created when installing SQL Server 2000.

You can now run and login to ServiceCEO in the normal manner.

Installing ServiceCEO with SQL Server 2005
SQL Server 2005 Workgroup or Standard Edition Overview
ServiceCEO's Database Management Tools ships with a managed version of Microsoft SQL Server called
SQL Server 2005 Express. Most users install this server, which automates many of the complex
configuration and maintenance tasks involved in managing a database. However, SQL Server 2005 Express
does have some performance limitations, including:
•

Supports only one CPU

•

Supports only one GB of RAM

Using the Workgroup or Standard versions of SQL Server to host one or more ServiceCEO databases will
prevent this performance degradation, including:
1.

Use of multiple processor machines. For example, SQL Server 2000 supports up to 32 Central
Processing Units (CPUs) and 64 GB of RAM.

2.

Expanded RAM capabilities. The Workgroup edition supports 3 GB of RAM, while the Standard
edition can use as much RAM as your operating system supports.

See Microsoft's SQL Server 2005 Features Comparison website for a graph of the capabilities of the
different versions of SQL Server 2005.
Note that SQL Server 2005 Express is included with ServiceCEO as part of the Database Management
Tools. If you want to use another version of SQL Server, you will need to purchase it from Microsoft. See
the Microsoft website for more information.
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Caution:
The bit version of your SQL Server will need to match that of your OS. In other words, if you
are running a 64-bit edition OS, you will need to purchase the 64-bit edition of SQL Server 2005
Standard Edition.
The following topics will cover installing SQL Server 2005 Workgroup or Standard Edition for use with
ServiceCEO. It is designed to be a general overview, and by no means should be intended as the final
authority on the subject. For more detailed information, troubleshooting questions, and other general issues,
please consult the appropriate Microsoft documentation.
If you want to use ServiceCEO with SQL Server 2000, please read the Installing ServiceCEO with SQL
Server 2000 topic.
Caution:
The installation and configuration of SQL Server 2005 should be performed by Network
Administrators, SQL Server Administrators and\or Information Technology (IT) personnel.

Installing SQL Server 2005 Workgroup/Standard Edition
To install the Workgroup or Standard version of Microsoft SQL Server 2005, you will need to purchase it
from Microsoft. Once purchased, follow these steps:
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1.

Insert the SQL 2005 CD or run the downloaded installer. The splash screen appears:

2.

Click the Install – Server components, tools, Books Online and samples link. The End User
License Agreement dialog box appears.
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3.

Select the I accept the licensing terms and conditions check box.

4.

Click Next. If any of SQL Server's prerequisites need to be installed, you will be prompted to
install them.
Note:
Depending on your server's configuration, you may or may not be prompted to install any
of SQL Server's prerequisites. If the protocol you are using is already enabled, you do not
need to perform any actions in this dialog box.

5.

When the Welcome to the Microsoft SQL Server Installation Wizard screen appears, click Next.
The System Configuration Check dialog box appears and will inspect your computer for any
issues that may cause problems with the installation.
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6.

If any tests fail, you should review the error messages and take the appropriate action. Note that
some warnings may be for informational purposes only, and may not cause any problems with the
installation of SQL Server. Whether or not a test is informational or not is difficult to tell. With
that in mind, we recommend that you contact the appropriate vendor for more information about
any warnings that occur before you continue installing SQL Server.

7.

Optionally, you can save these errors and warnings to a report file by clicking Report and
selecting Save Report to File from the pop-up menu.

8.

Click Next. The installation will begin. After a minute, the Registration Information dialog box
appears.

9.

Type the name of the SQL Server administrator into the Name field.
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10. Type the name of your company into the Company field.
11. Type your product key into the registration information fields.
12. Click Next. The Components to Install dialog box appears:

13. Select the SQL Server Database Services check box.
14. Select the Integration Services check box. All other check boxes are optional but not required.
15. Click Advanced. The Feature Selection dialog box appears.

16. Expand the tree to see the Client Components/Management Tools section.
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17. Click Management Tools and select Entire Feature will be installed on local Hard Drive from
the pop-up menu.
Note:
If you want to install SQL Server 2005 in a location other than the default path
(C:\Program Files\Microsoft SQL Server), in the Feature Selection dialog box:
•

Click Database Services. The Feature Selection dialog box appears.

•

Click Browse.

•

Navigate to and select the folder where you want to install SQL Server

18. Click Next.
19. Click Next.

20. Select the Named instance option button and type "ServiceCEO" into the field. While not
required, we highly recommended you perform this step.
21. Click Next. The Service Account dialog box appears.
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22. Select the Use the built-in System account option button.
23. Select Local system from the drop-down list.
24. Select the SQL Server check box in the Start services at the end of setup section.
25. Click Next. The Authentication Mode dialog box appears.

26. Select the Mixed Mode option button.
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27. Type your sa logon password into the Enter password and Confirm password fields. Note that a
blank password will not work with ServiceCEO.
28. Click Next. The Collation settings dialog box appears.

29. Select the SQL Collations option button.
30. Select Dictionary order, case-insensitive, for use with 1252 Character set from the list box.
Note that this setting is very important for international users running ServiceCEO outside of the
U.S.
31. Click Next. The Ready to Install page appears.
32. Click Install. SQL Server will start to install. The installation status will be displayed in the Setup
Progress dialog box.
33. When the installation has finished, click Next. The Completing Microsoft SQL Server 2005 Setup
dialog box appears.
34. Click Finish. SQL Server has been installed!
The next step is to install the Database Management Tools on the Server so that you can run the Database
Setup Wizard. When prompted to select the SQL Server instance you want to use, select the instance you
created in step 20.
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Configuring SQL Server 2005 for 20+ Users
If you are using the Workgroup or Standard Edition of Microsoft SQL Server 2005, and are going to have
more then 20 users accessing ServiceCEO, you should locate your Data and Log files in separate
networked locations in order to prevent performance issues.
Requirements:
•

RAID 5 array (requires minimum of 3 disks) for the Data file

•

Another separate drive (preferably a mirrored RAID array) for the Log file

The steps below should be run after Installing SQL Server 2005 but prior to running the Database Setup
Wizard. Administrators should setup up the ServiceCEO database manually so that the Data and Log files
can be installed in different locations.
To change the locations of your Data and Log files, the SQL Server Administrator should perform these
steps:
1.

Select Start > Programs > Microsoft SQL Server 2005. The SQL Server Management Studio
appears.

2.

Right-click on the Databases folder and select New Database... from the pop-up menu. The New
Database screen appears.

3.

Type ServiceCEO into the Database name field.

4.

In the Database files box, scroll to the right until the Path column is visible.

5.

Click

for the first file (the first file is the Data file). The Locate Folder dialog box appears.
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6.

Navigate to the location on the RAID 5 array you want to store the Data file.

7.

Click OK. The network path you selected appears in the Path column of the first file.

8.

Click

9.

Navigate to the location on the separate drive that you want to store the Log file.

for the next file (the second file is the Log file). The Locate Folder dialog box appears.

10. Click OK. The network path you selected appears in the Path column of the second file.
11. Click Options from the Select a page box.

12. Select Simple from the Recovery Model drop-down list.
13. Click OK. The database will be created.
The next step is to run the Database Setup Wizard. On the Install Database page of the Database Setup
Wizard, do not select the Use existing ServiceCEO database option button because there is currently
nothing in the database you just created. Instead, select either the Blank Database or Demo Database to
restore that information into the database you just created.
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Configuring your Network
Network Configuration Overview
You can connect multiple ServiceCEO users to the same database via a network. There are two different
types of networks:
•

Local Network. A Local Area Network (LAN) consists of computers that are in the same physical
location. For example, if you have seven computers in the same office building all working off of
the same database, you are running a LAN.
Note that a LAN is typically protected by a firewall from resources that are not located within the
network (like the internet).

•

External Network. A Wide Area Network (WAN) consists of multiple computers in separate
physical locations connected via the Internet. Examples of WANs include:
o
o

A user at home connecting to the ServiceCEO database located in their work office.
An employee based in Wichita, Kansas logging onto a ServiceCEO database located in
Wichita Falls, Texas.

A Typical ServiceCEO Network

Regardless of the type of network you are running, you need to configure all client computers running
ServiceCEO so that they are pointing at the server computer, as detailed in the Connecting the Client to a
Local Database section.
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Connecting the Client to a Local Database
In order to connect your client computers to the server computer over a Local Area Network (LAN), you
must point all clients at the server computer. This is done with the Database Connection tool.

Connecting to ServiceCEO for the First Time
1.

Double-click the ServiceCEO icon on your desktop. The Database Connection dialog box appears.

2.

Type the name of your server into the Server field. Alternatively, you can use the server's IP
Address.

3.

Type ServiceCEO in the Database drop-down list.

Note:
The connection information for the server is displayed on the last page of the Database Setup
Wizard.

4.

Click OK. The database will open.

Connecting After the Initial Connection
If, for whatever reason, you need to connect to another ServiceCEO database, you can run the Database
Connection tool from within ServiceCEO.

26

1.

Select File > Database Connection. The Database Connection dialog box appears.

2.

Type the name of your server into the Server field.

3.

Type ServiceCEO in the Database drop-down list.

4.

Click OK. The connection to the current database will close. ServiceCEO will open, connected to
the new database. You will need to log in to the new database.
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Troubleshooting a Network Configuration
If, after following the steps detailed in the Connecting the Client to a Local Database section, you are still
unable to connect to the server computer, there may be a general networking issue between the two
computers. For example, a defective network cable or a firewall may be blocking your access. To help
determine the problem, run the following two tests:

Test #1 - Basic Network Connectivity (the "ping" test)
1.

Select Start > Run. A Run dialog box appears.

2.

Type cmd or command in the Open field.

3.

Click OK. A DOS window appears.

4.

Type ping SERVER at the command prompt, replacing "SERVER" with the name or IP address
of your server.

5.

Press Enter.

If you see a series of "Reply from..." messages, this indicates that network traffic is successfully moving
between your client and your server. This test has succeeded and you can continue to test #2.
If you receive a "Could not find host" message, you may have entered a server name which is not
recognized on the local computer. Repeat test #1's step 4 but replace the server's computer name with its IP
address. If pinging the IP address succeeds, use this IP address to connect (in step 2 of the Connecting the
Client to a Local Database section).

Test #2 - Advanced Network Connectivity (the "telnet" test)
1.

Select Start > Run. A Run dialog box appears.

2.

Type cmd or command in the Open field.

3.

Click OK. A DOS window appears.

4.

Type telnet SERVER 1433 at the command prompt, replacing "SERVER" with the name or IP
address of your server.

5.

Press Enter.

If your DOS window goes blank and the cursor resets to the top left corner, this test has succeeded and you
can close the DOS window by clicking the X in the top right corner. Your server appears to be running and
no network obstructions are preventing your client from connecting.
If you see either a "Could not open connection to the host" message or a "Connection failed" message,
something preventing the client from connecting to the server port on the server. To fix this, verify that
SQL is running and that the server can see itself.

Verify SQL is Running
For the MSDE:
To verify if the SQL Engine is running on your server, look in your system tray (generally located in the
lower right corner of your computer's task bar, next to the clock). If it is running, you will see the MSDE
icon:
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If you do not see the SQL engine running in your system tray, select Start > Programs > Startup >
Service Manager. The SQL Server icon will appear in your system tray.
If the SQL icon does not have a green triangle, double-click on the SQL icon. This will open the SQL
Server Startup Manager window.

Press the green "play" button in this window to start SQL Server.
Note:
If the green "play" button is not active in the SQL Server Service Manager window, you may
need to click Refresh Services first.
For SQL Server 2005 Express, the full versions of SQL Server 2000, and SQL Server 2005:
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1.

Select Start > Settings > Control Panel > Administrative Tools.

2.

Double-click Services. The Services dialog box appears.
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In the list of the services, locate the service named SQL Server (InstanceName) and verify that its status is
Started. The InstanceName will be whatever you named your SQL Server instance when you installed SQL
Server.
If the SQL Server (InstanceName) service is not running, right-click it and select Start from the pop-up
menu.

Can the Server Connect to Itself?
On the Server computer, follow these steps:
1.

Select Start > Run. A Run dialog box appears.

2.

Type cmd or command in the Open field.

3.

Click OK. A DOS window appears.

4.

Type telnet SERVER 1433 at the command prompt, replacing "SERVER" with the name or IP
address of your server.

5.

Press Enter.

If your DOS window goes blank and the cursor resets to the top left corner, this test has succeeded - the
server can connect to itself.

Other Issues
Filtering Software
Port 1433 is the default port used by SQL. Since ServiceCEO communicates using the SQL language, all
incoming requests for ServiceCEO data will also be in the SQL language. Thus, if something is filtering the
traffic that arrives at port 1433 (i.e., all SQL requests), incoming ServiceCEO requests will not reach their
proper destination.
Software that may be filtering network traffic include:
•

Software or hardware firewall software (like the Windows XP Firewall)

•

Anti-virus applications

If any software product is filtering traffic to port 1433, you should either turn off this software or disable
the port 1433 filtering. Unfortunately, since every program is unique, we cannot tell you how to disable the
filtering software. We recommend you read your user documentation for the product you suspect is
filtering or blocking port 1433.
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Caution:
Disabling port 1433 filtering should only be done for clients within the LAN. Exposing port 1433
on any computer (but especially the server) directly connected to the internet is a security risk.
For more on security in ServiceCEO, please see the ServiceCEO Security Best Practices white
paper in the ServiceCEO Best Practices Library of the Member Center.
Once you have disabled any filtering software, try opening ServiceCEO again.

Excepting Port 1433 from the Windows XP Firewall
If any of the client computers are running Windows XP, you need to provide an exception for port 1433.
1.

Open Windows Explorer. A shortcut is to right-click the Start menu and select Explore from the
pop-up menu.

2.

Right-click My Network Places and select Properties from the pop-up menu. The Network
Connections dialog box appears.

3.

Right-click Local Area Connection and select Properties from the pop-up menu. The Local Area
Connection Properties dialog box appears.

4.

Click the Advanced tab. For more information on creating an exception for port 1433, please see
your Windows documentation.
Caution:
Providing an exception for port 1433 in the Windows XP Firewall should only be done for client
computers within a LAN. Under no circumstances should you expose port 1433 on any computer
(but especially the server) directly connected to the internet. For more on security, please see the
ServiceCEO Security Best Practices white paper in the ServiceCEO Best Practices Library of the
Member Center.

Still Can't Connect?
If, after running all of the above tests, you continue to experience connection issues, contact Insight Direct's
Technical Support Department. Be sure to tell the results of both the ping test and the telnet test to the
Technical Support Representative.
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Connecting to ServiceCEO from a Remote Location
You can connect to ServiceCEO from any external office or home (that is, over a Wide Area Network
(WAN).
Based on your connection needs, security concerns, and resources, there are three levels of remote
connectivity you can use:
1.

Basic. For small companies with only one remote user, you can use a basic connectivity tool. This
is the ideal solution if you want to set up remote connectivity yourself.
See the Basic - Connectivity Tools section for more.

2.

Advanced. For businesses that will have several remote users (1-10) who need to connect to
ServiceCEO, you should use a Virtual Private Network (VPN).
See the Advanced - VPN section for more.

3.

Expert. For businesses with several remote users (10+) who need to connect to ServiceCEO or are
experiencing VPN and/or network latency issues (slow connection speed), we recommend
configuring a server with Terminal Services.
See the Expert - Terminal Services section for more.

Please note that there are many security risks involved with opening your network and/or ServiceCEO
database to a public network such as the Internet. Using one of the methods above for remote connectivity
will help minimize these risks. However, if you feel uncomfortable or do not completely understand the
methods involved, we highly recommend contacting a local network professional. They will be able to
insure that your remote access is properly configured and your systems are not at risk.
Tip:
For more on ServiceCEO security, please see the ServiceCEO Security Best Practices white
paper, located in the ServiceCEO Best Practices Library of the Member Center.

Basic Remote Connectivity - Connectivity Tools
For small companies with only one remote user, the safest and easiest way to access ServiceCEO remotely
is to use a tool that enables you to access a client computer from a web browser. We recommend using one
of two tools:
•

GoToMyPC. For more, see their website at www.gotomypc.com.

•

LogMeIn. For more, see their website at www.logmein.com.

Using these services will not require you to compromise your security by opening additional ports on your
router or firewall.
To enable the remote connection, all you need is:
•

High speed internet access (a DSL or T-1 line)

•

A client computer on your internal network that has ServiceCEO installed. This instance of
ServiceCEO should be dedicated to the remote user.

•

A GoToMyPC account or a LogMeIn account.

Once the tool is configured, the remote user can login to the dedicated client computer on the LAN. From
the computer on the LAN, they can log into ServiceCEO.
Note that you could use this method for more then one user; however, you would need to have one
dedicated client computer on your local network for every remote user.
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Caution:
Insight Direct does not support setting up third-party remote configuration tools. With this in
mind, we recommend you purchase a fully-licensed version of GoToMyPC or LogMeIn so that if
you do experience any connection problems, you will be able to get the support you need.

Advanced Remote Connectivity - Virtual Private Networks
For businesses with several remote users (less that 10) who need to connect to ServiceCEO, your best
option is to set up a Virtual Private Network (VPN) with a firewall. If you have more then ten users, we
recommend you investigate using Terminal Services, as detailed in the Expert Remote Connectivity
section.
To set up a VPN, you will need to perform the following steps:
1.

Purchase and Setup a Firewall Appliance that Includes a VPN Gateway and VPN Client
Software. Buy a firewall appliance for the appropriate amount of remote users that will need to
connect to ServiceCEO.
Two products we recommend:
o
o

Netgear FVS114 ProSafe VPN Firewall 8. A good VPN gateway for up to eight users.
If you need to connect more than eight users, consider a more advanced model from
Netgear, such as the FVS124G (which handles 24 remote users).

In addition to Netgear, Cisco and SonicWall make comparable firewall appliances with similar set
up procedures.
We strongly recommend that before you purchase any firewall appliance, you and any technical
administrators in your company read the manuals for these products before you make your
purchase. The are typically available for free on the company's website.
2.

Get a static IP Address. Contact your DSL provider or Internet provider and ask for a static IP
address. An IP Address that doesn't change enables you to configure your remote computers so
that remote users will be able to consistently connect to the VPN.

3.

Configure the VPN Gateway. Install and configure the firewall and VPN gateway, and connect
both to your network.

4.

Configure All Remote Computers. Set up the VPN client software (included with the firewall
appliance) on every remote computer that will need to access ServiceCEO.
Caution:
All remote client computers should have a firewall enabled. At the very least, you can use the
Windows firewall with an exception for SQL Server. For details, see the Windows XP Firewall
section of the Troubleshooting a Network Configuration topic.

When configuring any of the above items, please follow the directions provided with the firewall
application. If you feel uncomfortable setting up the VPN and/or firewall, we recommend you contact a
network support consultant who has experience with VPNs and firewalls.
Once you have the VPN up and running, your remote users should be able to access the database server (or
PC) running the ServiceCEO database. After you have confirmed that remote users can access network
resources via the VPN, the remote user will use the Database Connect tool to point to the database server,
just as if they were working on your companies' LAN. For details, see the Connecting the Client to the
Server section.
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Expert Remote Connectivity - Terminal Services
Businesses with many remote users who need to regularly access ServiceCEO with heavy workloads (but
have VPN and/or network latency issues) can set up a Windows 2003 Server running Terminal Services.
Terminal Services (TS) is a component of Microsoft Windows operating systems (both client and server
versions) that allows a user to access applications or data stored on a remote computer over a network
connection. For more on Terminal Services, please see Microsoft's Terminal Services homepage.
Client computers will use Remote Desktop Connection (RDC) - software available in most 32-bit versions
of Windows - to connect to a server running Terminal Services.
When should you consider using Terminal Services? If your company has one or more of the following:
•

More than five remote users who have a heavy ServiceCEO workload on a daily basis.

•

Slow ServiceCEO performance over a WAN. TS is dramatically faster then a typical WAN
connection because it sends less data over the network.

•

Remote users that are experiencing problems interacting with QuickBooks®.
Note:
Some QuickBooks problems can be solved by reading and following the QuickBooks
Deployment Best Practices White Paper tips for maximizing QuickBooks integration
efficiency and performance. It is located in the ServiceCEO Best Practices Library of
the Member Center.

•

No fast DSL or T-1 connections that connect the remote users to the ServiceCEO server. For
example, there are DSL providers that offer only 256K lines. TS is faster because it sends less data
over the network.

•

A desire to ease the remote office set up. Once you have configured TS, adding additional remote
users takes less than one minute per user (assuming the remote office has a DSL line).

•

A desire to offer additional remote capabilities to remote users (such as easy access to Microsoft
Outlook® e-mail accounts and fileservers).

•

A need for the security and user roles built into TS with Active Directory.

•

A need to instantly shut off access to ServiceCEO to remote users.
Caution:
The intended audience for these instructions is a network professional. If you are uncomfortable
with Terminal Services or do not understand it, we recommend you contact a local Network
support consultant who has experience with TS and firewalls.

Setting up Terminal Services will require the following:
1.

A dedicated server running the Windows 2003 Operating System. Since multiple users will be
using this server, you will need at least 2 GB of RAM. If more than 5 users will be using TS, this
server will need 2 CPUs. You should also protect this server with a Firewall appliance.

2.

A TS Client Access License (CAL) for every user that will be accessing ServiceCEO remotely.

3.

Correct TS configuration. Windowsnetworking.com has a helpful article that describes this
process on their website.

4.

Installation of ServiceCEO on TS. This installation is straight forward; you just need to make sure
you have the right permissions on the TS. See your TS documentation for details.
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Managing your Database
Toggling Between Databases
To switch between two databases, you need to perform the following two steps:
•

Backup the current database

•

Restore another database

Note that these steps only apply to when using SQL Server Express. If you are running the full version of
SQL Server (i.e., the Workgroup or Standard editions), please consult your SQL documentation or search
the Knowledgebase in the Insight Direct Member Center.
Caution:
Restoring a database automatically overwrites the current database. Make sure that you have
backed up your current database before you restore another database or your will lose your
current data.
An example of when and why you might want to switch between two databases is when learning about
ServiceCEO. We recommend that you use a demo/training database from the Database Library to test out
configuration options for your business before you toggle back to your live database for your actual
configuration.
Caution:
Make sure that all users have exited ServiceCEO before you do perform any database
management activities.

Installing a New Database
To install a new, blank database, you need to run the Database Setup Wizard. For details, please see the
Database Setup Wizard section. You can run this application from the Start menu.
Caution:
If you have not yet backed up your current database, do so now. See the Backing up the Database
section for details. Once you click Yes in this dialog box, your current database will be deleted.

Tip:
If you are new to ServiceCEO, we highly recommend that you get familiar with ServiceCEO by
restoring a demo/training database from the Database Library before you start running your
business on your live database.
On the Install Database page of the Database Setup Wizard, select Blank Database.
When the Database Setup Wizard closes, the blank database is loaded into ServiceCEO; you can now start
configuring it. See the Configuration Overview section to get started.
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Backing up the Database
Since ServiceCEO contains so much valuable data, it is wise to periodically backup the database to protect
yourself from data loss in the event of system failure, theft of computer equipment, or other unforeseen
accidents. To protect you from any significant data loss, ServiceCEO lets you backup your entire database.
Tip:
You should regularly backup your database in order to minimize the possibility of losing any
data. We also recommend that you keep this backup file for at least six months, just in case you
need it.
Backing up a database saves your data in a backup file with a .scb extension. This file type stands for
ServiceCEO Backup. Note that only .scb files can be used as a ServiceCEO database.
Tip:
Starting with ServiceCEO 6.1, you can back up a database to anything that maps to a drive letter
(CD Drive, USB port, etc.)

Caution:
Your computer may recognize the ServiceCEO backup file as a .zip file, not a .scb file. If this
occurs, do not be alarmed - your computer has just confused two different types of file
compression. Simply change the extension of the file back to .scb to fix the problem. To rename
the file extension, right-click the file, select Rename from the pop-up list, and change ".zip" to
".scb".
Note that this solution will only work if you can see your file extensions. If you cannot see file
extensions, you must first instruct your operating system to turn them on. To do this, open
Windows Explorer. Select Tools > Folder Options. Click the View tab. Deselect the Hide
extensions for known file types check box - it should now have no visible check mark. Click
OK to display your file extensions.
To back up your database:
1.

Verify that all users are logged out of ServiceCEO.

2.

On the server computer, select Start > Programs > ServiceCEO > ServiceCEO Backup or
Restore. The ServiceCEO Backup and Restore Wizard appears.
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3.

Click Next. The Backup or Restore Database screen appears.

4.

Select the Backup a ServiceCEO database option button is selected.

5.

Click Next. The Backup File Location screen appears.
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6.

ServiceCEO's default backup location is C:\Program Files\ServiceCEO\backup\. If you would
like to change this location:
•

Click Browse. A dialog box appears.

•

Browse to the location that you want to save the backup file.

•

Click OK. The file you selected will appear in the destination drive or directory field.

Note:
Your backup file will automatically be named with the date and time on which the backup is
being run. For example, if you ran a backup on November 10th, 2006 at 11:30 AM, the backup
file would be named ServiceCEO_Backup_11-10-2006 11_30- AM.scb.
7.

By default, the backup will be made based on your default Database Connect settings. If you want
to change the location on which you want to make the backup, perform these steps:
•

Clear the Use Default Settings check box.

•

From the Server drop-down list, select the server on which the database you want to
backup is located.

•

Select the name of the database that you want to backup from the Database drop-down
list.

8.

Click Next. The database backup begins. It may take a few moments to complete the backup;
please be patient. When complete, the finish page appears.

9.

Click Finish. The ServiceCEO Backup and Restore dialog box closes. Your database is now
backed up!

To learn how to schedule automatic backups, please search for the "Scheduling Automatic ServiceCEO
Database Backups" solution in the Member Center's knowledgebase.
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Restoring a Database
At any point, you can restore a backup database file (.scb file) into ServiceCEO.
Caution:
Restoring a database will automatically overwrite and erase the current database. Make sure that
you have backed up your current database before you continue. See the Backing up the Database
section for details.
To restore a database:
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1.

Select Start > Programs > ServiceCEO > ServiceCEO Backup or Restore. The ServiceCEO
Backup and Restore Wizard appears.

2.

Click Next. The Backup or Restore Database screen appears.
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3.

Select the Restore a ServiceCEO database option button.

4.

Click Next. The Restore File Location screen appears.

5.

Select the database you want to restore by following these steps:
•

Click Browse. A dialog box appears.

•

Browse to the location that you want to save the backup file.

•

Click OK. The file you selected will appear in the Select a ServiceCEO database to
restore field.

Caution:
Only files with a .scb extension can be used as ServiceCEO databases. This file type stands for
ServiceCEO Backup.
However, your computer may recognize the ServiceCEO backup file as a .zip file, not a .scb file.
If this occurs, do not be alarmed - your computer has just confused two different types of file
compression. Simply change the extension of the file back to .scb to fix the problem. To rename
the file extension, right-click the file, select Rename from the pop-up list, and change ".zip" to
".scb".
Note that this solution will only work if you can see your file extensions. If you cannot see file
extensions, you must first instruct your operating system to turn them on. To do this, open
Windows Explorer. Select Tools > Folder Options. Click the View tab. Deselect the Hide
extensions for known file types check box - it should now have no visible check mark. Click
OK to display your file extensions.
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6.

By default, the restore will be performed on the database as entered in your default ODBC
settings. If you want to change the location where you are restoring the database, perform these
steps:
•

Clear the Use Default Settings check box.

•

From the Server drop-down list, select the server on which the database you want to
backup is located.

•

Select the name of the database that you want to backup from the Database drop-down
list.

7.

Click Next. The database restore begins. It may take a few moments to complete the restore;
please be patient. When complete, the Finish page appears.

8.

Click Finish. The database is restored!

The Database Library
The Database Library is a repository, located in the Insight Direct Member Center, where you can
download databases that have been pre-configured to meet the needs of a number of industries.
There are two types of databases in the Database Library:
•

Training Databases

•

Starter Databases

Training Databases
Training databases are designed to for you to practice using and configuring ServiceCEO before you use it
to run your live business.
Training databases are pre-configured with "dummy" practice data relevant to a particular industry,
including customers, jobs, employees, inventory parts, etc. In addition, all of the Lists and Options have
been configured with industry-relevant settings. For example, the Pest Control database contains "Termite
Treatment" and "Fungus Treatment" services.

Starter Databases
A starter database, in contrast to a training database, contains no practice data. Instead, it contains a number
of pre-configured settings (as defined in Tools > Lists and Tools > Options) so that your configuration
work is minimized.
It is meant for two things:
1.

To start running your business. You can start entering customers, jobs, etc. but can keep the
implementation (the selection of the Tools and Options) to a minimum.

2.

You can practice using ServiceCEO with a minimum of data.

Downloading a Database
To download a training or starter database:
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1.

Log into the Insight Direct Member Center.

2.

Click Database Library. The Database Library appears.
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3.

Find your industry or the industry closest to yours.

4.

Click on either the industry name or the link in the download column.

5.

Follow the instructions to save the file to your computer.

6.

Once the file is on your computer, follow the instructions in the Restoring a Database section to
restore the database.

7.

Login to the database using the Administrator/Administrator user name/password combination.

Purging a Database
Once you have configured one of the ServiceCEO training databases for your company, technical support
can delete your practice customers and the associated data so you may begin using a clean database without
losing your configuration settings.
Caution:
The database purge is designed to remove ALL customers, jobs, quotes, etc. entered into your
database. If you enter any real customers, jobs, quotes, etc. prior to the purge, these will also be
deleted along with the practice information.
Technical support will run a database purge utility to delete all:
•

Customer records, including custom fields

•

Jobs, schedules, and projects

•

Estimates

•

Quotes

•

Invoices

•

Payments

•

Dispatch Board assignments

•

Tasks

•

Service Contracts

•

Equipment

•

All customer, job, and employee notes

•

Time Cards

•

Paychecks

•

Purchase Orders

•

Inventory adjustments

•

Stock Levels
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Your database will retain the following information:
•

Employee records (but not employee notes)

•

All lists found in Tools > Lists

•

All settings in Tools > Options

•

Vendor records and parts catalogs

•

Call Center scripts

•

Quoting Wizard configurations

•

Report list

•

Customized reports

•

Form and note templates

•

Employee work hours

•

Custom employee fields

•

Dispatch Board views

Any deposits or sales you have exported to QuickBooks will remain in QuickBooks, even though they have
been deleted from ServiceCEO.
To purge your database, upload your database to the Insight Direct Technical Support department.

Upgrading ServiceCEO
Upgrading ServiceCEO is an easy process. Basically, you just need to download the client installer file, run
it, and then reboot your computer. However, note that if you are running ServiceCEO on multiple
computers, you will need to run the installer on all client computers running ServiceCEO. If you do not,
and multiple users attempt to log into ServiceCEO using different versions of the software, errors will
result.
You can download the upgrade file from the Insight Direct Member Center. For a full description of the
new features in the upgrade, please read the ServiceCEO Release Notes, also located in the Member
Center.
Note:
When upgrading, you will only need to run the Client installer. You will not need to run the
Database Management Tools again unless instructed to do so.
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1.

Login to the computer you want to upgrade as the Windows Administrator.
Note that if you are running Microsoft Vista , you can be logged in as a regular user, but will need
to enter the Administrator credentials before ServiceCEO will be installed.

2.

Log into the Member Center.

3.

Click the Download and Install ServiceCEO Upgrades link. The Upgrade Installer page
appears.

4.

To download the ServiceCEO Client, click the appropriate Download File button. A File
Download dialog box appears.

5.

Click Save. A Save As dialog box appears.
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6.

Navigate to your desktop and click Save. The upgrade file will be downloaded to your desktop.
Tip:
Rather then downloading the installer from the Internet for every computer, you may want to
save the upgrade installer in a common folder on your internal network. Everyone running
ServiceCEO can then copy the installer from the network to their computer for installation.

7.

Double-click on the upgrade file. The InstallShield Wizard dialog box appears.
Note:
If any users are logged into ServiceCEO when the database upgrade begins, the Show Connected
Users dialog box appears. Since no users can be logged into the program when the database is
being upgraded, select every user and click Disconnect. See the Show Connected Users section
of the ServiceCEO Help System for details.

8.

Click Next. ServiceCEO will recognize that you already have ServiceCEO installed and will start
to upgrade your files. When the upgrade is completed, a Finish screen appears.

9.

Click Finish. ServiceCEO has been upgraded!

10. Login to ServiceCEO. A dialog box appears, informing you that you need to upgrade your
database. If you are running SQL Server Workgroup or Standard edition, you may be prompted to
enter your SA password.
11. Click Yes. The Database Validator appears and automatically starts running. The Database
Validator is a tool that runs a number of tests on your database before it is upgraded to ensure that
there is no data corruption. For details, please see the Database Validator topic.
12. If the Database Validator finds no errors, or if you click Upgrade after the Database Validator
results appear, your database will be upgraded to the new version of ServiceCEO. For some
upgrades, this may take some time while database scripts run in the background, making your
database compatible with the new version of ServiceCEO. Please be patient while the upgrade
process runs.
13. When the database upgrade is completed, the ServiceCEO login page will appear. Log in to the
program in the normal manner.

Tip:
To see the version of your software, select Help > About. The About ServiceCEO dialog box
appears. The version number is displayed on the Client Software Version line.
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The Database Validator
The Database Validator is a tool that runs a number of tests on your database to ensure that there are no
problems or data corruption. Running the Database Validator will ensure that any potential problems are
caught and fixed as soon as possible.
You can run the Database Validator can be run in two different ways:
1.

Before running any upgrade file. Upgrading ServiceCEO will automatically run the Database
Validator before upgrading the database.

2.

As a standalone program. At any time, you can run the Database Validator by selecting Start >
All Programs > ServiceCEO > Database Validator. Click Start from the Database Validator
window. Make sure that nobody is logged into ServiceCEO before you start it.

However you run it, the Database Validator dialog box will appear. It will take a minute for the tests to run.
After the tests have run once, the Database Validator will attempt to fix all tests that failed and then will run
all of the tests again. When complete, a results screen will appear. Click Details to see detailed results,
including a listing of tests that did not pass as well as any tests that found an issue that was automatically
fixed.

If you are upgrading your database, and no errors are found, the Database Validator automatically closes
and the database upgrade begins.
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Failed Tests
Each test is assigned a severity. If any tests failed, you should view the detailed results and perform one of
several actions, depending on the number and severity of errors that the Database Validator finds. The
severities are:
•

Minor Errors. Minor tests are designed to catch small inconsistencies in your data, such as
corporate customers with a First Name/Last Name (rather then a single company name). These
tests are generally informational in nature; note of these issues will affect the day-to-day running
of your business. You can upgrade a database with minor errors without any issues.

•

Major Errors. Major tests - indicated by a yellow caution sign - are issues that could affect some
areas of the program. While you will be able to upgrade your database without any problems, we
recommend you contact Technical Support to resolve these issues at your earliest convenience.

•

Critical Errors. Critical tests are indicated by a red warning sign. Critical tests catch problems
that could affect your business; for that reason, we do not recommend that you upgrade a database
with any open critical issues. We highly recommend that you contact Technical Support to resolve
any critical issues before continuing to work in ServiceCEO.

Note that you can double-click the name of any test in the details pane to display the database records that
were affected by this issue.
Other steps you can perform in the Database Validator are:
•

Details/Hide Details. This button expands and contracts the Database Validator screen so that you
can see the individual test that failed.

•

Help. This button displays the Database Validator help, where you can read an explanation of the
Database Validator tests and what they mean to your data.

If you are upgrading your database, please be sure to read the Upgrading ServiceCEO topic.

Training Materials
Training Overview
Insight Direct's relationship with you doesn't end when you purchase our products!
We believe in our products and their ability to help you succeed. We stand behind what we say it will do
for your business. We have a team of professionals - software developers, training experts, technical and
sales representatives - who share one common goal: the success of your business. To that end, we've
created a number of resources for you to help you get ServiceCEO up and running in no time, including:
•

Live Online Classes

•

Recorded Videos

•

Additional Member Center Resources

Training Classes
While experience is often the best teacher, you don't have to learn about ServiceCEO the hard way. Our
interactive, online classes give our customers a place to get their questions answered by experts at Insight
Direct and to learn from other ServiceCEO customers.
Our training classes are open to Membership Plan members to help them get up and running quickly.
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Live Online Training
Insight Direct offers at least three or four live training classes every week day! Any current member with a
computer and phone is invited to attend. Feel free to take as many classes as you need, as often as you like.
The current class schedule is located at www.insightdirect.com/classes.html. For a complete description of
every class, visit http://www.insightdirect.com/classdesc/.
To attend a class, log into the Member Center and click Attend Live Training Classes.

Recorded Videos
We recognize that you are busy. To help those of you who may not have time to attend one of our live
training classes, we've generated a series of pre-recorded training videos. You can access these videos at
anytime.
To watch a pre-recorded video:
1.

Log into the Member Center in the usual manner.

2.

Click the Watch Pre-Recorded Training Video link to view the current list of classes.

3.

To run the video, perform one of the following actions:
o

Click the name of the video you want to watch. A new window will appear, running the
video you want to view.

o

To download the video and run it from your local computer, click the appropriate
Download link. A File Download dialog box appears. Click Save. A Save As dialog box
appears. Navigate to your desktop and click Save. The video will be downloaded to your
desktop.

Downloaded videos are compressed files with a .RAR extension. You will need to extract the video file
before you can run it. Once extracted, double-click the file with the .HTML extension to run the video. If
you do not have a file compression tool, please download WinRAR from the Support Utilities section of
the Support tab of insightdirect.com.
Tip:
If you are accessing the Internet via a dial-up connection, we recommend you download the
video to your computer to avoid performance issues.
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The Member Center
To access the Member Center and receive technical support, you must have an active Membership Plan.
The Member Center offers many useful features:
•

Solutions Knowledgebase. The online Solutions Knowledgebase is a searchable database
containing hundreds of solutions to common ServiceCEO problems and suggestions for handling
common issues. Click Find Solution to search for your issue.

•

Software Upgrades. Download and install the latest ServiceCEO upgrades to keep your software
current with the latest ServiceCEO innovations. Click the Download ServiceCEO Upgrades and
Full Installers link.

•

Support Ticket Management. Customers with a support plan can submit Support Tickets to our
Technical Support department. In addition, you can view and attach comments to any of your past
and current Support Tickets as you interact with our Technical Support Specialists.

•

Discussion Boards. An online forum where you can post questions and comments to the rest of
the ServiceCEO community. These forums can be extremely useful to help you work though
ServiceCEO workflow issues and concerns. Click the Discussion Boards link.

•

Training Databases. You can download and use any database in our database library. These
contain both training databases as well as blank databases, both configured to many specific
service industries. See the Database Library section for details.

•

Crystal Reports Library. You can download a number of reports, created by Insight Direct or
other ServiceCEO users, for your own personal use.

•

Best Practices Library. A series of documents with detailed ServiceCEO best practices and
procedures, including security and networking recommendations.

•

Documentation. The ServiceCEO Help System contains everything you need to configure, setup
and use ServiceCEO. You can access it in two ways:
•

When logged into ServiceCEO, press F1.

•

Online at http://support.insightdirect.com/help/serviceceo.htm

Logging into the Member Center
To log in to the Member Center:
1.

Open the Insight Direct Support page at http://www.insightdirect.com/support.html.

2.

Click the orange Log into Member Center button. The Member Center Login page appears.

3.

Type your e-mail address into the E-mail Address field.

4.

Type your password address into the Password field.
Tip:
If you do not have a password, or have forgotten or misplaced your current password, click Click
Here. The Forgotten Your Username or Password page appears. Fill in the fields with the
appropriate information and click Send. Insight Direct will e-mail you a password for the
Member Center.

6.

Click Login. The Welcome to the Insight Direct Member Center page appears.
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Technical Support
If you run into any problems with ServiceCEO, our Technical Support Specialists can quickly resolve your
questions in three ways:
•

Support Tickets. The fastest method of receiving technical support is to submit a Support Ticket
online via the Member Center.
Tip:
All inquiries (Support Tickets) submitted online - via the Member Center - will be handled first.
Tickets submitted via the telephone will be handled, after online inquires, in the order in which
they were received.

•

Telephone. The dedicated Technical Support Line is (617) 557-4898. Please do not call the main
Insight Direct number (800-471-4200) as the support staff does not have access to this line.

•

Remote Assistance. With your permission, our support personnel can log into your computer and
fix your problems directly. This requires a small software utility to be downloaded and installed.
Note:
You must have an active Membership Plan in order to obtain technical support. Technical
support minutes are separate from your Membership Plan; you must purchase minutes in order to
receive assistance. An active Membership Plan is required to receive technical support because
you may need access to the materials in the Member Center (ServiceCEO software updates,
training materials, Knowledge Base articles, etc.) in order to fix your issue. Support Minutes
never expire as long as you have an active Membership Plan; however, if your Membership Plan
does expire, your Support Minutes also expire.

Insight Direct's Technical Support policy is located online at http://www.insightdirect.com/supporttraining/technical-support/policy/.

Logging into ServiceCEO
To access ServiceCEO for the first time, you will use the administrator account. This account provides you
with the security rights to all features, lists, and options throughout ServiceCEO's system. The default
administrator user name and password are:
•

User name: Administrator

•

Password: Administrator

You will not be able to change the Administrator user name. However, to protect your data, we highly
recommend that you change the Administrator account password after you have created your own database.
For details on changing passwords, see the Managing Users section of the ServiceCEO Help System for
more information.
To log into ServiceCEO:
1.
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2.

Type your assigned user name in the User Name field.

3.

Type your password in the Password field. For additional security, when you type your password,
it will appear as asterisks rather then characters.

4.

Click OK. ServiceCEO will open.

If the username or password is entered incorrectly, an error message will appear indicating in which field
the problem occurred.
Tip:
If ServiceCEO is not automatically maintaining a four-month active period, an active period
dialog box may appear from time to time when you launch the application. When these appear,
OK to extend the active range by one month or select the Automatically maintain 4-month
‘Active Period’ check box. See the Defining Active Period section of the ServiceCEO Help
System for details.
Caution:
If you are not an administrator, someone with security rights must assign you an active user name
before you can access ServiceCEO.
The information that is displayed to a particular user in ServiceCEO will depend on their user rights. See
the Establishing Security Rights section for more information.
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Activation Codes
ServiceCEO requires that a valid activation code be entered in order to use the application beyond the 14day trial period. All new users have these 14 days to use ServiceCEO before you need to enter your
Activation Code. While in the trial period, an expiration warning dialog box may appear, reminding you
how many days are remaining before you must activate ServiceCEO. You can contact Insight Direct at any
time to get a new Activation Code.

Requesting and Entering an Activation Code
You must be logged into ServiceCEO as the administrator to request or enter an activation code. To request
and/or enter an Activation Code:
1.

Select Help > Enter License Codes. The Activation Code dialog box appears.

The Company Name and Postal Code fields are pulled from the Company Information (as defined when
selecting Tools > Options > Company Information in ServiceCEO) and are not editable in the Activation
Code dialog box. If you want to edit them, please do so before you submit your request.
The rest of the steps vary depending on if you are connected to the internet or not:
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If you are connected to the Internet
If you are connected to the internet, you can request a new activation code via e-mail. However, note that
the Challenge Code submit is good for 24 hours. If you have not entered an Activation Code after 24 hours
have passed since requesting one, you will need to submit a new online request.
2.

Click Submit Request On-Line. A browser appears with your information defaulted into it.

3.

Verify this information is correct. If it is not, correct it now.

4.

Click Submit. Your request has been submitted to Insight Direct.

5.

You will receive an e-mail shortly with your Activation Code. Type the activation code you
receive into the Activation Code fields of the Activation Code dialog box.

6.

Click Enter Codes. The Activation Code dialog box closes. Your code(s) are now active.

If you are not connected to the Internet
If you do not have internet access, you can get an activation code via the telephone. To do so:
2.

Follow the steps in the Requesting and Entering an Activation Code section, above.

3.

Call Insight Direct at (617) 557-4898.

4.

Provide the Insight Direct Support Representative the code displayed in the Challenge Code field.
The support representative will take this code and generate your Activation Code.

5.

Type the activation code you receive into the Activation Code fields.

6.

Click Enter Codes. The Activation Code dialog box closes. Your code(s) are now active.
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Glossary
#
.NET: "Dot Net" is a Microsoft operating system platform that is designed to hide the boundaries between
applications and the Internet. In other words, .NET will enable you to seamlessly connect to many
different computers and services that will exchange and combine objects and data, instead of
interacting with an application or a single Web site. Microsoft envisions this new technology as
revolutionary, enabling Internet users to integrate fax, e-mail and phone services, centralize data
storage and synchronize all of a user's computing devices to be automatically updated. They
envision that software will be rented as a hosted service over the Internet, users will have access to
their information on the Internet from any device, anytime, anywhere. .NET depends on four
Internet standards: HTTP, XML, SOAP, and UDDI.

C
Client Computer: Any computer running ServiceCEO that is not hosting the ServiceCEO database. All
client computers must connect, via a network, to the server in order to see the ServiceCEO
database.
CPU: Short for Central Processing Unit.

D
DNS: DNS (Domain Name System/Service) is an Internet service that translates domain names into IP
addresses. Although domain names are easier to remember, the Internet communicates using IP
addresses. Thus, when you use a domain name, a DNS must translate the name into the
corresponding IP address. For example, the domain name www.insight.com might translate to
154.211.12.4.
DSL: Short for Digital Subscriber Line. DSLs carry data at high speeds over standard telephone wires.
With DSL, data can be delivered at a rate of up to 1.5 mbps.
DSN: Short for Data Source Name. A DSN connects to a database through an ODBC driver. The DSN
contains database name, directory, database driver, UserID, password, and other information.
Once you create a DSN for a particular database, you can use the DSN to retrieve information
from that database.

G
Gateway: A network node that serves as an entrance to another network
GB: Short for Gigabyte.

H
HTML: Short for HyperText Markup Language. Much of the web is written in HTML or one of its
derivatives.
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I
IIS: IIS (Internet Information Server) is IIS is Microsoft's business-class Web server. Although Apache
boasts more total worldwide installations than IIS, many corporations choose IIS as their Web
server because it is supported by a commercial organization. Some have criticized IIS in the past,
though, for its alleged security weaknesses. IIS has improved over the years, supports many Web
standards including SSL, and integrates well with other Microsoft Web technologies such as
FrontPage. An administrator can manage IIS through a graphical console, the Internet Services
Manager.
IP Address: A numeric identifier used by computers to transmit and receive information over a network
(such as the Internet). IP addresses are displayed as four numbers separated by periods; for
example, 7.155.23.211 is a valid IP address.
ISP: Internet Service Provider, a company that provides access to the Internet. For a monthly fee, the
service provider gives you a software package, username, password and access numbers. Armed
with this data, you can then log on to the Internet via a modem and browse the Internet.

L
LAN: Short for Local Area Network. A computer network that spans a relatively small area. Most LANs
connect workstations and personal computers.

M
MSDE: Microsoft Desktop Engine. The MSDE was the default database server for all versions of
ServiceCEO previous to 6.1.

N
Named Instance: A second installation of SQL Server on a computer.

O
ODBC: Short for Open DataBase Connectivity. ODBC is a standard database access method developed by
Microsoft . ODBC enables access to any data from any application, regardless of which database
management system (DBMS) is handling the data.
OS: Short for Operating System

R
RAM: Short for Random Access Memory.
Router: A device that forwards data between networks. A router is connected to at least two networks,
commonly two LANs or WANs, or a LAN and its ISP's network. Routers are located at gateways,
the places where two or more networks connect.

S
Server Computer: The computer hosting the ServiceCEO database. As opposed to a "client" computer,
which is a user computer connecting to the ServiceCEO database on the server computer.
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ServiceCEO Enterprise: ServiceCEO Enterprise is an expanded version of ServiceCEO with enhanced
functionality designed to help you to manage an organization with multiple locations. The main
difference between ServiceCEO and ServiceCEO Enterprise is the company structure ServiceCEO Enterprise has a hierarchical organization model, starting at the top with the
Organization, and then moving down into Regions, Branches, and Zones. Each organization can
have an unlimited number of regions or branches.
SMTP: SMTP (Simple Mail Transfer Protocol) is a protocol for sending e-mail messages between servers.
Most e-mail systems that send mail over the Internet use SMTP to send messages from one server
to another.
SQL Server: A database management system. All of ServiceCEO's functionality is run via SQL Server.
SSMS: SSMS is short for SQL Server Management Studio. For more on SSMS, please point your browser
to http://www.microsoft.com/downloads/details.aspx?familyid=C243A5AE-4BD1-4E3D-94B85A0F62BF7796&displaylang=en

T
TCP: Short for Transmission Control Protocol. The most common transport layer protocol used on
Ethernet and the Internet. TCP is the connection-oriented protocol built on top of Internet Protocol
(IP) and is nearly always seen in the combination TCP/IP (TCP over IP). It adds reliable
communication and flow-control and provides full-duplex, process-to-process connections.
TCP/IP: Short for Transmission Control Protocol over Internet Protocol. TCP/IP is the standard Ethernet
protocol. TCP/IP was developed for internetworking and encompasses both network layer and
transport layer protocols. While TCP and IP specify two protocols at specific protocol layers,
TCP/IP is often used to refer to the entire DoD protocol suite based upon these, including telnet,
FTP, UDP and RDP.

U
UAC: Short for User Account Control. A security feature in Microsoft's Windows Vista operating system
that requires you to actively enable certain actions before they are performed.
UDP: Short for User Datagram Protocol, UDP is one of the core protocols of the Internet protocol suite.
URL: Uniform Resource Locator (URL) is a string of characters that refers to a web page on the Internet.
For example, http://www.serviceceo.com/ is a URL.

V
VPN: Short for Virtual Private Network. A computer network which uses a public network to transfer
information using secure methods. For example, you could set up a VPN between your home
office and your business office using security and encryption with the Internet as your transfer
pipe.

W
WAN: Short for Wide Area Network. A computer network, typically connected through the Internet, that
spans a relatively large geographical area.

55

Installation Guide

56

Index

Index
A

Installing ServiceCEO, Database 2

Advanced Remote Connectivity - VPN 32

Installing SQL Server 2005 16

B

Installing the ServiceCEO Client 11

Backing up the Database 35

Installing, New Database 34

Basic Remote Connectivity 31

Intstall, Client 11

C

L

Client, Connecting to the Server 26

Library, Database 40

Client, Installing the 11

M

Configuring a Network 25

Member Center 47

Connecting the Client to the Server 26

N

Connecting to ServiceCEO from a Remote
Location 31

Network Configuration 25

Connection, Database 26
Connection, Troubleshooting a Network
Connection 27
Contacting Technical Support 48

Network, Troubleshooting a Connection 27
O
Online Training Classes 45
Overviews
Network Configuration 25

D

Training 45

Database
Backing up the Database 35
Installing a New Database 34
Restoring a Database 38
Toggling between Databases 34
Database Connect 26
Database Management Tools 7
Database Purge 41
Database Setup Wizard 11
Database Validator 44
Database, Starter/Training/Demo 40
Demo Database 40
E
Expert Remote Connectivity 33
I
Install, Database Setup Wizard 11
Install, with Full Version of SQL Server 15
Installation 2

P
Purge, Database 41
R
Remote Connection Tools - Basic 31
Remote Connectivity, Advanced (VPN) 32
Remote Connectivity, Basic 31
Remote Connectivity, Expert (Terminal
Services) 33
Remote Location, Connecting to ServiceCEO 31
Restoring a Database 38
S
Server, Connecting from the Client 26
ServiceCEO, Installing 2
ServiceCEO, Upgrading 42
Setting up a Database 2
Setup, Database Setup Wizard 11
SQL Server 2005, Installing 16
SQL Server, Configuring 2005 for 20+ Users 23

Installing ServiceCEO 2
57

Installation Guide

SQL Server, Full Version 15

Training 45

SQL Server, Standard Edition 15

Training Database 40

SQL Server, Workgroup Edition 15

Training, Online 45

Standard Edition, SQL Server 15

Troubleshooting a Network Configuration 27

Starter Database 40

U

T

Upgrading ServiceCEO 42

Technical Support, Overview

V

Contacting 48

Validator, Database 44

Member Center 47

VPN 32

Terminal Services 33

W

Toggling between Databases 34

WAN, Connecting to ServiceCEO 31

Tools, Database Management 7

Workgroup Edition, SQL Server 15

58

