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Implementation Checklist 
The Implementation Checklist is designed to help you setup ServiceCEO to work with 
you. It lists the lists and options that you need to configure, at a minimum, before starting 
to use ServiceCEO to run your business. 

The Implementation Checklist is available in several places: 

• Online as a PDF file. This is the clearest printable version. 

• The ServiceCEO's Help System Table of Contents. 

• The Implementation Checklist section below. 

• The Implementation Training Series Video Library area of the Member Center.  

Defining Company Information 
The first step in configuring ServiceCEO is to define your company information. 

 

Note: 
If you are running ServiceCEO Enterprise, the Company Information area and 
button will be called Company Structure. For more on ServiceCEO Enterprise, 
please read the ServiceCEO Enterprise Configuration Guide. 

To define your company information: 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Company Information from the Categories bar. The Admin - Company 
Information dialog box appears. 
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3. Type the name of your company into the Name field. Note that your company 
name cannot contain more than 50 characters.  

4. Type the name and information of the main company contact into the Contact 
section. 

5. Type the address of your company's main location into the Address section. 

 

Caution: 
Your Activation code is linked to the company name and ZIP Code. If you edit 
the Name or ZIP Code fields, you will need to get a new Activation code. See 
the Activation Code section for details. 

3. Type your main phone number into the Phone field. 

4. Type your main fax number into the Fax field, if applicable. 

5. Type your company's main e-mail address into the E-mail field. Note that if you 
do not define an e-mail address here, you will not be able to e-mail work orders to 
your employees. For details, see the E-mailing a Work Order to an Employee 
topic of the ServiceCEO Help System. 

6. Type your company's website address into the Web site field. 
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7. Type the percentage of profits the company gets from its franchisees, if any, into 
the Royalty Rate 1 and 2 fields. 

8. Type any information you would like into the five Custom Fields. Note that you 
cannot edit the names of these custom fields. 

9. If you are using Inventory Tracking, select the Stock Location check box to make 
the company a stock location. See also the Defining Inventory Management 
Options topic. 

10. Type any relevant notes into the Notes field. 

11. You can insert your company logo into the Logo box. For more, see the Inserting 
a Logo topic. 

12. You can integrate ServiceCEO with an accounting package by selecting the 
Enabling Accounting Integration check box. See the Integrating Accounting 
section for more information. 
If you are not integrated with a third-party Accounting application, you can type 
the name of your main bank account into the Default Bank Account field. 

13. If you are using Advanced Billing, click Configure Billing Settings to setup an 
advanced billing configuration for the entire company. See the Defining Billing 
Properties topic of the ServiceCEO Help System for more. 

14. Click Save and Close.  

Defining Tax Codes 
ServiceCEO's multi-tiered tax rate functionality enables you to charge and track taxes on 
the services and products you provide. You can define up to three different tax types, 
with unlimited tax codes for each tax type. 

You do not need to enable all three tax types. For example, a company that only needs to 
charge a state tax (no city, county, or other extra taxes) would only need to enable a tax 
type named State. 

Once a tax type is defined, you can create a list of different tax codes within that tax type. 
To continue our example, the company charging state taxes would define tax codes for 
each state within which the company conducts business. 

Adding Tax Codes 

1. Select Tools > Lists > Tax Codes. The Tax Codes dialog box appears. 
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2. The Active check box will be selected by default. Deselect it if you do not want 
this tax type to appear in drop-down lists in ServiceCEO. 

3. Click the name field of the tax type you want to add. 

4. Type the name of the tax into the Name field. 

5. Click in the Tax Code List field. 

6. Click . The Tax Code List dialog box appears. In this dialog box, you define the 
tax codes for the tax type. For example, if you do business in three states, you 
would create three tax codes - one for each state. 

 

7. Click Add. A new row appears. 

8. Type a name for the new tax code. 

9. If you are using an accounting package, select the accounting vendor for this tax 
code from the Accounting Vendor drop-down list. 

10. Type the tax rate into the Tax Rate field. 

11. Deselect the Active check box if you do not want this tax code to appear on drop-
down lists throughout ServiceCEO. 

12. Repeat steps 7-11 to add more tax codes for the current tax type. 

13. Click Close. 

14. Repeat steps 2-13 to add additional tax types and codes. 
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15. Click OK. 

Editing Tax Codes 

1. Select Tools > Lists > Tax Codes. The Tax Codes dialog box appears. 

2. Click in the Tax Code List field of the tax type that includes the tax code you 
want to edit. 

3. Click . The Tax Code List dialog box appears. 

4. Make any appropriate edits. 

5. Click OK. 

6. Repeat steps 2-5 to edit additional tax codes. 

7. Click OK. The Tax Updates dialog box appears. 

 
This dialog box displays all of the taxes you've changed. The tax changes will update all 
active jobs with unlocked invoices, as described in the dialog box. 

 

Caution: 
Taxes on miscellaneous charges, Credit Note Adjustments, and Service 
Contracts will not be automatically adjusted. 

8. Click Update. 
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Deleting Tax Codes 
You cannot delete tax codes that have been used in the past. Attempting to delete a tax 
code will mark it as Inactive, meaning that you will not be able to select this tax code in 
the future. Any existing customers that are currently using the existing tax code will 
continue to do so until the tax code is manually removed from the appropriate Customer 
Address. 

1. Select Tools > Lists > Tax Codes. The Tax Codes dialog box appears. 

2. Click in the Tax Code List field of the tax type that includes the tax code you 
want to delete. 

3. Click . The Tax Code List dialog box appears. 

4. Select the name of the tax code you want to delete. 

5. Click Delete. A confirmation dialog box appears. 

6. Click Yes. The tax code is deleted. 

7. Repeat steps 4-6 to delete additional tax codes. 

8. Click Close. 

9. Click OK. 

The Zone Manager 
A zone is a user-defined geographic territory. Zones enable you to break up your 
coverage area into manageable sub-sections so that you can associate teams and/or 
employees in a particular zone with customers located in the same zone, facilitating easy 
and efficient employee dispatching. You should assign your zones in such a way that a 
single team could handle multiple jobs within a zone without difficulty (due to reduced 
travel time). 

Opening the Zone Manager 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager dialog box appears. 
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Manage by ZIP Code 
The Manage by ZIP Code tab of the Zone Manager enables you to assign zones to 
particular ZIP Codes. 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Manage by 
ZIP Code tab of the Zone Manager appears. 
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2. Filter the ZIP Code list to find the ZIP Code you want to associate with zones. For 
details, see the Zone Manager Filter section. 

3. Select the ZIP Code that you want to associate with a zone(s).  

4. Edit the ZIP Code as necessary. You can: 

o Define the City. Add or edit the ZIP Code's city in the appropriate City 
field. 

o Define the State. Add or edit the ZIP Code's two letter state code in the 
appropriate State field. 

o Define the Tax Rates. Select a state tax rate from the appropriate Rate 
drop-down lists. The tax rates that appear are defined in the Tax Codes 
dialog box; see the Defining Tax Codes section for details. 

5. Select the check box corresponding to the zone(s) you want to associate with the 
selected ZIP Codes. 

6. Click Save or Save and Close. The Optional Updates dialog box appears. See the 
Optional Updates section. 
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Manage by Zone 
The Manage by Zone tab of the Zone Manager enables you to assign ZIP Codes to 
particular zones. 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager appears. 

2. Click the Manage by Zone tab. 

 

3. Select the Zone you want to associate with ZIP Code from the Step 1 section. 

4. If you'd like, edit the zones' values. You can: 

o Define Zone Pricing. Select a zone price for the zone from the Zone 
Pricing drop-down list. For more on Zone Pricing, see the Using Zone 
Pricing topic of the ServiceCEO Help System. 

o Deactivate the Zone. Deselect the Active check box if you do not want 
this zone to appear on the zone drop-down lists throughout ServiceCEO. 
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Note: 
The Active check box for each zone is selected by default, meaning that it will 
appear on all customer and/or employee records. Deselecting the Active check 
box for existing list items will remove the list item for future records but keep it 
for those customer and/or employee records that are already using this item. 

o Describe the Zone. Edit or define a zone's description by typing a short 
definition in the appropriate Description field. 

5. Filter the ZIP Code list to find the ZIP Codes you want to associate with the 
selected Zone. For details, see the Zone Manager Filter section.  

6. Select the check box corresponding to the ZIP Code(s) that you want to associate 
with the selected zone.  

7. Edit the ZIP Code as necessary.  

8. Click Save or Save and Close. The Optional Updates dialog box appears. See the  

Assign Tax Codes 
The Assign Tax Codes tab of the Zone Manager enables you to assign tax codes to your 
zones. 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager appears. 

2. Click the Assign Tax Codes tab. 
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3. Filter the ZIP Code list to find the ZIP Codes you want to associate with tax 
codes. For details, see the Zone Manager Filter section. 

4. Select the check box(es) corresponding to the ZIP Code(s) for which you want to 
define tax codes.  

5. Select the check box(es) corresponding to each tax type(s) that you want to apply 
to the selected ZIP Codes in the step two section. 

 

Note: 
The (up to three) tax types that appear correspond to the tax types you have 
defined and enabled. For details, see the Defining Tax Codes section. 

6. Select the tax code(s) you want to assign to the ZIP Code(s) from the appropriate 
drop-down lists.  

7. Click Apply. The tax codes selected in step 6 are applied to the selected ZIP 
Codes, and will appear in the appropriate Step 1 section. 

8. Click Save or Save and Close. The Optional Updates dialog box appears. See the 
Optional Updates section, below. 
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The Zone Manager Filter 
The Zone Manager filter appears on all three tabs of the Zone Manager. 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager appears. 

2. Click the tab on which you want to define a filter. 

3. Define the filter criteria. To do so, perform one or any combination of the 
following: 

o Type the ZIP Code you want to use in the ZIP Code field. 

o Select the Zone whose ZIP Codes you want to see from the Zone drop-
down list. 

o Type the name of the city whose ZIP Codes you want to see in the City 
field. 

o Type the name of the state whose ZIP Codes you want to see in the State 
field. 

o Select the tax code whose associated ZIP Codes you want to see from the 
Tax Code drop-down list. 

4. Click Run Filter. The list will be filtered by your criteria. 

 

Note: 
The Zone Manager filter is designed to work like the filter in other sections of 
ServiceCEO: If the Filter button contains a red circle, the filter is NOT active. If 
the Filter button contains a green circle with a check mark, the filter is active. 

 

Tip: 
If you want to clear all of the values in the filter fields, select Edit > Clear 
Filters. Note that this will clear the filter values for only the current tab - the 
filter values for the other tabs will still remain as they were. 

Zone Manager Optional Updates 
The Optional Updates dialog box enables you to propagate the changes you've made in 
the Zone Manager to existing customer records. It appears when you close the Zone 
Manager whenever you have made any additions or changes in the Zone Manager. 
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This dialog box details all of the changes you've made in the Zone Manager dialog box 
and enables you distribute these changes to existing records if you want. The changes 
you've made are displayed in the upper list box. You can control how these changes are 
made to existing records in the following ways: 

• Set Zone on Customer Locations. Select this check box to change the zone for 
each customer location with the same zip code as those marked "Zone Changes".  

• Set Tax Codes on Customer Locations. Select this check box to change the tax 
code for each customer location with the same zip code as those marked "Tax 
Changes".  

• Update Charges. Select this check box to update the tax charges for all future 
jobs at customer locations with updated Tax Codes.  

To update existing records, click Update. The changes are made to your database.  

If you do not want to apply any Zone Manager changes to existing records, click No 
Update. No changes will made to existing records; only records created from here on out 
will be affected by your edits. 

Creating a Zone 
You can create a new zone from the Zone Manager. 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager dialog box appears. 
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2. Click New Zone or select Edit > New Zone. A new line appears in the zone list. 

3. Type a name for the zone in the Zone field. 

 

Tip: 
It is usually a good idea to make your Zone name as short as possible. A shorter 
name will be able to be more easily deciphered if you use the Short Dispatch Job 
Line Format, which only displays the Zone's first five letters on the Dispatch 
Board. (See the Defining Dispatch Board Options topic of the ServiceCEO Help 
System for more.) For example, if one of your zones covers Northeast Houston, 
you could use the zone name "NEHou". 

4. If necessary, select a zone price group for the zone from the Zone Pricing drop-
down list. For more on Zone Pricing, see the Using Zone Pricing topic of the 
ServiceCEO Help System. 

5. Deselect the Active check box if you do not want this zone to appear on the zone 
drop-down lists throughout ServiceCEO. 

 

Note: 
The Active check box for each zone is selected by default, meaning that it will 
appear on all customer and/or employee records. Deselecting the Active check 
box for existing list items will remove the list item for future records but keep it 
for those customer and/or employee records that are already using this item. 

6. Edit or define a zone's description by typing a short definition in the appropriate 
Description field. 

7. Click Close. The Optional Updates dialog box appears. See the Optional Updates 
section, above. 

Editing Zones 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager dialog box appears. 

2. Click the Manage by Zone tab. 

3. Make any necessary edits to the zone you want to edit. 

 

Note: 
The Active check box for each zone is selected by default, meaning that it will 
appear on all customer and/or employee records. Deselecting the Active check 
box for existing list items will remove the list item for future records but keep it 
for those customer and/or employee records that are already using this item. 
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4. Click Close. The Optional Updates dialog box appears. See the Optional Updates 
section. 

Deleting Zones 
You cannot delete a Zone with active employees and/or jobs assigned to it. You can, 
however, make it inactive by clearing the Active check box for the appropriate zone. 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager dialog box appears. 

2. Select the zone you want to delete. 

3. Click  or select Edit > Delete. A Confirmation dialog box appears. 

4. Click Yes. The zone is removed from the zone list. 

Managing ZIP Codes 
ServiceCEO can automatically fill in the City, State, Zone, and associated Tax Codes for 
every customer entered into ServiceCEO when you type the ZIP Code. To create this 
automation, you must define these items for every ZIP Code within your coverage area. 
ServiceCEO already contains a list of all of the ZIP Codes in the United States. All you 
need to do is map each ZIP Code to your tax codes and zones. For details about this 
automation, see the Defining a Customer Address topic of the ServiceCEO Help System. 

 

Note: 
Insight Direct does not have a license to distribute postal codes for other 
countries other than the United States. If you need different or additional 
ZIP/Postal Codes, you can either manually enter these codes or import ZIP 
Codes using the Data Import Wizard. From the Zone Manager, select Tools > 
Import ZIP Codes. The Data Import Wizard appears. For more information, 
read the Importing Data into ServiceCEO topic. 

Adding ZIP Codes 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager dialog box appears. 

2. Click Add New ZIP Code or select Edit > New ZIP Code. A new line will 
appear in the ZIP Code list. 

3. Type the ZIP Code in the ZIP Code column. 

4. Type the ZIP Code's city in the City column. 

5. Type the ZIP Code's two letter state abbreviation in the State column. 
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6. Select a state tax rate from the appropriate Rate drop-down lists.  

 

Note: 
The columns to the right of the City and State columns will vary depending on 
the defined tax types. See the Defining Tax Codes section for details. 

 

Tip: 
You can control the displayed ZIP Codes by using the filter. For details, see the 
Zone Manager Filter topic. 

7. Click OK. The Optional Updates dialog box appears. For details, see the Zone 
Manager Optional Updates topic. 

8. Click OK.  

Editing ZIP Codes 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager dialog box appears. 

2. Type the ZIP Code you want to edit into the ZIP Code field in the Filter ZIP 
Codes section. 

3. Click Run Filter. 

4. Click on the ZIP Code you want to edit. The row will highlight in yellow. 

5. Edit the ZIP Code's values as needed. 

6. Repeat steps 2-5 for additional ZIP codes. 

7. Click OK. The Optional Updates dialog box appears. For details, see the Zone 
Manager Optional Updates topic. 

8. Click OK.  

Deleting ZIP Codes 

1. Select Tools > Lists > Zone Management or press CTRL+F6. The Zone 
Manager dialog box appears. 

2. Type the ZIP Code you want to delete into the ZIP Code field in the Filter ZIP 
Codes section. 

3. Click Run Filter. 

4. Select the ZIP Code you want to delete. 
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5. Click  or select Edit > Delete. A Confirmation dialog box appears. 

6. Click Yes. The ZIP Code is removed from the list. 

7. Repeat steps 2-6 to delete additional ZIP Codes. 

8. Click OK. The Optional Updates dialog box appears. For details, see the Zone 
Manager Optional Updates topic. 

9. Click OK.  

Master Categories Overview 
ServiceCEO groups together individual services and products in master categories. These 
master categories are useful for organizational and reporting purposes, and can be used to 
define employee skill sets. 

After you define the master categories, you can assign every service or product in your 
database to a master category. You create a master category on any of the four tabs in the 
Service/Product Categories dialog box: 

• Services - Categories defined here will only appear for services and on the Master 
Services List.  

• Products - Categories defined here will only appear for Products and on the 
Master Products List. 

• Kits - If using kits, categories defined here will only appear for kits and on the 
Kits List. 

• All - Categories defined here will appear for all items (services, products and kits) 
as well as in all master lists. 

 

Tip: 
If you are using, or are going to use, ServiceCEO's Inventory Tracking module, 
we suggest you review the Product List Overview and relevant Inventory 
sections before creating your master categories. This will help you understand 
the direct relationship between Master Categories, Master Products, and the 
vendor catalog items. 

Adding a New Master Category 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Click Master Categories. The Service/Product Categories dialog box appears. 
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3. Click the tab on which you want to add your master category. 

4. Click Add. A new row will appear. 

5. Type the name for the new category in the Description field. 

6. The Active check box will be selected by default. Deselect it if you do not want 
this category to appear on the Products and Services page. 

7. If you are integrated with an Accounting account, click the Income Acct field to 
link this category to an accounting account. The value you select here will set the 
Income account on the Accounting tab of the Product and Service Detail dialog 
box for all products under this category. 

8. If you are integrated with an Accounting account, click the Commission Account 
field to link this category to an accounting account. The value you select here will 
set the Commission account on the Accounting tab of the Product and Service 
Detail dialog box for all products under this category. 

 

Tip: 
For more details, see the Associating Master Categories with Accounting section.

9. Select the Is a Skill? check box to make this master category a skill. For more on 
skills, see the Defining Skills section. 

10. Select the Skill Req by All Emps? check box to require that, if a job requires this 
skill, all employees assigned to the job must have this skill. 

11. Repeat steps 3-10 to add more master categories. 

12. Click OK. 
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Editing a Master Category 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Click Master Categories. The Service/Product Categories dialog box appears. 

3. Click the tab on which the master category you want to edit is located. 

4. Edit the necessary fields. 

5. Click OK. 

Deleting a Master Category 
If services and/or products are referencing a master category, you cannot delete the 
master category. In these instances, you should deselect the Active check box to make the 
master category inactive. 

When you deactivate a master category, it will automatically deactivate all products and 
services within that category, so it is a good idea to move all of the products and services 
to new categories before deactivating the current category. 

To deactivate a master category: 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Click Master Categories. The Service/Product Categories dialog box appears. 

3. Click the tab on which the master category you want to deactivate is located. 

4. Clear the Active check box for the master category you want to deactivate. 

5. Click OK. 

To delete a master category that has never had any information contained within it, repeat 
the steps above but click Delete rather than the Active check box in step 4. 
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Defining Service Units 
A Service Unit is a method of breaking down or measuring a service for payment 
purposes. For example, if you wanted to measure a lawn cutting service by acres cut, you 
could create an “acre” service unit and define how much the customer would be charged 
per acre in the Product Detail or Service Detail dialog box. The Service Units list allows 
you to build the specific unit types that you want for those items that you charge 
services/labor on a per unit basis. 

 

Tip: 
Companies that charge for labor/services on a flat fee or hourly rate do not need 
to create service units. 

Adding Service Units 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Click Unit List. The Service Units dialog box appears. 

 

3. Click Add. A new row appears. 

4. Type a name for the service unit in the Unit field. 

5. Type a description of the service unit in the Description field. 

6. Repeat steps 3-5 to add additional service units. 

7. Click OK. 
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Editing Service Units 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Click Unit List. The Service Units dialog box appears. 

3. Select the service unit you want to edit. 

4. Edit the Unit and Description fields as necessary. 

5. Click OK. 

Deleting Service Units 
Deleting service units that are in use on jobs will remove the service units from those 
jobs. The amount of the service will remain the same, but the unit will no longer have a 
name. 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Click Unit List. The Service Units dialog box appears. 

3. Click the gray button to the left of the service unit you want to delete in order to 
select the entire row. 

4. Click Delete. A confirmation dialog box appears. 

5. Click OK. 

6. Click OK. 

Services List Overview 
All of the ServiceCEO's services are located on the Services tab of the Products and 
Services dialog box. Note that any existing Master Categories (as defined on the Services 
or All tab of the master Categories dialog box) are displayed in bold black lettering. 
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Each line item is a service that is available when creating jobs and schedules (on the 
Services and Products tab). These services will also appear on the work order and 
invoice(s) that will be created. As you are creating your service list, keep in mind that the 
more detailed the Services list, the more detailed your reports will be. In addition, a 
detailed list will also increase the power of the Sort and Filter grouping capabilities for 
both the revenue tracking and marketing modules. 

For details on creating individual services, see the Defining Service Items section. 

To expand the master categories: 

• Click the plus sign to the left of the master category to expand the single category. 

• Click  to expand all master categories. 

To collapse the master categories: 

• Click the minus sign to the left of the master category to collapse the single 
category. 

• Click  to collapse all master categories. 

Defining Service Items 
Before you can assign services to a job, you first have to define the services in the 
application. Note that the information you record here is only for default purposes. You 
will have the ability to edit this information on the job or recurring schedule to which you 
apply the service. 

Adding a New Service 

1. Select Tools > Lists > Master Service List or press CTRL+F4. The Products 
and Services page appears. 

2. Click New. The Product and Service Detail dialog box appears. 
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3. Select a category from the Category drop-down list. 

4. Type a name for the service in the Service field. 

5. Type a description of the service into the Description field. 

6. The Active check box will be selected by default. Deselect it if you do not want 
this category to appear on the Products and Services page. 

7. Select the type of charge you want to apply to this service from the Charge Type 
drop-down list. Depending on what you select, additional fields will appear: 
 
If you select Per Unit, a drop-down list and the Est. Duration field appear. Select 
the type of unit from the first drop-down list. Enter the minimum amount of units 
for this service in the Est. Duration field. 

 

Note: 
The Est. Duration field enables you to add services to a per-unit job without 
specifically setting job duration. For example, if you create a new job and add a 
service (with an Est. Duration value of 15 minutes) to it with and a Quantity of 
two, the duration of the service will be 30 minutes or .5 man-hours. 

8. Click the Print as Flat Fee check box to display all charges as one charge on the 
work order. This check box will not appear if you selected Flat Fee from the 
Charge Type drop-down list. 

9. Type the default charge into the Charge field. 

10. Click Edit... to define and edit price groups for the service. For more, see the 
Using Price Groups topic of the ServiceCEO Help System. 
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11. Select the appropriate Tax check boxes to apply taxes to the service. 

 

Note: 
The name of the tax check boxes will vary depending on your defined tax types. 
In the screenshot above, we've defined two tax types as State and County. See 
the Defining Tax Codes section for details. 

12. Select the Pay Commission check box to pay commissions on this service. The 
commission fields will activate. 

o To apply the same commission rate to all commissioned employees, select 
the Pay same commission rate option button and edit the rates in the 
Original Sale Rate (%) and Add-On Sale Rate (%) fields as needed. 

o To apply different commission rates to different employees, select Pay 
different commission rates and click View Individual Rates. The Per-
Employee Commissions dialog box will appear. Edit these fields as 
necessary. Click Save. The Per-Employee Commissions dialog box will 
close. The new commission rates are now in effect. 

13. If you're integrated with an Accounting package, click the Accounting tab. See 
the Associating Products-Services with Accounting section for details. 

14. You can automatically create a task when this service is sold. See Automatically 
Creating Tasks with Products and Services for details. 

15. Click OK.  When you add this service to a job, this task will automatically appear 
on the Tasks tab, linked to the service and job. 

16. Click OK. 

Editing Service Details 

1. Select Tools > Lists > Master List or press CTRL+F4. The Products and 
Services page appears. 

2. Double-click the product or service you want to edit. The Product and Service 
Detail dialog box appears. 

3. Edit the values as necessary. 

4. Click OK. 

Deactivating Services  

Services that are associated with a job at any point - be it a job in the past, present, or 
future - cannot be deleted. You can, however, mark the service as Inactive, meaning that 
you will no longer be able to assign the service to jobs moving forward.  
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1. Select Tools > Lists > Master Service List or press CTRL+F4. The Products 
and Services page appears. 

2. Double-click the service you want to deactivate. The Service Detail dialog box 
appears. 

3. Clear the Active check box. A confirmation dialog box appears. 

4. Click OK. 

Products List Overview 
The Master Products list functions much like the Master Services list – it lists each 
product your business offers for sale as part of a job, project or invoice. If you do not 
want to track purchases or inventory amounts, you'll configure the Master Products list in 
the exact same manner as the Master Services List, meaning that the Master Products list 
will serve as a Master List of all of the products you sell. You will also be able to attach 
these products to jobs and schedules. To use the Master Products List in this manner, 
enter your products in the same manner as you did the Master Services List. See the 
Service List Overview section for details. 

 

Tip: 
Items are listed exactly as they will appear on work orders and invoices, so 
names and descriptions should be customer friendly.  The part numbers entered 
here should be the ones you use internally for referencing a part, regardless of 
which vendor or supplier from which it came. 

If you are, or plan on ever, tracking inventory in ServiceCEO, the Master Products List 
can also act as an internal parts control system. See the Inventory topic of the 
ServiceCEO Help Systems for details.  

Defining Master Product Items 
Before you can assign products to jobs, you first have to define the products in 
ServiceCEO. The information you record here is only for default purposes. You will have 
the ability to edit this information on the job or recurring schedule to which you apply the 
service. 

Adding a New Product 

1. Select Tools > Lists > Master Product List or press CTRL+F5. The Products 
and Services Detail page appears. 

2. Click New. The Product and Service Detail dialog box appears. 
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3. Select the product's category from the Category drop-down list. 

4. Type a number for the product in the Product No. field. 

5. Type a name for the product in the Product field. 

6. Type a description of the product into the Description field. 

7. The Active check box will be selected by default. Deselect it if you do not want 
this category to appear on a job's Services/Products tab. 

8. If necessary, select the product's units from the Units drop-down list. 

9. Type the amount it cost you to buy this product in the Our Cost field.. 

10. Type the amount you are selling this product for in the Selling Price field. 

11. Click Edit... to define and edit price groups for the product. For more, see the 
Using Price Groups section. 

12. Select the appropriate Tax check boxes to apply taxes to the product. 

 

Note: 
The name of the tax check boxes will vary depending on your defined tax types. 
In the screenshot above, we've defined two tax types as State and County. See 
the Defining Tax Codes section for details. 
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13. Select the Pay Commission check box to pay commissions on this product. The 
commission fields will activate. 

o To apply the same commission rate to all commissioned employees, select 
the Pay same commission rate option button and edit the rates in the 
Original Sale Rate (%) and Add-On Sale Rate (%) fields as needed. 

o To apply different commission rates to different employees, select Pay 
different commission rates and click View Individual Rates. The Per-
Employee Commissions dialog box will appear. Edit these fields as 
necessary. Click Save. The Per-Employee Commissions dialog box will 
close. The new commission rates are now in effect. 

14. If the product's custom fields are active, you can define values for them now. 
These fields are activated in the Products/Services Options dialog box.  

15. If you want to add this product to Inventory Tracking, click the Inventory, 
Vendors and Stock Levels tabs. For more, see the Adding Master Products to 
Inventory topic of the ServiceCEO Help System. 

16. If you're integrated with an Accounting package, click the Accounting tab. See 
the Associating Products-Services with Accounting section for details. 

17. You can automatically create a task when this product is sold. See the 
Automatically Creating Tasks with Products and Services topic of the 
ServiceCEO Help System for details. 

18. Click OK.  When you add this product to a job, this task will automatically 
appear on the Tasks tab, linked to the product and job. 

19. Click OK. 

Editing Product Details 

1. Select Tools > Lists > Master Product List or press CTRL+F5. The Products 
and Services page appears. 

2. Double-click the product you want to edit. The Product and Service Detail dialog 
box appears. 

3. Edit the values as necessary. 

4. Click OK. 
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Deactivating Products  

Products that are associated with a job at any point - be it a job in the past, present, or 
future - cannot be deleted. You can, however, mark the product as Inactive, meaning that 
you will no longer be able to assign the product to jobs moving forward. 

1. Select Tools > Lists > Master Product List or press CTRL+F5. The Products 
and Services page appears. 

2. Double-click the product  you want to deactivate. The Product Detail dialog box 
appears. 

3. Clear the Active check box. A confirmation dialog box appears. 

4. Click OK. 

Defining Inventory Management Options 
You can use ServiceCEO to track your inventory data. Enabling inventory management 
lets you track product vendors, purchase orders, and the stock levels at your stock 
locations. For more on tracking Inventory, please read the Inventory topic of the 
ServiceCEO Help Systems.  

Enabling Inventory Management 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Inventory from the Categories bar. The Inventory Management Options 
dialog box appears. 
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3. Click the Enable Inventory Management check box to start managing your 
inventory.  

To further control how you track inventory, you can define settings in four different 
areas: 

• Purchase Order Settings - Defines the appearance of your Purchase Orders 
(POs). 

• Item Costing - Defines the rules that set the cost of non-serialized items, and 
controls which items will be used to fill purchase orders. 

• Stock Locations - Enables inventory stocking at the various levels of your 
organization. 

• Reorder Points - Excludes inventory that is already assigned to jobs from the 
figures that determine reorder and maximum control point warnings. 

Purchase Order Settings 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Inventory from the Categories bar. The Inventory Management Options 
dialog box appears. 

3. Click PO Settings. The Purchase Order Print Options dialog box appears. 
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4. Select the Require notes after each phase of Purchase order check box to 
capture an audit trail for each purchase order. 

5. Select the Print Bill-To Information in Header check box to include billing 
information in the header of a printed purchase order. 

6. If you selected the Print Bill-To Information in Header check box, next select 
the check boxes corresponding to the information you want to include in the 
header. These options include:  

o Phone 
o Fax 
o Web 
o E-mail 

7. From the first drop-down list, select the company segment to which you want to 
bill orders for a Region. 

8. From the second drop-down list, select the company segment to which you want 
to bill orders for a Branch. 

 

Tip: 
Steps 7 and 8 are only valid if you are using ServiceCEO Enterprise to manage 
multiple company locations. 

9. From the third drop-down list, select the company segment to which you want to 
bill orders for a Team. 

10. In the text box, edit the text. This text appears on Purchase Orders as a 
notification message with notification dates. 
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Tip: 
To automatically insert the purchase order's notification date, type "%DATE%" 
in the text field. 

11. Click OK. 

Item Costing 
Since non-serialized inventory items are indistinguishable from each other, but each item 
may cost differently depending on the Vendor from which they are purchased, you need 
to define a cost estimate and inventory selection method. The Inventory Costing dialog 
box enables you to define a default method of estimating the inventory cost and which 
item will be used when the master product is sold - see the Non-Serialized Inventory 
topic of the ServiceCEO Help System for more.  

 

Tip: 
You will always be able to change these defaults when defining a new master 
product. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Inventory from the Categories bar. The Inventory Management Options 
dialog box appears. 

3. Click Item Costing. The Inventory Costing dialog box appears. 

 

4. In the first section, click the appropriate option button to set the default method of 
calculating an item's cost. 

5. In the second section, click the appropriate option button to set the method of 
selecting which items will fill new sales orders. Your options are: 

o First In, First Out. Older inventory will ship before newer stock. 
o Last In, First Out. Newer inventory will ship before older stock. 
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Note: 
For more details on these options, please read the Non-Serialized Inventory topic 
in the ServiceCEO help system. 

6. Click OK. 

Inventory Stock Locations 
By selecting the check boxes in the Inventory Stock Locations dialog box, you make that 
level a Stock Location. In other words, if you select the Team check box in step four, 
every team in ServiceCEO will be become a functioning stock location. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Inventory from the Categories bar. The Inventory Management Options 
dialog box appears. 

3. Click Stock Locations. The Stock Locations dialog box appears. 

 

4. Select the check boxes that correspond to every location where you want to 
enable inventory stocking. The Region and Branch check boxes will only appear 
if you are running ServiceCEO Enterprise. 

5. Click OK. 

Inventory Reorder Points 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Inventory from the Categories bar. The Inventory Management Options 
dialog box appears. 

3. Click Reorder Points. The Inventory Reorder Points dialog box appears. 
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4. Select the check box to exclude inventory that is already assigned to jobs from the 
figures that determine your reorder and maximum control point warnings. 

Price Levels Overview 

 

Caution: 
Price levels are different from Zone Pricing. Zone Pricing used to be called 
"Price Groups" in versions of ServiceCEO before 6.1. For more on Zone Pricing, 
please see the Using Zone Pricing topic of the ServiceCEO Help System.  

Price Levels enable you to tailor charges for particular customer locations or jobs by 
raising or lowering product and service prices by a percentage that you define. For 
example, if you could provide a preferred customer a 5% markdown on all of their 
products and services. 

In addition, you can mark up or mark down products based on the cost or price. In other 
words, you can use price levels to generate the product's sell price based on two things: 

1. Standard Price. Price-based price levels generate a new sell price by adjusting 
the product's standard price as defined in the Product Detail dialog box.  

2. Cost Based. The sell price will be derived by taking the product's cost (as defined 
in the Product Detail dialog box) and multiplying it by the price level. 

 

Note: 
Depending on how the inventory product is being costed (i.e., Serialized, LIFO, 
FIFO, Average On Hand, Last Purchase Price, etc.), the original cost of items 
may vary; for details on how inventory items are costed, see the How is the Cost 
Calculated for Inventory Items? topic of the ServiceCEO Help System. 

Managing Price Levels 
You can define percentage by which the price level will increase or decrease cost or sell 
prices in the Price Levels dialog box. 

Creating Price Levels 
Before you can use Price Levels, you first need to create them. To do so: 

1. Select Tools > Lists > Price Levels. The Price Levels dialog box appears. 
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2. Click Add to add a new price level to the list.  

3. The Active check box is selected by default. Deselect it if you do not want this 
price level to appear when assigning products and services to jobs.  

 

Tip: 
Once a price level has been created, it cannot be deleted. If you are no longer 
using a price group, simply deselect the Active check box and the price group 
will no longer be able to be selected from a drop-down list in ServiceCEO. See 
the Discontinuing Price Levels section for details. 

4. Type a name for the price level in the Name field.  

5. In the Services field, type the percentage amount by which you want to change 
the sell price of services using this price group. This value can be positive or 
negative.  

6. Type the percentage amount by which you want to change products using this 
price group in the first Products field. This value can be positive or negative.  

7. If you typed a value in the Products field, select what about the product you want 
to change from the Products drop-down list. Your options are:  

o Cost. The product's cost will be adjusted by the amount in the first 
Products field. If you are using the Inventory Tracking module, the 
method of cost calculation may vary, depending on what costing type you 
are using (i.e., serialized, LIFO, FIFO, Average On Hand, Last Purchase 
Price, etc.)  

o Sell Price. The product's sell price will be adjusted by the amount in the 
first Products field.  

8. Repeat steps 2-7 to create additional price levels.  

9. Click OK to save your changes and close the Customer Price Levels dialog box.  
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Editing Price Levels 

1. Select Tools > Lists > Price Levels. The Price Levels dialog box appears. 

2. Select the price level you want to add. 

3. Edit any of the values as necessary. 

4. Repeat steps 2-3 to edit additional price levels. 

5. Click OK. Your changes are saved. 

Deactivating Price Levels 
Once created, you cannot delete a price level. However, you can make it inactive so that 
the price level no longer appears in drop-down lists throughout ServiceCEO. To do so: 

1. Select Tools > Lists > Price Levels. The Price Levels dialog box appears. 

2. Clear the Active check box for the price level you want to deactivate. If the price 
level is assigned to any customers, customer locations, or jobs, then the Price 
Level Update dialog box appears: 
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This dialog box lets you control how the inactive price level is replaced, if at all, on your 
customers and/or jobs. Your choices are: 

• Change all Customers with [deactivated price level] to. This option will 
replace the deactivated price level with the price level you select from the drop-
down list. The replacement will occur in all customer records and addresses 
where the deactivated price level appears. In other words, if a customer is using 
the price level you are deactivating, that price level will be replaced by the one 
you select now. The implications of this replacement are: 

o All new jobs will use the price level you define here. 

o All old jobs will continue to use the old price level. 

• Do not change existing Customers with [deactivated price level]. All jobs for 
the customer will continue to use the deactivate price level. 

 

Caution: 
If you keep the deactivate price level, it will continue to be used for those 
customers that have it selected in their Address Information dialog box. 
However, you will not be able to select it from any of the price level drop-down 
lists in ServiceCEO. 

3. Select the appropriate value from the drop-down list. 

4. Click OK. The Price Level is not active. 

5. Repeat steps 2-4 to deactivate other price levels. 

6. Click OK. Your changes are saved. 

Campaigns 

Campaigns Overview 
A campaign is a specific marketing activity, such as such as yellow page ads, store fronts, 
billboard ads, mass emails, holiday cards, direct mail, and telemarketing campaigns. You 
can manage your campaign efforts from a centralized location in ServiceCEO by utilizing 
your existing customer base and demographics. Campaigns are comprised of several 
interconnected features: 

• Configuring and maintaining campaigns.  

• Assigning tasks to users and/or groups that need to be completed as part of a 
campaign 

• Tracking metrics about the cost and revenue generated by specific campaigns 
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Note: 
In versions of ServiceCEO before version 6.0, "campaigns" were known as 
"marketing". 

Campaigns are organized into several main areas: 

• Defining Campaign Categories 

• Defining Campaigns 

• Campaign Tasks 

• Defining Demographics 

Campaign Metric Tracking 

You can track the performance of your campaigns using two reports: 

• Revenue report. Select Marketing from the Select the order / groups in which 
the items will appear drop-down list. 

• Job Costing report. Select the Campaign - Summary or Campaign - Details 
 print style. 

Campaign Categories 
Before you create a campaign, you can create different categories in which to save your 
campaigns. You can do this in the Category Maintenance dialog box. 

The value displayed in the Number of Categories column indicates how many campaigns 
are located in this category in the Campaign Setup & Maintenance dialog box. This value 
is read-only. 

Creating a Campaign Category 

1. Select Tools > Lists > Campaign Categories. The Category Maintenance dialog 
box appears: 
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2. Click Add to add a new category. 

3. Type the category's name in the Name field. 

4. Repeat steps 2-3 to add more categories. 

5. To delete a category, highlight the category and click Delete. Note that you will 
only be able to delete categories without any campaigns attached to it.  

Editing a Campaign Category 

1. Select Tools > Lists > Campaign Categories. The Category Maintenance dialog 
box appears. 

2. Make any necessary edits to the appropriate campaign categories.  

3. Click OK. 

Deleting a Campaign Category 
Note that you can only delete categories without any campaigns attached to it. If at least 
one campaign belongs to a category, the Delete button will not be active. You will need 
to remove all campaigns from the category before you can delete it. 

1. Select Tools > Lists > Campaign Categories. The Category Maintenance dialog 
box appears. 

2. Highlight the campaign category you want to delete. 

3. Click Delete.   

4. Click OK. 

Defining Campaigns 
A campaign enables you to track what marketing efforts are being conducted and how 
effective they are in generating revenue for your company.  

Creating Campaigns 

To create a campaign: 

1. Select Tools > Lists > Campaigns or press CTRL + F7. The Campaign Setup & 
Maintenance dialog box appears. 
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2. Highlight the category in which you want your new campaign to appear and click 
New Campaign. The Campaign Details section will appear with no data. 

3. Type a name for the campaign in the Name field. 

4. Select the campaign's category from the Category drop-down list. See the 
Defining Campaign Categories section for details. 

5. Select the date the campaign will start from the Start Date calendar box. The 
default value is today's date. 

6. Select the date the campaign will end from the End Date calendar box. The 
default value is today's date. 

7. Enter the amount budgeted for the campaign in the Budget Amount field. The 
default value is $0.00. 

8. Enter the actual amount spent during the campaign in the Actual Amount field. 
The default value is $0.00. 

9. If necessary, enter any notes into the Notes field.  



Implementation Checklist 

40 

10. The Keep Available in Drop-Downs section controls when the campaign will be 
present in the Campaign fields elsewhere in ServiceCEO. To define these values: 

1. Select the From option button corresponding to the date at which you 
want the campaign to start being displayed in the drop-down lists:  

 Campaign Start Date. The campaign will start being displayed on 
the date entered in the Start Date field. 

 Specific Date. Select the date you want the campaign to start 
appearing from the calendar box. 

2. Select the Until option button corresponding to the date at which you want 
the campaign to start being displayed in the drop-down lists:  

 Campaign Start Date. The campaign will start being displayed on 
the date entered in the Start Date field. 

 Specific Date. Select the date you want the campaign to start 
appearing from the calendar box. 

 Always. The campaign will always appear in the drop-down lists. 
11. Add tasks to the campaign. See the Campaign Tasks section for details. 

12. Click Save and Close. 

Editing Campaigns 

1. Select Tools > Lists > Campaigns or press CTRL + F7. The Campaign Setup & 
Maintenance dialog box appears. 

2. Expand the category tree and select the campaign you want to edit. 

3. Make any necessary edits in the Campaign Details and/or Tasks sections. 

4. Click Save and Close. 

Deleting Campaigns 

You cannot delete a campaign if it is selected in the Campaign drop-down list in at least 
one customer or job record. While you cannot make the campaign inactive either, you can 
adjust the campaign's Keep Available in Drop-Downs fields so that the campaign cannot 
be selected in the future. 

1. Select Tools > Lists > Campaigns or press CTRL + F7. The Campaign Setup & 
Maintenance dialog box appears. 

2. Expand the category tree and select the campaign you want to delete. 

3. Click . 
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Note: 
If any tasks are associated with the campaign, the tasks which are already 
complete will NOT be deleted and will instead be detached from the Campaign. 
Tasks that are not started will be deleted. 

Demographics 
In ServiceCEO, a demographic is a selected group of customers based on characteristics 
and/or filters you define. You can create a demographic and then reuse it in multiple 
campaigns without redefining your filter criteria. Demographics are typically used to 
define the audience for Campaign Tasks. 

Creating Demographics   
To create a demographic: 

1. Select Tools > Lists > Demographics. The Demographic Maintenance dialog 
box appears. 

 

2. Click Add. The Demographic Builder dialog box appears. 
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Tip: 
The filters in the Demographic Builder are identical to the filters in the 
Marketing Module report. 

3. Type a name for the demographic in the Name field. 

4. Type a description of the demographic in the Description field. 

5. Select the check boxes corresponding to the customer locations you want to 
include in the demographic:  

o Target the locations specified by the filter tabs. All locations that match 
the criteria you define in the filter tabs will be included. This check box is 
selected by default. 

o Target the PRIMARY locations of the specified Customers. Will 
include only the primary locations for customers matching your criteria (as 
defined in the demographic filters).  

o Target the BILL TO locations of the specified Customers. Will include 
only the bill to address for customers matching your criteria (as defined in 
the demographic filters). 
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Tip: 
You can select multiple customer location check boxes to further refine your 
location criteria. For example, if you select the first two check boxes, the 
demographic will include only the primary location for every customer returned 
by your filter criteria. 

 

Note: 
The Primary and Bill To addresses are defined in the customer's Address 
Information dialog box. See the Defining a Customer Address topic of the 
ServiceCEO Help System for more details. 

6. Select the option button corresponding to the contacts that you want to include in 
the demographic:  

o Primary contact. Will only include each customer's primary contact. This 
option button is selected by default. (The primary contact is the first 
contact listed in the customer's Contact Name drop-down list.) 

o All contacts. Will include all customer contacts. 
7. Select the option button corresponding to the order in which the output will be 

sorted:  

o Alphabetically by Name. This option button is selected by default. 
o ZIP Code. 

8. Select your filter criteria from the left side of the dialog box. For details, see the 
Demographic Filters section. 

9. Click OK. The demographic is saved. 

 

Caution: 
You cannot edit a demographic once it has been created, so be sure that the 
demographic contains the correct filters before you save it. If you want to 
preview a filter setup to review the results, preview the mailing labels output 
using the Marketing Module report. This report uses the same filters as the 
Demographic Builder. 

Deleting Demographics 

You cannot delete a demographic that are used for any active or completed campaign 
tasks. If the demographic is not in use, follow these steps: 

1. Select Tools > Lists > Demographics. The Demographic Maintenance dialog 
box appears. 

2. Select the demographic you want to delete. 
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3. Click Delete. A confirmation dialog box appears. 

4. Click Yes. The demographic is deleted. 

5. Repeat steps 2-4 to delete additional demographics. 

6. Click OK. 

Demographic Filters 
The demographic filter consists of nine tabs. Click the tab to define a filter on that tab. 
You can define filter settings on as many or as few tabs as necessary. The tabs are all 
described in detail below. 

 

Tip: 
These filters also appear on the Marketing Module report. 

Status 

To filter the demographic by status: 

1. Select the Only include Customers with the following status settings: check 
box. 

2. Select the check box corresponding to the customer statuses you want to include 
in the demographic. 

Product/Service 

To filter the demographic by product/service: 

1. Select the Only include Customers scheduled for the following 
Products/Services: check box. Past jobs are included unless you also define a 
date filter. 

2. By default, the master product and service categories appear in a tree format. To 
expand the list, click the appropriate plus box. 

3. Select the check box corresponding to the product/services you want to include in 
the demographic filter. All customers scheduled for service that includes the 
selected product/service will be included in the filter. 

 

Tip: 
If you select the check box corresponding to a master category, all 
products/services under the category will be selected. 
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For more details, read the Master Service-Product Categories Overview section. 

Campaign 

To filter the demographic by campaign: 

1. Select the Only include Customers with the following Campaigns: check box. 

2. Select the campaign for which you want to filter the demographic. Only 
customers who are part of the selected campaign(s) will be included in the current 
campaign. 

Custom Fields 

To filter the demographic by custom field: 

1. Select the check box corresponding to the custom field you want to filter. 

2. Type or select the value for which you want to filter the custom field. 

3. Repeat steps 1-2 to filter by additional custom fields. 

For more on custom fields, please read the Defining Custom Fields topic of the 
ServiceCEO Help System.  

Profiles 

To filter the demographic by company profile: 

 

Tip: 
The Profile tab will only appear if the use of company profiles has been enabled 
in ServiceCEO. For more on profiles, read the Creating Multiple Company 
Profiles topic of the ServiceCEO Help System. 

1. Select the Only account for Customers with the following Profile association: 
check box. 

2. Select the check box(es) associated with the profile(s) for which you want to filter 
the demographic. 

Contact Interval 

To filter the demographics' customers by their contact interval settings: 

1. Select the check box corresponding to the contact interval that you want to honor. 
If needed, you can select multiple contact settings. 
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Zone 

To filter the demographic by zone: 

1. Select the Only include Customers with a location in one of the following 
Zones: check box. 

2. Select the check box(es) associated with the zone(s) for which you want to filter 
the demographic. 

For more details, read the Zone Manager section. 

Date of Service 

To filter the demographic by the job's date of service: 

1. Select the Filter by a Date Range check box. 

2. Select the option button corresponding to the type of date range you want to use: 

o  Only include Customers with service in the following date range. This 
option will include customers who have at least one active job, schedule, 
or project scheduled during the date range defined below. 

o Only include Customers whose last completed service occurred in the 
following date range. This option will include customers whose most 
recently completed job, schedule, or project falls within the date range 
defined below. 

3. Select the start date from the Start calendar box. 

4. Select the end date from the End calendar box. 

5. Select the type of records for which you want to filter from the Account for drop-
down list. Your choices are:  

o All Records. Includes Jobs, Schedules, and Estimates. 
o All Estimates. Only includes estimates. 
o All Jobs. Includes Jobs, Schedules, and Projects. 
o Recurring Jobs. Only includes schedules (jobs with a defined frequency). 
o One-Time Jobs. Only includes jobs being performed once. 
o Reservice Jobs. Only includes reserviced jobs. For more on the reserviced 

jobs fields, please read the Reservicing Jobs topic of the ServiceCEO Help 
System.  

 

Tip: 
In the Date of Service tab of the Demographic Builder, projects will be returned 
if you select All Jobs or Recurring Jobs from the Account for drop-down list. 
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Date Entered/Contacted 

To filter the demographic by customers' entered or contacted dates: 

1. To filter by entered date, select the Filter by date Customer was entered check 
box. Only customers that were created during the date range will be included in 
the demographic. 

 

Note: 
The Date Entered field is located on the customer's General tab. 

2. To filter by the customers last contacted date (as defined in the Customers Detail 
Tab), select the Filter by date Customer was last contacted check box and the 
contact type by which you want to filter from the drop-down list. Your choices 
are Mail, Voice, and E-mail. 

3. Select the filtering option button you want to use: 

o Between specific dates. Select a date range from the two drop-down lists. 
Only customers that were created or contacted during the date range will 
be included in the demographic. 

o Between relative dates. These dates will be relative to the date on which 
the demographic is run. 

 Type the amount of days you want the date range to include in the 
number field. 

 Select the relative amount from the drop-down list. 

For example, if you wanted to create a demographic that included 
everyone that had been contacted by e-mail in the last 60 days, you would 
select the second filter option button, select E-mail from the drop-down 
list, select the second between option button, and setup 60 Days Before 
and 0 Days After. 

Campaign Tasks 

Creating Campaign Tasks 

To create a campaign task: 

1. Open the campaign to which you want to add a task. 

2. Click Add. The Task Setup Wizard appears. 
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3. Type a title for the task in the Subject field. 

4. Select the option button corresponding to the type of task you wish to create. 
Your options are:  

1. Regular Task. A normal task. 

2. Campaign Activity. Includes:  

 Microsoft® Word® Mail Merge. Create a mail merge document 
for this campaign. For more on mail merges, see the Running a 
Mail Merge topic of the ServiceCEO Help System. 

 Mailing Labels. Creates a Microsoft Word document containing 
mailing labels for the task's audience. 

 Copy E-mails. Copies the e-mail addresses for the task's audience 
to your clipboard so that you can paste them into an e-mail 
application. 

 Microsoft Excel® Expert. Exports the customers to Microsoft 
Excel. 

3. Telemarketing. Used to link a task to a call center record. The values that 
appear on this list correspond to the call types you've created. (See the 
Defining Call Types topic of the ServiceCEO Help System for details.) 
Selecting a call type will automatically run the call type when the task is 
begun. 

5. Click Next. The next page of the Task Setup Wizard appears.  



Implementation Checklist 

49 

 

 

Note: 
If you are creating a Microsoft Word Mail Merge, the Select Template dialog 
box appears. See the Defining Mail Merge Templates topic of the ServiceCEO 
Help System for details. 

6. In many instances, the Task will target an audience check box will be selected 
by default, meaning that the task's audience will be controlled by a demographic. 
If it is not selected and you do not want to use an audience/demographic, go to 
step 8. 

7. If the Task will target an audience check box is selected, select a value from the 
drop-down list. Your options are:  

o Edit List. Select if you want to define a new demographic. The 
Demographic Maintenance dialog box will appear. See the Demographic 
Setup section for details. 

o All existing demographics will appear in the drop-down list. Select one to 
use it for the current task. 

8. Click Next. The Task dialog box appears. 

9. Define the task details in the usual manner. See the Creating a Task topic of the 
ServiceCEO Help System for details. 

10. Click OK. If you are creating a regular task or a Telemarketing task (based on 
your selection from the first page of the Task Setup Wizard) and you selected an 
audience, the third page of the Task Setup Wizard appears. If you selected 
Campaign Activity, the task will be saved and appears on the Campaign page.  
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11. Select the option button corresponding to how many tasks you want to create for 
the audience:  

o Select ONE Task to create one task that covers the entire demographic 
audience. 

o Select MULTIPLE Tasks to create one task for each customer in the 
task's demographic. The Task Creation section will become active.  

 

Caution: 
Depending on your demographic, selecting multiple tasks could create a large 
number of tasks. 

12. Select the option button corresponding to when you want to create the multiple 
tasks. For more, see the Executing Campaign Tasks section.  

o Immediately when the Campaign is saved. The task will be created 
when you click Next. 

o Schedule these tasks to be created at a later date. A reminder task will 
appear when you click Next. 

13. Click Next. If you selected the Schedule these tasks to be created at a later date 
option button, a reminder task appears. 

14. Change the date of the reminder task to the date to which you want to be 
reminded to create the tasks. 

15. Assign the task if necessary. 

16. Click OK. The task appears on the campaign dialog box as well as the Tasks 
section of Office Duties. 
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Deleting Campaign Tasks 

 

Note: 
Deleting a parent task (a task that created one task for each customer in its 
demographic) will delete all associated child tasks that have not yet been 
completed. However, any child tasks that have already been completed will not 
be deleted. 

To delete a campaign task: 

1. Open the campaign from which you want to delete a task. 

2. Select the task you want to delete. 

3. Click Delete. A warning dialog box appears. 

4. Click Yes. The task is deleted from the campaign. 

Executing Campaign Tasks 
Creating a multiple task (a task where you selected Multiple Tasks from the final page 
of the Task Setup Wizard) will create one task for each member of the task's 
demographic. You can create these in two ways: 

• Immediately after saving the campaign. The series of tasks will automatically 
be created and will appear on the Tasks tab of the Office Duties area. 

• At a later date. The series of tasks will be created at a later date. You will be 
prompted to create a "reminder" task. Once created, the reminder task will appear 
identical to a normal task except for the Begin Task button. Click Begin Task to 
run the task. The multiple tasks are created and will appear on the Tasks tab of the 
Office Duties area. 

 

Caution: 
If you use the At a later date option, the customers in your demographic may be 
different then if you created the tasks immediately. For example, if you defined a 
demographic to include all customers with a job scheduled 30 days before and 30 
days after the run date, the demographics' customers will vary depending on the 
date on which you begin the task. 

Starting a Task 

If the task requires an action (like opening a Call Center script or creating mailing labels), 
you must begin the task to start this action. To begin the task, perform one of the 
following actions: 

• Open the task record and click Begin Task. 

• Right-click the task and select Begin Task from the pop-up menu. 
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Tip: 
Tasks that require starting will be distinguished by a green arrow on their icon: 

 

Once begun, the task will have a substatus of “In Progress” so that other users will not 
attempt to begin working on the same task, or at least be warned that it has been opened 
by another user. 

At the conclusion of the action, the task record appears with a default status of 
Completed Task and substatus of Completed as Requested. You can keep these values 
or, if the task is not yet completed, edit them before saving.  

Defining Substatuses 
Substatuses enable you to define the state of your jobs, estimates, and tasks with a greater 
degree of accuracy. For example, you may want to distinguish between different types of 
Active Jobs. To do this, you could create substatuses for the Active Job status. Once 
defined, you would then select the appropriate substatus from each Job's Substatus field.  

1. Select Tools > Lists > Job Status or press CTRL+F10. The Configure Statuses 
dialog box appears. 

 

Tip: 
The Status Name and Description fields of the default system statuses cannot 
be edited or deleted. 
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This dialog box enables you to define and control substatuses for all of the system's Job, 
Estimate, and Task statuses. If you like, you can also control which substatuses can be 
assigned from other substatuses. 

 

Note: 
ServiceCEO's statuses are standard and cannot be edited. 

Adding/Editing Substatuses 
To add or edit substatuses: 

1. Select the category of status to which you want to add or edit a substatus by 
selecting Job, Estimate or Task from the Category drop-down list.  

2. If necessary, select a color from the Color drop-down list. The color you select 
will be displayed for all jobs, tasks and/or estimates with that status on the 
ServiceCEO calendar.  

3. Select the status for which you want to add or edit a substatus from the list box. 
All of the statuses' substatuses will appear in the Step 2 list box.  
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Note: 
All statuses automatically have a default status of <None>. 

4. If adding a new substatus, click Add. A new substatus appears in the Step 2 list 
box.  

5. Define or edit the substatuses' values as necessary: 

o Icon. Select the icon you want to display on the Dispatch Board from the 
drop-down list. All jobs, estimates, or tasks with this substatus will display 
the icon you select here. 

o Name. The title of the substatus.  

o Default. Select this check box to make the current substatus the default 
value of its status. Note that only one substatus can be the default of a 
status.  

o Active. Activated by default, this check box makes the substatus visible in 
ServiceCEO.  

o Description. A brief explanation of the substatus.   

 

Note: 
In previous versions of ServiceCEO, only Active Jobs could have icons. 
However, with 6.0, 130 new icons are available to help you distinguish between 
your Jobs, Tasks, Estimates and Roles. 

6. In the allowed transactions dialog box, select the check box corresponding to all 
status or substatuses to which you want to allow the user to change. In other 
words, if the check box is selected, then users will be able to change the current 
substatus to the selected status or substatus in the system.  

 

Note: 
If you select or deselect a status check box, you will be prompted to permit or 
restrict access all substatuses under this status. Clicking Yes will select or 
deselect all of the substatuses under the status. 

7. Repeat steps 1-5 to add or edit more substatuses.  

8. When complete, click Save to save your changes.  

9. Click Close.  
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Once configured, ServiceCEO will verify that substatus changes are allowed before 
saving a substatus edit. The following areas of ServiceCEO are affected: 

• New Job  

• Existing Job  

• Customer Jobs tab  

• New Tasks  

• Tasks tab of the Office Duties area  

• Completion tab of the Office Duties area  

• Canceling jobs via the Calendar  

 

Caution: 
Only one substatus can be marked as the default value of the primary status. 

Deleting Substatuses 
Substatuses that are in use for an active or completed record cannot be deleted. For 
substatuses that can't be deleted, we recommend that you deactivate the substatus by 
clearing the Active check box for the substatus. This means that existing records will 
continue to use this substatus, but it will not be able to be assigned to any new records 
moving forward. 

To delete a substatus: 

1. Select Tools > Lists > Job Status or press CTRL+F10. The Status Editor dialog 
box appears. 

2. Select the status category in which the substatus you want to delete is located.  

3. Click in the Substatus field for the status you want to delete. 

4. Click Remove. A Confirmation dialog box appears. 

5. Click OK. The substatus is deleted. 

6. Repeat steps 2-5 to delete additional substatuses. 

7. Click OK. The Status Editor dialog box closes. 

To deactivate a substatus: 

1. Select Tools > Lists > Job Status or press CTRL+F10. The Status Editor dialog 
box appears. 

2. Select the status category in which the substatus you want to delete is located.  
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3. Click in the Substatus field for the status you want to deactivate. 

4. Clear the Active check box. 

5. Repeat steps 3-4 to deactivate additional substatuses.  

6. Click OK. The Status Editor dialog box closes. 

Defining Vocabulary 
The Vocabulary option lets you customize common ServiceCEO terms. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Vocabulary from the Categories bar. The Vocabulary Options dialog box 
appears. 

 

3. Type a new name for any field that you would like to customize. The fields on 
this page are described below in the order in which they appear: 

o First field. The name for the individuals/organizations to which you 
provide services and or products. This setting defaults to "Customer". 

o Second field. The name for a job with a frequency, or service plan. 
Defaults to "Schedule".  

o Third field. The name for the work scheduled to be performed for your 
customers. This defaults to "Jobs". 
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o Fourth field. The name for the people who perform tasks for your 
customers. This field defaults to "Employees". Customized Examples: 
Technicians, subcontractors, cleaners, service providers. 

o Fifth field. The name for the area of the application in which you will 
perform various financial and inventory tasks. This field defaults to 
"Office Duties". Customized examples: Financials, Completions, To Dos, 
Pending Posting. 

o Sixth field. The name for a group of employees who perform tasks. This 
field defaults to "Teams". Customized Examples: Crews, Routes, 
Technician, Trucks, etc. 

o Seventh field. The name for a pre-service plan for your customers. This 
field defaults to "Estimates". 

o Eighth field.  The name for a contract for service between you and your 
customers. Defaults to "Service Contracts". 

o Ninth field.  The name for a grouping of products and services. Defaults 
to "Kits". 

o Tenth field. The name for a set of services, products, kits, and/or tasks 
that are scheduled under multiple visits but all appear on one invoice. 
Defaults to "Projects". 

o Eleventh field. The name for the individual jobs that make up a project. 
Defaults to "Visits". 

4. Click OK.  

 

Tip: 
The name of the third icon on the Navigator bar is controlled by the plural value 
of the second, or "schedules", field. 

Defining Idiolect 
Idiolect is a linguistic pattern unique to speakers of a language or dialect. In terms of 
ServiceCEO, idiolect enables you to customize the terms used in ServiceCEO to match 
those of the country or region in which you are operating. You can customize five 
different fields. These fields, which default to the U.S. standards, are described in more 
detail below. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Idiolect from the Categories bar. The Idiolect Options dialog box appears. 
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3. Type a new value into any field whose value you want to customize. These fields 
are described in order below: 

o First custom field. The name for your the postal region or local area. This 
field defaults to "City". 

o Second custom field. The name for your broad municipality. This field 
defaults to "State". 

o Third custom field. The name for your mailing or postal code. This field 
defaults to "ZIP Code". 

o Fourth custom field. The name for the unique identifier assigned to an 
individual for tax tracking purposes. This field defaults to "Social Security 
No". 

o Fifth custom field. The format of the unique identifier (the fourth custom 
field). This field defaults to the U.S. Social Security Number format: 
"999-99-9999". To change this value, use "A" (uppercase, not lowercase) 
for alphanumeric characters and "9" for numbers.  

4. Click OK. 

Defining Note Types 
Many areas of ServiceCEO let you create notes for customers, employees, jobs, and 
estimates. These notes can be used to track performance, capture comments, or save any 
other necessary information. For reporting purposes, ServiceCEO has a master list of note 
types that allows you to manage, group and report on the notes that users create. You can 
add to, edit, or delete these note types as you see fit. 
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Note Type Tabs 
There are seven different categories of note types: 

• Customer - Customer note types are available on a customer's Notes tab. An 
example of a Customer note type is "Client Call Details." 

• Employee - Employee note types are available on an employee's Personnel File 
tab. An example of an Employee note type is "Training Update." 

• Cust & Empl - Cust & Empl note types are available when recording customer 
feedback through the feedback wizard. These items also appear with the standard 
Customer and Employee notes in their usual locations. An example of a Cust & 
Empl note type is "Poor Service." 

• Quoting - Quoting note types are available when a user cancels or ends a call 
center quote during the quoting wizard process. These note types help you track 
why quotes are abandoned. An example of a Quoting note type is "Did Not Want 
To Give Name." 

• Estimate Won - Estimate note types help the company track why a customer 
chose your bid over others. An example of an Estimate Won note type is "Best 
Price." 

• Estimate Loss - Estimate Loss note types help the company track why a customer 
chose a competitor's bid over your company's estimate. An example of an 
Estimate Loss note type is "Staying with current provider." 

• Estimate History - Estimate History note types are available when adding a note 
to an estimate. An example of an Estimate History note type is "Progress Update." 

Adding New Note Types 

1. Select Tools > Lists > Note Types or press CTRL+F2. The Note Types dialog 
box appears. 
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2. Select the appropriate tab for the note type you would like to add. 

3. Click Add. A blank row will appear. 

4. Double-click the blank cell in the Category column. 

5. Type a descriptive name for the new note type. 

6. Some tabs have extra check boxes, including: 

o Customer and Cust & Empl tabs. Select the Print on WO check box if 
you would like the note type printed on work orders. 

o Estimate History. Select the Print by Def. check box to print these notes 
on reports. 

7. If desired, type a numeric rank for the new note type in the Rank field. Adding a 
rank will enable ServiceCEO to numerically quantify the notes. Type a positive 
value for good note types; type a negative value for negative note types. 

 

Note: 
The Rank field enables you to assign a value to a note. You can use these values 
to track employee performance or customer satisfaction. Note types that you 
wish to not be used in these calculations should have a zero rank, as zero rank 
items are not included in any ranking calculations. 

8. Click OK. 

Editing Note Types 

1. Select Tools > Lists > Note Types or press CTRL+F2. The Note Types dialog 
box appears. 

2. Select the tab that contains the note type you want to edit. 

3. Select the note type you want to edit. 

4. Make any necessary changes to the note type. You can change the note’s name, 
rank, or choose to include or remove the note from printed reports. 

5. Click OK. 

Deleting Note Types 
Please be aware that any note type that has already been used cannot be deleted. 

1. Select Tools > Lists > Note Types or press CTRL+F2. The Note Types dialog 
box appears. 

2. Select the tab that contains the note type you want to delete. 
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3. Select the note type you want to delete. 

4. Click Delete. 

5. Click OK. 

Defining Requirements 
You can control which fields must be entered before a record is created in ServiceCEO. 
These required fields are defined in the Requirements Options dialog box.  To open this 
dialog box: 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Requirements from the Categories bar. The Requirements/Defaults 
Options dialog box appears. 

 
You can control the requirements for three types of records: 

• Customers 

• Jobs 

• Employees 
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Customer Options 

Customer Requirements 
You can define what fields must be entered before a customer record can be saved. To do 
so: 

1. From the Requirements/Defaults Options dialog box, click Customer Options. 
The Requirements dialog box appears. 

 

2. Select the appropriate Prospective check box for each field you want to make 
required when creating a prospective customer. Prospective customers are 
customers without any jobs. 

3. Select the appropriate Normal check box for each field you want to make 
required when creating an active customer. An active customer is a customer with 
at least one job. 

4. Click OK. 

5. Select the Check for duplicate records before saving new ones check box to 
enable ServiceCEO to search all existing customer records before saving a new 
record. The other two check boxes will become active. 

 

Note: 
If this check box is selected, ServiceCEO will, when a user attempts to save a 
new customer record, check the database for potential duplicate records. If any 
potential duplicates are found, the Duplicate Warning dialog box appears 
displaying the customer record(s) that could be considered a duplicate of the new 
one. You will have the opportunity to either continue creating the new record or 
switch to the existing record.  
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6. Select the Use advanced name checking (nicknames, sounds-like) check box to 
have the system search for similar names when checking for duplicate records.  

7. Select the Check last names only check box to have the system check only last 
names when searching for similar names. 

 

Note: 
Due to the complexity of many names, we can't guarantee that the advanced 
name checking or check last name functionality will find all of the names one 
may think are sufficiently similar to the new name. While this functionality will 
find most of the similar names, for those users uncomfortable with this 
uncertainty, we recommend that you use the basic duplicate checking feature.  

Customer Defaults 
You can define the default values for all new customer records. To do so: 

1. From the Requirements/Defaults Options dialog box, click Customer Defaults. A 
blank customer record will appear. 

2. Enter the values you would want to appear by default for a new customer into the 
General tab and the Detail tab. You can always edit these values when you are 
actually creating a new customer. 

 

Caution: 
You will not be able to define a default value for all customer fields. For 
example, you cannot define any location fields as a customer default. 

3. Click Save and Close. The default values are saved. 

Job Options 
To define the required fields for a job record: 

1. From the Requirements/Defaults Options dialog box, click Job Options. The 
Requirements dialog box appears. 
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2. Select the appropriate check box in the Required Entries section for each field 
you want to make required when creating a new job. 

3. Select the appropriate check box in the Prompt for notes when: section for each 
job action you want to prompt the user to enter a note. Your options are: 

o Making Cancellations. You will be prompted to enter a note when 
cancelling a job.  

o Winning Estimates. You will be prompted to enter a note (with the 
Estimate Won note type) when marking an estimate as won.  

o Losing Estimates. You will be prompted to enter a note (with the 
Estimate Lost note type) when marking an estimate as lost.  

4. Click OK. 

Employee Options 
To define the required fields for an employee record: 

1. From the Requirements/Defaults Options dialog box, click Employee Options. 
The Requirements dialog box appears. 
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2. Select the appropriate check box for each field you want to make required when 
creating a new employee. 

3. Click OK. 

Defining Employee Roles 
You can define employee roles to control employee payroll based upon the work they 
perform on any given job. You can also use roles to organize your employees based upon 
the duties they perform.  

Once defined, you can determine an employee's roles on the employee's Payroll Setup 
tab. 

Adding Employee Roles 

1. Select Tools > Lists > Employee Roles. The Employee Roles dialog box appears. 

 

 

Note: 
There are two default roles: General and Sales Rep. 
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2. Click Add. A blank row will appear. 

3. The Active check box is selected by default. Deselect it if you do not want the 
role to be visible when creating/editing employees. 

4. Type a descriptive name for the new employee Role in the Role field. 

5. Type a description for the new employee role in the Description field. 

6. Select the icon you would like to represent this role from the Role drop-down list. 
The icon that you select here will be displayed on the Dispatch Board.  

7. Select the Assign to Jobs check box if you want to be able to assign this role to 
jobs via the Dispatch Board and job record. Note that if you deselect this check 
box, employees with this role will not appear on the Dispatch Board or in the job 
record. 

8. Select the Works On Site check box to indicate if employees assigned to this role 
work at your customer's site(s). Because only employees that work on site will be 
included in payroll calculations (as opposed to employee who work off site, like 
Sales Representatives), this designation affects payroll calculations for man-hour 
scheduling. For details on man-hour scheduling, see the Defining Scheduling 
Options section. 

9. Select the Sales Rep. check box to indicate if the role is for a Sales 
Representative. Assigning an employee to a Sales Representative role affects 
payroll calculations. 

10. Select the Is A Skill check box to add the job to the Skills list. See the Defining 
Skills section for more. 

11. Select the Skill Req by All Employees? check box to require that any job 
needing this skill will then need ALL employees assigned to the job to have the 
requisite skill. If this check box is not selected, only one employee will need the 
skill. 

 

Note: 
If you have run the Payroll Setup Wizard, the Pay Cycle and Start of First Pay 
Period fields will already be populated. In this case, you should not select new 
values here unless you want to override the common values set in the Payroll 
Setup Wizard or you are creating a new role. For more, see the Using the Payroll 
Setup Wizard section. 

12. Select the frequency by which you want to run payroll for all employees working 
under this role from the appropriate Pay Cycle drop-down list. Note that you can 
select a different pay cycle for each role. 
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13. If necessary, type the date at which you want the first pay period for this role to 
start. 

14. Repeat steps 2-13 to add additional roles. 

15. Click OK. 

Editing Employee Roles 

1. Select Tools > Lists > Employee Roles. The Employee Roles dialog box appears. 

2. Edit any of the role fields as necessary. 

3. Click OK. 

Deactivating Employee Roles 
You cannot delete employee roles that are in use or have been used in the past.  

You can deactivate a role as long as it is not currently an employee's default role (on their 
Payroll Setup tab). Deactivating a role will remove the role from all current 
configurations and you will not be able to use it moving forward. Keep in mind that if an 
employee is eligible for a role and the role is deactivated, the employee will no longer be 
eligible for that role. 

1. Select Tools > Lists > Employee Roles. The Employee Roles dialog box appears. 

2. Clear the Active check box for the role you want to deactivate. 

3. Click OK. The role is deactivated! 

Configure Payroll 

Payroll Overview 
Follow these steps to configure payroll in ServiceCEO:  

1. Run the Payroll Setup Wizard. 

2. Define Payroll Options. See the Defining Payroll Options section for details. 

3. Define Payroll Security Options. See the Establishing Security Rights section for 
details. 

4. Define XML export options. For information on exporting your Payroll 
information to a General Ledger application, see the Integrating Accounting 
section. 
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5. Define Pay Cycles. Defined during the Payroll Setup Wizard, you can override 
these settings in the Employee Roles dialog box. See the Defining Employee 
Roles section for details. 

6. Define Time Code defaults. See the Defining Time Codes section for details. 

7. (Optional) If needed, define your holidays. See the Defining Holidays topic of the 
ServiceCEO Help System for details. 

8. Configure specific employee records 

o Payroll Setup. See the Employee Payroll Setup Tab topic of the 
ServiceCEO Help System for details. 

o Work hours. See the Employee Work Hours topic of the ServiceCEO Help 
System for details. 

9. Enter time cards. See the Time Cards Overview topic of the ServiceCEO Help 
System for more on Time Cards. 

10. Calculate paychecks. 

11. Review employee payroll history. See the Employee Payroll History Tab topic of 
the ServiceCEO Help System for details. 

 

Caution: 
Depending on your company's business processes, steps 2-9 are optional. Please 
review the specific sections below to determine if you want to configure this 
section of ServiceCEO's payroll functionality or not. There are no adverse effects 
of not using a particular portion of payroll. 

 

Tip: 
For more information on payroll, and solutions to common payroll issues, please 
also read the Frequently Asked Questions about Payroll topic of the ServiceCEO 
Help System. 

The Payroll Setup Wizard 
The Payroll Setup Wizard provides you with a quick, easy method of configuring 
employee payroll in ServiceCEO. It will automatically configure the payroll settings for 
all of your employees. However, note that after you run the wizard, you can always 
configure the settings for individual employees in the appropriate employee record. 
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You can access the Payroll Setup Wizard from several places: 

• Click Payroll Setup Wizard from the Payroll Options dialog box. 

• If you haven't already run the Payroll Setup Wizard, it will appear when:  

• You select the Use Time Cards or Pay by Work Hours check boxes on the 
Payroll Setup tab of an employee record. 

• You access the Payroll or Time Cards tabs of the Office Duties area. 

 

Caution: 
You can run the Payroll Setup Wizard at any time. However, running the Wizard 
again after the first time will override any previous settings you may have made 
for individual employees.  
If you have run the wizard, a reminder will appear, informing you of this fact. 

Once you access the Payroll Setup Wizard, an introductory page appears. Click Next to 
open the next page of the Payroll Setup Wizard. The settings on this page will overwrite 
the Pay Cycle and Start of First Pay Period fields in the Employee Roles dialog box. 

 

1. Select the date on which you want to start using ServiceCEO for your payroll 
from the first drop-down list.  

 

Tip: 
Since all payment frequencies operate on a weekly basis, we recommend 
defining your payroll start date on a Sunday or Monday so that your pay periods 
conform to a typical week. 

2. Select the frequency on which you pay your employees from the second drop-
down list. 
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3. Click Next. The third page of the Payroll Setup Wizard appears. 

 

4. Select the option that corresponds to how you pay your hourly (non-salaried) 
employees: 

o I pay my employees based on the time they spend working on 
customer jobs. This will automatically deselect the Pay by Work Hours 
check box on the Payroll Setup tab for all employees. This option means 
that employees will only be paid for the jobs and tasks that they work on, 
just like previous versions of ServiceCEO. 

o I pay my employees for a full shift, regardless of how many jobs they 
work on during that shift. This will automatically select the Pay by 
Work Hours check box on the Payroll Setup tab for all employees. The 
Pay by Work Hours check box will consider both the employee’s paid 
work hours and the time spent on work assignments (jobs, tasks, etc.) in 
calculating the employee’s pay. Work hours are used to calculate a base 
pay for the employee, which can be overridden at the job or task level.  

 

Tip: 
If using Pay by Work Hours, keep in mind an employee can only be paid for one 
assignment at one time. This means that you will need to make sure that start and 
end times of jobs and tasks are properly recorded. If multiple assignments 
accidentally overlap, ServiceCEO will choose one assignment to determine pay 
for the overlapping period. 

5. Click Next. The Fourth page of the Payroll Setup Wizard appears. 



Implementation Checklist 

71 

 

6. Select the first option button to pay employees based on their work hours without 
using Time Cards (i.e., the Use Time Cards check box will not be selected on all 
employees' Payroll Setup tab). 
 
Select the second option button to pay employees based on Time Cards (i.e., the 
Use Time Cards check box will be selected on the Payroll Setup tab of all 
employee records). 

7. Click Next. The fifth page of the Payroll Setup Wizard appears. 

 

Caution: 
The second Time Cards page will only appear if you select the second option 
button on the first Time Cards page. 
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8. Select the check box corresponding to the frequency by which you want to enter 
time cards. You can also define this setting in the Payroll Options dialog box. The 
frequency you select here will automatically populate the Enter Time Cards 
every X days field in the Payroll Options dialog box. 

9. Click Next. The Final page of the Payroll Setup Wizard appears. 

 

10. Click Finish. All of your hourly employees are now configured for payroll. 

Defining Payroll Options 
You can control your payroll options in the Payroll Options dialog box. Configurable 
options include the Payroll Setup Wizard, travel time costing, and employee commission 
splitting. 

To define payroll options: 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Select Payroll from the Categories bar. The Payroll Options dialog box appears.  
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3. Click Payroll Setup Wizard to run the Payroll Setup Wizard. See the Using the 
Payroll Setup Wizard section for details. 

4. To include travel time in your job costing calculations, select the Cost travel time 
to: check box and select a value from the drop-down list:  

o Previous Job/Task. Travel time is included in the cost of the job/task 
immediately preceding the travel. 

o Next Job/Task. Travel time is included in the cost of the job/task 
occurring immediately after the travel. 

o Both (split). The cost of the travel time is split between the two jobs/tasks 
occurring before and after the travel. 

5. Select frequency by which you want to enter time cards in the Enter Time Cards 
every X days field. You can also define this setting in the Payroll Setup Wizard. 
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6. Select the option button corresponding to how you want to pay out commissions 
to commissionable employees. The three options are: 

o Do not split commissionable charge. The commission will not be split, 
meaning that all commissioned employees will be paid their full 
commission. For example, two employees receiving a 10% commission on 
a $100 service would both be paid $10. 

o Split commissionable charge among only commissioned individuals on 
the job. The commission for the job is split among all commissioned 
employees. For example, two employees receiving a 10% commission on 
a $100 service would be paid $5 a piece (10% of $50). Non-commissioned 
employees do not factor into this calculation.  

o Split commissionable charge among all individuals on the job. The 
commission will be divided amongst all employees but only 
commissioned employees will receive payment. For example, two 
employees receiving a 10% commission working with three non-
commissioned employees on a job with a $100 service will split the 
commission five ways; all commissioned employees will be paid $2 and 
all non-commissioned employees will receive no commissions. 

To demonstrate, for a commissionable charge of $100.00 on a job with three 
employees assigned to it: 

Tools > Options > Payroll Options setting  Pay 
Commissions? 
(defined via 
Employee Role 
or a Service/ 
Product Item) 

Do not split 
commissionable 

charge 

Split 
commissionable 
charge among 

only 
commissioned 
employees on 

the job 

Split 
commissionable 
charge among 
all employees 

on the job 

Empl. 1 Yes (10%) $10.00 $5.00 $3.33 

Empl. 2 Yes (20%) $20.00 $10.00 $6.66 

Empl. 3 No N/A N/A N/A 

 

Tip: 
Another way of looking at commissionable charge splitting is that ServiceCEO 
will apply the employee’s commission percentage to the total sale of the service, 
then divide it by the number of employees on the job. In other words: 
(Sale * Commission rate) / # of Employees. 
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7. If one of the last two option buttons in the Commission section are selected, the 
Include Sales Reps in Commission Split check box will be selected by default, 
meaning that your sales representatives will be included in any payroll 
commission splitting.  
To remove sales reps from this commission split, deselect the check box.  

8. Select the Pay commission on amounts covered by Service Contracts check 
box to pay a commission on all moneys mentioned in a service contract. For more 
on service contracts, see the Enabling Service Contracts topic. 

9. Click OK. 

Defining Time Codes 
ServiceCEO is shipped with a set of time codes designed to meet the needs of most 
businesses. Time codes provide three settings to the time blocks to which they are 
assigned: 

• Availability. Determines if the employee is available or unavailable for work. 

• Hourly Employee Setup. Determines if the time block is eligible for payroll or 
not.  

• General Ledger Account. If integrated with an Accounting Account, determines 
the account to which pay associated with this time code will be exported. 

Time code setup is hierarchical. This means that values not explicitly defined are 
inherited from a higher level in your company hierarchy. Thus, if you define time codes 
for your entire company, these values will propagate down to all of the companies' 
employees. Accordingly, if you then edit an employee's time codes, the new values will 
override the company level time code for that employee.  

 

Tip: 
When you save an employee-level override of a company-level time code, the 
edited time code row will appear in bold. Afterwards, if you change the 
employee-level time code's values to match the company, the override will be 
deleted when the record is saved. 

You can access the Time Code Setup dialog box from two places: 

• For the entire company, select Tools > Lists > Time Codes. 

• For an individual employee, click Time Codes from the employee record. 
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Tip: 
The values for Color, Active, Name, and Available for Work can be updated for 
the entire organization. However, they cannot be updated for individual 
employees or, if you are running ServiceCEO Enterprise, specific branches. 

Adding Time Codes 
If you'd like, you can add new time codes to ServiceCEO.  

1. Open the Time Codes dialog box. 

2. If necessary, select the level for which you want to define time codes from the 
Setup for drop-down list. 

3. Click Add to add a new time code. 

4. Type the name of the time code into the Code field. 

5. By default, all time codes are active. Deselect the Active check box if you don’t 
want it to appear in the list when you select a Time Code elsewhere in 
ServiceCEO. 

 

Note: 
Time codes which are in use in the database cannot be deleted. However, they 
can be deactivated, which will make them unavailable for selection on new 
records. 



Implementation Checklist 

77 

6. Select the appropriate value from the Available for Work drop-down list. Your 
options are: 

o Available. Indicates employees with this time code are available for work. 

o Unavailable. Indicates employees with this time code are not available for 
work. 

o Busy. Busy is generally used to mark time spent on a job. It indicates that 
an employee is not available to be scheduled for work because they are 
busy working (as opposed to explicitly unavailable time like a vacation).  
Note that you cannot schedule an employee to be Busy (i.e., you cannot 
assign an employee a time code with a Busy value on the Work Hours or 
Work Hours Override screen). 

7. Select the appropriate value from the Hourly Employee Setup drop-down list. 
Your options are: 

o Include. This time code will be used to calculate payroll for hourly 
employees. 

o Exclude. This time code will NOT be used to calculate payroll for hourly 
employees. 

o Include/No Overtime. This time roll will be used to calculate normal 
payroll for hourly employees, but will not be used towards calculation of 
overtime. 

 

Caution: 
The Hourly Employee Setup selection only controls hourly payroll. It will not 
affect employees being paid commissions, a flat fee, or a salary.  

8. To link a time code with a particular accounting account, click the "three dots" 
button in the General Ledger Account column and select the appropriate account 
from the subsequent dialog box. 

 

Tip: 
The General Ledger Account column appears only if Accounting Integration is 
enabled. 

9. To add additional time codes, repeat steps 3-8. 

10. When complete, click OK. 
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Editing Time Codes 

1. Open the Time Code Setup dialog box.  

2. If necessary, select the level for which you want to define time codes from the 
Setup for drop-down list. 

3. Edit the time code values as necessary. 

 

Note: 
Note that you cannot deactivate time codes that are in use. In addition, the Job, 
Task, and Travel are built-in time codes which cannot be renamed or have their 
Available for Work status changed. 

4. Click OK. 

Deactivating Time Codes 
You cannot delete time codes that are in use, or have been used in the past. You can, 
however, deactivate time codes, meaning that the time code will not be removed from 
current configurations, but you will not be able to select the deactivated time code from 
any Time Code drop-down list moving forward.  

1. Open the Time Code Setup dialog box.  

2. If necessary, select the level for which you want to deactivate a time code from 
the Setup for drop-down list. 

3. Clear the Active check box for time code you want to deactivate. 

4. Repeat steps 3-4 to deactivate additional time codes. 

5. Click OK. 

Defining Scheduling Options 
The Scheduling option enables you to customize the application's scheduling 
possibilities. Here, you can define the company's work week, job duration measurement, 
and many other options. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Scheduling from the Categories bar. The Scheduling Options dialog box 
appears. 
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3. Select the appropriate check boxes to enable its functionality. The available check 
boxes are: 

o Enable Job/Schedule substatuses. Select this check box to enable the 
substatus field in jobs. This allows a more detailed status for jobs, beyond 
the default statuses (Canceled, Active, Completed and Pending). See the 
Defining Substatuses section for details. 

o Enable Project Management. Select this check box to enable the 
creation of projects. A project is a job that is performed over several days 
or visits and is combined into one invoice. If this check box is not 
selected, the project button will not appear in the job record or in the 
various right-click menus. For more on projects, please read the Project 
Overview topic of the ServiceCEO Help System. 

o Enabling Scheduling Picklist. Select this check box to enable scheduling 
picklists. The Picklist is a list of all active jobs that do not have specific 
engagement times. The picklist is used to accommodate customers with 
tight schedules who may not know when they can be serviced until the day 
their job is scheduled to be performed. 

o Enable Manual Budgeting. Select this check box to enable manual 
budgeting. Manual budgeting lets you define estimates for job costs 
(services, materials, labor, etc.) that, after the job is completed, can be 
compared to the actual job using the Job Costing report. The manual 
budgeting fields are the Charge, Labor, and Materials fields located on 
the right side of the Job record page. 
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o Enable Team Lock. Select this check box to enable users to lock any 
team for a day, meaning that no changes can be made to the team 
(add/remove members, assign/move jobs to or from the team) for that day. 
See the Locking a Team from the Dispatch Board topic of the ServiceCEO 
Help System. 

o Check Scheduling Conflicts when Saving Jobs and Dispatching. Select 
this check box to warn you if an employee is already committed to another 
job or task when saving a job or making a change on the Dispatch Board. 
This will ensure that your employees are not scheduled for multiple jobs at 
the same time. 

o Check Work Hours when Saving Jobs and Dispatching. Select this 
check box to enable automatic review of available employee hours when 
you save a job or make changes on the Dispatch Board. This will help 
ensure that there are no time conflicts. See the Employee Work Hours 
topic of the ServiceCEO Help System for more. 

o Check Overtime Rules when Saving Jobs and Dispatching. Select this 
check box to warn you if a job's settings will create overtime pay for the 
employees assigned to the job. The warning will appear if overtime rules 
are called when saving a new or edited job, or when any changes are made 
to the job via the Dispatch Board. For more on overtime, see the Defining 
Overtime Rules topic of the ServiceCEO Help System. 

o Check Skill Sets when Saving Jobs and Dispatching. Select this check 
box to compare the required skills for a job with the skill sets of the 
employees assigned to it. If they do not match, then a warning dialog box 
will appear when a new job is saved, or the job is reassigned via the 
calendar or the Dispatch Board. See the Employee Skills Tab topic of the 
ServiceCEO Help System. 

 

Tip: 
Note that the four check boxes that begin with Check... will cause warning 
dialog boxes to appear whenever a conflict is generated. For example, if the 
Check Scheduling Conflicts when saving jobs and dispatching check box is 
selected, and you create a new job for employee X at the same time that 
employee X is scheduled to work on another job, a warning dialog box will 
appear informing you of the conflict. 

4. Select the number of days in a week your company is open from the works a X 
work week drop-down list. 

5. Select the time at which your company is open for business from the first spin 
control box. 

6. Select the time at which your company is closed from the second spin control 
box. 



Implementation Checklist 

81 

 

Note: 
Steps 4-6 control your company's default work hours. The values you enter here 
will be displayed in white on the Daily and Weekly Views of the Calendar (as 
opposed to gray) and in light yellow in an employee's Work Hours dialog box (as 
opposed to dark yellow). 

7. Select the option button corresponding to how you want to calculate the duration 
of a job. Your options are: 

o Man-hour based Scheduling. Calculated by dividing the total hours for 
the job by the number of workers assigned to that team. For example, if 
you have a 4 hour job and there are 2 individuals (that work on site) on the 
assigned team, the Duration will be displayed as 2 hours. If there were 
only one individual on the assigned team, the Duration would be displayed 
as 4 hours. 

o Duration-based Scheduling. Calculated by using the total hours of the 
job, regardless of amount of employees assigned to the job. For example, a 
4 hour job will take up 4 hours of time, regardless of whether there are 1, 
2, 3, or more employee(s) assigned to it. 

8. Click OK.  

Entering Employees 
To add a new employee in ServiceCEO: 

1. Click Employee from the Navigator bar. The Employee List appears.  

2. Click New or select File > New Employee. The General tab of a new employee 
record appears. 

3. Enter the employee's data on the relevant tabs. See the appropriate topics of the 
ServiceCEO Help System for details: 

o Employee General Tab 
o Employee Detail Tab 
o Employee Signouts Tab 
o Employee Personnel File Tab 
o Employee Links Tab 
o Employee Payroll Setup Tab 
o Employee Skills Tab 
o Employee Payroll History Tab 

 
4. When done, click Save and Close. The Employee List appears, displaying the 

new employee. 
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Defining Employee Skills 
Skills are the abilities a particular employee possesses. For more, see the Employee Skills 
Tab topic of the ServiceCEO Help System. 

Creating Skills 
To manually define skills: 

1. Select Tools > Lists > Skills. The Skills dialog box appears.  

 

2. Click Add to add a new row. 

3. The Active check box is selected by default. Deselect this check box if you do not 
want anyone to use this skill. 

4. Type a name for the skill in the Skill Type field. 

5. Type a brief description of the skill in the Description field. 

6. Select Yes from the Skill Req by All Emps? drop-down list. If selected, any job 
requiring this skill will then need ALL employees assigned to the job to have the 
requisite skill. If not selected, only one employee will need the skill. 

7. Repeat steps 2-6 to add additional skills. 

8. Click OK. 

Editing Skills 

1. Select Tools > Lists > Skills. The Skills dialog box appears.  

2. Edit any of the skills fields as necessary. 

3. Click OK. 
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Deleting Skills 
If a skill is in use, meaning that it is assigned to at least one employee, the skill cannot be 
deleted. In these instances, we recommend you deactivate the skill by clearing its Active 
check box. Doing so means that the skill will continue to be assigned to those employees 
and jobs who had it before, but the skill will not be able to be assigned in the future. 

1. Select Tools > Lists > Skills. The Skills dialog box appears.  

2. Select the skill you want to delete. 

3. Click Delete. A confirmation dialog box appears. 

4. Click Yes. The Skill is deleted.  

5. Repeat steps 2-4 to delete additional skills. 

6. Click OK. 

Creating Teams 
A team is a group of employees that work together. When a team is assigned to a job, all 
of the team's employees will work on the job. Teams are created and populated in the 
Team dialog box - you can create a team, add employees to it, and default values for the 
team. 

 

Note: 
The team's default employees are in the Team dialog box; however, you will 
always be able to customize a team's employees for an individual job. This 
customization can be defined through the job record, the dispatch board, and the 
completion wizard. 

A Team's default values enable you to control which teams can be assigned to which 
jobs. First, you define default values for your teams as described below. Once these 
values are defined, selecting the SmartList check box on the General tab of a job record 
will limit the teams displayed in the Team drop-down list to those teams whose default 
values match the job's values. For more, see the Jobs General tab topic of the 
ServiceCEO Help System. 

 

Tip: 
If you no default values to a team, then, for SmartList purposes, the team will 
appear for all of those values. For example, if you do not select any zones in the 
Team dialog box, the team will appear for all zones when the SmartList check 
box is selected. 
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Creating Teams 

1. Select Tools > Lists > Teams List or press CTRL+F1. The Team dialog box 
appears. 

 

2. Select File > New or click New. A new row appears. 

3. Type a name for the new team in the Name field. 

4. The Active check box is selected by default. Deselect it if you do not want the 
team to be visible when assigning jobs.  

5. Click the appropriate check box for every employee you want to assign to this 
team in the Employee Name section.  

6. Click the appropriate check box for every zone you want to assign to this team in 
the Zone section. 

7. Click the appropriate check box for every customer type you want to assign to this 
team in the Customer Type section. 
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8. Click the appropriate check box for every Master Service/Product Category you 
want to assign to this team in the Categories section. For details on Master 
Product/Categories, read the Master Service-Product Categories Overview 
section. 

9. Click the appropriate check box for every appointment type you want to assign to 
this team in the Appointment Type section. For details, read the Defining 
Appointment Types topic of the ServiceCEO Help System. 

10. Click the appropriate check box for every substatus you want to assign to this 
team in the Substatus section. For details, read the Defining Substatuses section.  

11. Repeat steps 3-10 for each additional team. 

12. Click Save and Close. The Team dialog box closes. 

Editing Teams 

1. Select Tools > Lists > Teams List or press CTRL+F1. The Team dialog box 
appears. 

2. Select the team you want to edit. 

3. Make any necessary changes to the team Name or Active fields. 

4. Add or remove employees and default values by selecting or deselecting the 
appropriate check boxes.  

5. Click OK. 

6. Click Save and Close. 

Deactivating Teams 
You cannot delete teams that are either currently assigned to a job or have worked on a 
job in the past. You can, however, deactivate a team, meaning that the team will not be 
able to be assigned to any work moving forward. 

 

Tip: 
Teams that are assigned to active or pending jobs cannot be deactivated. If you 
want to deactivate the team, you will need to either assign those jobs to another 
team, or wait until the scheduled jobs are completed or canceled. 

1. Select Tools > Lists > Teams List or press CTRL+F1. The Team dialog box 
appears. 

2. Select the name of the team you want to deactivate. 

3. Clear the Active check box. The team is deactivated. 
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4. Click Save and Close. 

If a team has never performed any work, you can delete it by selecting it in the Team 
dialog box and clicking .  

Enabling Service Contracts 
You can use ServiceCEO to create service contracts for your customers. For more on 
Service Contracts, please read the Service Contracts topic of the ServiceCEO Help 
Systems.   

To enable service contracts: 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Contracts from the Categories bar. The Contracts Options page appears. 

 

3. Select the Enable Service Contracts check box to enable the use of service 
contracts. 

4. Select the Print the Disclaimer and Agreement statements on Contracts check 
box to include the disclaimer and agreement on printed invoices. 

5. Click Edit Disclaimer. The Edit Disclaimer dialog box appears. 

6. Edit the disclaimer as necessary. 

7. Click Save. The new invoice is saved. 
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8. Click Edit Agreement. The Edit Agreement dialog box appears. 

9. Edit the agreement as necessary. 

10. Click Save. The new agreement is saved. 

11. Type the subject line for your e-mail message in the E-mail Subject Line field.  

12. Type the text of the e-mail message in the E-mail Body field.  

13. Click OK. The Contracts Options dialog box closes. 

Defining Customer Subtypes 
You can define subtype groups that organize your customers into groups beyond the 
individual/corporate distinction.  

Note that while you cannot delete customer subtypes, you can make them inactive, 
meaning that you will no longer be able to assign them to customers. 

Adding Customer Subtypes 

1. Select Tools > Lists > Customer Subtypes. The Customer Subtypes dialog box 
appears. 

 

2. Click Add. A blank row will appear. 

3. The Active check box is selected by default. Deselect it if you do not want the 
team to be visible when assigning jobs. 

4. Type a descriptive name for the new customer subtype in the Subtype field. 

5. Type a description for the new customer subtype in the Description field. 

6. Click OK. 
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Editing Customer Subtypes 

1. Select Tools > Lists > Customer Subtypes. The Customer Subtypes dialog box 
appears. 

2. Edit any of the subtype fields as necessary. 

3. Click OK. 

Enabling Equipment Tracking 
You can use ServiceCEO to track the equipment you have located at customer sites. 
Enabling equipment tracking will display Equipment tabs in several different locations in 
ServiceCEO. For more on equipment tracking, please read the Equipment topic of the 
ServiceCEO Help Systems. 

To enable equipment tracking: 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Equipment from the Categories bar. The Equipment Options page appears. 

 

3. Select the Enable tracking of On-Site Equipment check box to track your 
equipment. 

4. Click OK. The Equipment Options dialog box closes. 
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Configure Reporting Options 

Defining Reporting Options 
You can define the manner in which ServiceCEO’s reports are displayed in the Reporting 
Options dialog box. 

To define your report options: 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Reporting from the Categories bar. The Reporting Options dialog box 
appears. 

 

3. Adjust the settings for individual reports as necessary. These include: 

o The Invoice/Work Order/Estimate Report 

o The Statements Report 

o The Route Sheets Report 

4. Click OK. 

Adjusting Invoice/Work Order/Estimate Report Options 
The Work Order, Invoicing, and Estimate reports contains all the information an 
individual or team of employees would need to know for a single job, including any 
customer or job notes. You can define all of the options for these reports on the 
Invoice/Work Order/Estimate Options page. 
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To set the options for the Invoice, Work Order, or Estimate reports:  

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Reporting from the Categories bar. The Reporting Options dialog box 
appears. 

 

3. Click Invoice/WO/Estimate. The Invoice/Work Order/Estimate dialog box 
appears. 
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Company Settings 

1. Select the Print Company Information in Header check box to include 
company information in the header of all printed Invoices, Work Orders, or 
Estimates. 

2. If you selected the Print Company Information in Header check box, next 
select the check boxes corresponding to the information you want to include in 
the header. These options include:  

o Phone 

o Fax 

o Web 

o E-mail 

 

Tip: 
The specific values for these fields are defined in the Company Information 
dialog box. See the Defining Company Information section for details. 

3. Select the option button corresponding to the company segment from which you 
want to pull the company information.  
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Note: 
You can only select the Customer's region or Customer's branch option buttons if 
you are running ServiceCEO Enterprise. 

4. Type your billing terms into the Enter Billing Terms field. Billing terms refers to 
the description of when the payment of the Invoice, Work Order, or Estimate is 
due (i.e. Net 30, upon receipt, etc.). 

Customer Settings 

1. Select the Include Day Phone Number and Include Evening Phone Number 
check boxes to include the company's phone number(s) on your work orders and 
classic invoice reports. 

2. Select the Include E-mail Address check box to include the company's e-mail 
address to your work orders and classic invoice reports. 

3. Select the Include Work Address Name check box to include the name of the 
company's work address to your work orders, invoices and estimates. 

4. Select the length of time you would like Customer Notes added to Work Orders 
by selecting the appropriate option button. 

Invoice/Estimate Style 
Select the option button corresponding to the style in which you want to display your 
invoices and estimates. Your options are: 

• Classic Layout. This option will display the Invoice similar to a Work Order. 
Only a single work location and job information (arrival time, work date, etc.) is 
displayed. Note that this options will NOT display kits as a single line item 
despite which Invoice As option you have selected.  

• CEO Layout. This option can display multiple jobs, products, and multi-visit 
jobs. This option can also display kits as a single line item (if that option is 
selected in the Kit's Invoice As drop-down list).  

Work Orders 

1. Select the Print Charges on Work Orders check box to display all of the 
charges on a printed work order. 

2. Select the Print Add-On Section check box to include additional blank lines to 
printed work orders. 

3. If you selected the Print Add-On Section check box, type the number of lines 
you want to add in the lines spin control box. 



Implementation Checklist 

93 

4. Select the Print unmarked alarm code beneath Work Order number to 
include the alarm code under the work order number. This number will not be 
labeled. 

 

Note: 
The alarm code appears without a label on the report so that your Customer's 
sensitive information is not compromised if the report is lost or stolen in the 
field. 

Footers and Disclaimer Statements 

1. Select the Print the Disclaimer and Agreement statements on Invoices check 
box to include the disclaimer and agreement on printed invoices. 

 

Caution: 
The Disclaimer and Agreement statements are shipped with default text. Thus, if 
you select the Print the Disclaimer and Agreement statements on Invoices 
check box, you must edit the disclaimer and agreement text. 

2. Click Edit Disclaimer. The Edit Disclaimer dialog box appears. 

 

3. Edit the invoice disclaimer as necessary. 

4. Click Save. The new invoice is saved. 

5. Click Edit Agreement. The Edit Agreement dialog box appears. 
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6. Edit the customer agreement as necessary. 

7. Click Save. The new agreement is saved. 

8. Repeat steps 1-7 for the Work Order and Estimate statements. 

9. Type the text for your estimate's footer in the Estimate Footer Line field. 

E-mail Integration - MS Outlook 

1. Type the subject line for your e-mail messages in the E-mail Subject Line field.  

2. Type the body for your e-mail messages in the E-mail Body field.  

When you have finished customizing your Invoice, Work Order, and Estimate reports, 
click OK. The Invoice/Work Order/Estimate dialog box closes. 

Adjusting Statements Report Options 
The Statement report provides a summary of all invoices created during a date range. 
These reports can be used for general information purposes or as actual bills to be sent to 
the customer for remittance. 

To adjust the statement report options: 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Reporting from the Categories bar. The Reporting Options dialog box 
appears. 
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3. Click Statements. The Statement Reports - Settings dialog box appears.  

 

4. In the Statement Footer Line field, type the text you want to appear as a footer 
in both the Statement and the bottom of the payment coupon. 

5. Select the Show Receivables Aging in Footer check box to break down the 
account by time. If selected, the report will display what the customer currently 
owes you. 

6. Click OK. The Statement Reports - Settings dialog box closes. 

Adjusting Route Sheets Report Options 
The Route Sheets report is a summary of all service jobs within a given date range. You 
can customize this report to suit your company's needs. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Reporting from the Categories bar. The Reporting Options dialog box 
appears. 
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3. Click Route Sheets. The Route Sheets - Settings dialog box appears.  

 

4. Select the phone number you want to display on the Classic style route sheet from 
the drop-down list. 

5. Select the Show notes check box to display the job's notes on the Classic and 
CLIP™ style route sheets. 

6. Select the Show address check box to display customer addresses on the Classic 
and CLIP style route sheets. 

7. Select the Show total charge amount check box to display the total amount 
charged to the customer for the job on the Classic and CLIP style route sheets. 
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8. Select the Show unmarked alarm code field check box to display the alarm code 
on the Classic and CLIP style route sheets. 

 

Note: 
The alarm code appears without a label on the report so that your customer's 
sensitive information is not compromised if the report is lost or stolen in the 
field. 

9. Click OK. The Route Sheets - Settings dialog box closes. 

Security Rights / User Groups 

Security Overview 
Keeping your data secure is essential, which is why security is an extremely important 
element of ServiceCEO. The ServiceCEO user security system allows you to clearly 
define what information can be viewed, modified, or entered by each user with access to 
the application. 

The ServiceCEO administrator can set access rights (user names and passwords) and 
permissions for all other users. In other words, the administrator determines not only who 
has access to ServiceCEO but also who access to the application's individual features. 

To access the security area, log on as the Administrator and selecting Tools > Options > 
Security. User Access Rights dialog box appears. The dialog box has two subsections: 

• Groups - A grouping of users with identical security access rights. See the 
Managing User Groups section. 

• Users - The individual people who will be accessing the system. See the 
Managing Users section. 

Users are assigned to groups, and security rights and access levels are assigned to the 
groups. 

Show Connected Users 

On both the Groups and Users tabs, you can display all of the users that are currently 
connected to the application by clicking Show Connected Users. The Connected Users 
dialog box appears. 
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This dialog box displays all of the users that are connected to the system. 

To disconnect a user, select their name and click Disconnect. The user will be 
immediately disconnected from ServiceCEO. 

Managing User Groups 
A user's user group controls the user’s access rights. In other words, access rights are not 
defined via individual users but by the user group or groups to which that user belongs. 
To change a user's security rights, you can edit the groups to which a user belongs or edit 
the security rights of the entire group. However, note that editing the security rights of an 
entire group will affect every member of that group. 

Adding New User Groups 
New users can be added to ServiceCEO by the Administrator. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Security from the Categories bar. The Admin - User Access Rights dialog 
box appears. 

 

3. Click New, press CTRL+G, or select File > New > New Group. The Details and 
Rights sections will become active. 

4. Type the group's name into the Name field. 

5. Type a description of the group in the Notes field. 
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6. Select the appropriate check boxes in the Rights section to determine the security 
rights of each user that will be assigned to this group. An explanation of each 
security setting is located in the Security Rights Table. 

 

Tip: 

To quickly assign all rights to the group, click . To quickly remove all access 

rights from a group, click . 

7. Repeat steps 3-6 to add additional groups. 

8. When complete, click Save and Close. 

Editing User Groups 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Security from the Categories bar. The Admin - User Access Rights dialog 
box appears. 

3. Select the user group you want to edit. 

4. Make any changes to the user group as necessary. An explanation of each security 
setting is located in the Security Rights Table topic of the ServiceCEO Help 
System. 

 

Tip: 

To quickly assign all rights to the group, click . To quickly remove all access 

rights from a group, click . 

5. Repeat steps 3-4 to edit additional groups. 

6. When complete, click Save and Close. 

Deleting User Groups 
You can delete any user group in ServiceCEO. No confirmation notice appears, so be 
sure you want to delete the user group before you click Delete. Note that deleting a user 
group will automatically remove the security rights of that group from all users assigned 
to that group. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Security from the Categories Bar. The Admin - User Access Rights dialog 
box will appear. 
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3. Select the name of the group you would like to delete. 

4. Click Delete. 

5. Click Save and Close. 

For a complete listing of all of the security rights in ServiceCEO, please see the Security 
Rights Table topic of the ServiceCEO Help System. 

Managing Users 
On the users tab of the Security Options window, you can define user accounts for all 
people using ServiceCEO. Any person logging into ServiceCEO will need a Login and 
Password combination. This combination can only be used by one person at a time. In 
addition, you will need to have a user license for every Login in ServiceCEO. The 
number of users for which you are licensed is controlled by your Activation Code. If a 
user attempts to login with a Login name that is already in use, or if the number of 
allotted users has been exceeded, you will receive an error message. 

Adding New Users 
New users can be added to ServiceCEO by anyone with right to edit security settings. 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Security from the Categories bar. The Admin - User Access Rights dialog 
box appears. 

3. Click the Users tab. 
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4. Click New, click Add, press [CTRL]+U, or select File > New > New User. The 
Information and Member Of sections becomes active. 

5. Type a login name for the user in the Login field. What is used as the login name 
is entirely up to the discretion of the individual creating the new user. However, 
we advise you use standardized login names. 

6. Type a password for the user in the Password field. The password will appear as 
asterisks for added security. 

7. Retype the password in the Verify field to ensure that the password was spelled 
accurately. 

8. Type the user’s complete name into the Full Name field. 

9. Type the user's e-mail address in the E-mail field. 

 

Caution: 
For security reasons, we highly recommend that you edit the Administrator's 
password from its default value. 

10. Select the check boxes for each user group you want to assign to this customer 
from the Member Of section. The user groups control what security rights the 
user will have. 

 

Note: 
If a user is a member of two groups, one group with a particular security right 
(X) and the second without security right X, the user will have that security right.

11. Repeat steps 4-10 to add new users. 

12. When you have finished adding users, click Save and Close. 

Editing Users 

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Security from the Categories bar. The Admin - User Access Rights dialog 
box appears. 

3. Click the Users tab. 

4. Select the user who you would like to edit from the Users list. 

5. Make any appropriate changes to the user as necessary. Add or remove the user 
from groups as needed by selecting or deselecting the appropriate check boxes in 
the Member Of section. Note that this will affect the user's security rights. 
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6. When you are finished, click Save and Close. 

Removing Users 
In order to ensure data integrity, you cannot delete users after they have been created. 
Given this limitation, if you want to block a user from accessing ServiceCEO, we 
recommend you change the user's password and deselect all of their User Group check 
boxes. This will effectively prevent them from logging into the program. 

Accounting Integration 

Accounting Integration Overview 
ServiceCEO's accounting integration is designed to give you the tools to keep your 
company ledger and balance sheet correct at all times without duplicating data entry 
between ServiceCEO (your management application) and your accounting, banking and 
payables systems. To this end, ServiceCEO can link up with many General Ledger (GL) 
applications in order to transfer data between the two programs. In general, this will be a 
one-way transfer of data from ServiceCEO into the GL application. 

 

Note: 
ServiceCEO was designed and built for accrual-based accounting, meaning that 
sales are recorded when the sale occurs, regardless of when you are paid for that 
sale. When you receive goods or services, you record an expense, regardless of 
when you pay for that expense. 

The GL application that can be most closely integrated with ServiceCEO is 
QuickBooks®. QuickBooks is a popular accounting software program developed by 
Intuit. ServiceCEO can quickly and easily connect with and update the QuickBooks 
general ledger after financial actions are performed within ServiceCEO (i.e., jobs are 
closed, deposits are made, etc). This integration helps reduce errors often associated with 
double entry and cuts down on amount of accounting work that is required to run your 
business. 

XML Integration 

If you are using a GL application other then QuickBooks, ServiceCEO will export a 
representation of your financial transactions in an XML format, saving these transactions 
to a .xml file. Extensible Markup Language (XML) files will be created and saved to a 
designated directory (identified during accounting integration - see the Configuring XML 
Integration topic for details). The XML files are marked with the event date and a serial 
number. These XML files can then be imported into an accounting package. 

This XML Integration does not automatically integrate with any applications, nor is it a 
web service. Rather, it is a manual process that begins with a user clicking an Export 
button in ServiceCEO.  
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Since ServiceCEO does not directly import the XML files into your accounting 
application; you, or your systems integrator, will need to create or purchase an 
application that performs the following actions: 

1. Monitor the directory (as defined in ServiceCEO) for created XML files (aka, a 
"file drop").  

2. Open the XML file and parse the information out of the file.  

3. Load the data from the XML file into an object.  

4. Validate the information. If there are errors, the user should be made aware of 
these errors.  

5. Import the information stored in the object into your accounting package. This 
will most likely require the ability to integrate with your accounting package as 
well as the ability to map fields from the object to the proper fields within your 
accounting application.  

While one example of such a tool is Microsoft® Great Plains® Integration Manager, we do 
not currently recommend any applications that could import XML into an accounting 
package for you.  

 

Caution: 
ServiceCEO exports the GL information into an XML file, but does nothing with 
that file once it is created. You, or your systems integrator, will need to install 
and configure a tool to load data from ServiceCEO XML files into your general 
ledger database. 

For more information about these XML Files, download the XML Software Development 
Kit (SDK). This compressed file contains: 

• ServiceCEOXML.zsd. This XSD file explains the structure of the XML export 
files. 

• Sample XML files. Currently, this includes an example of exported deposits, 
inventory adjustments, paychecks, purchase orders, and two invoice exports 
(identified as Sales and Sales2). 

Exporting Data 

Data can be exported from three locations within ServiceCEO, all located in the Office 
Duties area: 

• Invoices, Transactions, and (if tracking Inventory) Inventory Adjustments through 
the Sales Exports tab.  

• Deposits, including customer payments, through the Deposits tab.  

• Paychecks (gross wage data) through the Paychecks tab.  
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If you are using ServiceCEO's Inventory module, you can also export your Purchase 
Orders from the Purchase Order record. 

 

Tip: 
While you do not need to be logged into ServiceCEO as an administrator to 
export data an accounting package, only users with the proper security settings 
can export data from ServiceCEO. See the User Groups section for details about 
security settings. 

QuickBooks Overview 
QuickBooks® is a popular accounting software program developed by Intuit. ServiceCEO 
can quickly and easily link up with your QuickBooks application to facilitate data sharing 
between the two programs. Basically, you can export financial information from 
ServiceCEO to the QuickBooks general ledger when certain financial actions are 
performed within ServiceCEO (i.e., invoices are posted, deposits are made, etc). While 
this integration is limited to only financial data - ServiceCEO does not export customer 
information or payment application information - sending financial data from 
ServiceCEO to QuickBooks helps reduce errors associated with double entry and cuts 
down on the amount of accounting that needs to be done.  

 

Caution: 
Due to limitations with the QuickBooks import utility, ServiceCEO cannot 
export payroll into QuickBooks.  

Before you integrate QuickBooks with ServiceCEO: 

• You will need QuickBooks 2002, 2003, 2004, 2005, 2006, 2007, or 2008. Note 
that ServiceCEO does not integrate with the Basic, Simple Start, or Online 
editions of QuickBooks.  

• A version of QuickBooks must be installed on every computer using ServiceCEO 
to export data to QuickBooks. 

• You will need to know the location where QuickBooks is installed. The 
QuickBooks database has a ".qbw" file extension. This file is usually found in 
your QuickBooks directory folder. The default location for this folder is: 
C:\Program Files\Intuit\QuickBooks\databasename.qbw. 

• Read the QuickBooks Deployment Best Practices White Paper (PDF) for tips on 
how to configure your QuickBooks network for maximum efficiency and 
performance. 

• Integration with QuickBooks UK is in an indefinite beta, due to two known 
issues. For details, please read this topic in the Insight Direct Discussion Boards.  
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Caution: 
To integrate the applications, you must be logged into both ServiceCEO and 
QuickBooks as an Administrator. After the programs are integrated, any user 
with the proper Security Rights can export data from ServiceCEO into 
QuickBooks. 

 

Note: 
You can view a training video that covers QuickBooks integration in the 
Member Center.  

Configuring Accounting Integration 
When integrating with a General Ledger (GL) application with ServiceCEO, you need to 
enter or select the GL account names/numbers to which you want to send different types 
of data. This is described in detail in the Integrations sections below.  

If you are integrating with QuickBooks, ServiceCEO imports the account names from 
QuickBooks so that they are synchronized between the two applications. See the 
Configuring QuickBooks Integration section for more. In addition, if you are using 
Inventory Tracking, you can synchronize your vendor information between QuickBooks 
and ServiceCEO. See the Integrating Inventory with Accounting section for details. 

To integrate ServiceCEO with an accounting program, either QuickBooks or a General 
Ledger Application, follow these steps: 

1. Log into ServiceCEO as the administrator. 

2. Select Tools > Options or press CTRL+O. The Options page appears. 

3. Click Company Information from the Categories Bar. The Company 
Information dialog box appears. 

4. Scroll down to the bottom of this dialog box.  
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You can integrate two aspects of ServiceCEO with your accounting application: 

• Sales, purchasing and Accounts Receivable. Can be linked to XML or 
QuickBooks. To integrate with QuickBooks, please read the Configuring 
QuickBooks Integration section. To integrate with XML, please read the 
Configuring XML Integration section. 

• Payroll Integration. Please read the Configuring XML Integration section to 
learn how to integrate payroll with a GL application. 

Once integrated, you can export the data to the accounting application: 

• Accounts Receivable and Adjustments. See the Export Sales topic of the 
ServiceCEO Help System. 

• Payments. See the Export Deposits topic of the ServiceCEO Help System. 

• Purchase Orders. See the Exporting Purchase Orders topic of the ServiceCEO 
Help System.  

• Paychecks. See the Exporting Paychecks topic of the ServiceCEO Help System. 
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Configuring QuickBooks Integration 

 

Caution: 
If you are running Microsoft® Vista®, you need to have the User Account Control 
(UAC) enabled in order to integrate with QuickBooks®. If the UAC is disabled, 
you will receive an error. 

To integrate ServiceCEO with QuickBooks: 

1. Select Tools > Options. The Options dialog box appears. 

2. Click Company Information from the Categories Bar. The Company 
Information dialog box appears. 

3. Scroll down to the bottom of this dialog box.  

4. Select the Enable Accounting Integration check box. A group of additional 
fields appears. 

5. Click the "three dots" button next to the Location of the QuickBooks Company 
File field. The Select Company File dialog box appears. 

6. Navigate to the location where your QuickBooks database is located. The default 
location is C:\Program Files\Intuit\QuickBooks\databasename.qbw. 

 

Tip: 
If you are running ServiceCEO on a network and want multiple users to be able 
to access the same QuickBooks database, the QuickBooks database file (a .qbw 
file) must be located on a mapped network drive so that it is located on the same 
path for all ServiceCEO users. 
If not, only the user operating the computer with the QuickBooks database can 
export information to QuickBooks. 

7. Click Open. A warning dialog box appears, reminding you that you must have 
QuickBooks open.  

8. Click OK.  

9. Select the appropriate version of QuickBooks from the Select Package drop-
down list.  

o QuickBooks USA. Select this option if you are running the U.S. version 
of QuickBooks.  

o QuickBooks Canada. Select this option if you are running the Canadian 
version of QuickBooks. 

o ServiceCEO XML. For details on configuring XML accounting 
integration, see the Configuring XML Integration topic. 
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Note: 
By default, ServiceCEO installs QBFC5, the latest QuickBooks Integration Pack. 
This program enables ServiceCEO to integrate with all versions of QuickBooks 
up to QuickBooks 2007.  

10. Click Verify Connection. ServiceCEO will attempt to retrieve the chart of 
accounts from the QuickBooks database (the one displayed in the Select Package 
field). If this is the first time you are integrating your application with 
QuickBooks, a Create New QB Customer? dialog box appears. 

11. Click Yes. QuickBooks will create a customer record called "ServiceCEO". A 
Success dialog box appears. 

 

Note: 
The ServiceCEO customer record is the customer account that will keep your 
Accounts Receivables balance in QuickBooks. Due to a QuickBooks limitation, 
ServiceCEO only links up with QuickBooks’ General Ledger and Chart of 
Accounts, and that the ServiceCEO customer record will act as a generic 
customer record for all of your sales activities. Specific customer and invoice 
information linked to exported sales will not be transferred to QuickBooks, since 
you will have access to all customer information in ServiceCEO (including 
invoices, balances, and accounts receivables). The ServiceCEO and QuickBooks 
integration is designed to give you the tools to keep your company ledger and 
balance sheet correct at all times without duplicating data entry between 
ServiceCEO (your management application) and QuickBooks (your accounting 
application). 

 

Caution: 
If you receive this error after clicking Yes: Error 91 - Object variable or With 
block variable not set  
You may have a customer or vendor with the name ServiceCEO already in your 
QuickBooks file. Since QuickBooks does not allow duplicate customer\vendor 
names, you will need to open change the name of the ServiceCEO 
customer\vendor in QuickBooks. Once the name is changed, you will be able to 
integrate the two applications. 

12. Click OK. The Company Information dialog box reappears. 
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13. Select the appropriate default accounts from the following drop-down lists. The 
accounts you select here will be the default accounts to which your accounting 
information will be exported. You can overwrite these defaults for specific Master 
Products/Services, Master Categories, etc.) as well as when you export the data. 

o Cash Account. All of your customer's Cash, Checks, and Credit Card 
payments will be exported to the account indicated here. Logical accounts 
for the Cash Account field include any Asset or Bank accounts.  

o Tip Account. All money collected as tips in ServiceCEO. Example 
accounts for the Tip Account field are Cash Expenditures (if you pay your 
employees their tips in cash) or Other Current Liability (if you include tips 
in your employee's payroll checks). 

o Inventory Asset Account. The default Inventory asset account; typically 
linked to an Other Current Liability account. Can be overwritten when 
defining Inventory for a Master Product.  

o Default Inventory Loss Account. All lost, damaged, or stolen inventory 
will be exported to the expense account selected here. If your inventory 
loss is for an inventory revaluation, this should be linked to an Asset 
account. If the loss is to indicate the loss of stock, then it can be linked to 
an Expense account. 
Note that this account can be easily changed in the Inventory Loss 
management screen every time you reduce Inventory, so the account you 
select here is for default purposes only. 

o AR Account. Almost all ServiceCEO users link this field to their 
Accounts Receivables account. 

o Default Income Account. Link this account to an Income account. Note 
that this account is for default purposes only - you can change it for each 
individual service line that you offer to your customers. See the 
Integrating Products and Services section for more. 

o Default Adjustment. Used to track all adjustments in ServiceCEO. 
Typical linked accounts are Expense accounts. 

o Default Misc. Expense Account. Used for products that are not included 
in inventory tracking when the inventory tracking module is enabled. 
Typically linked to an Other Expense account. 

o Sales Tax Payable Accounts. One of these accounts will appear for each 
ServiceCEO Tax Code you have configured. Link these to a Long Term 
Liability or Other Current Liability account.  
Note that to view the Sales Taxes in QuickBooks after they have been 
exported, select Reports > Vendors & Payables > Sales Tax Liability 
and drill into the Sales Tax Payable column. 
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Note: 
The Inventory Asset Account, Default Adjustment, and Default Misc. Expense 
Account drop-down lists will only appear if you have Inventory Tracking 
enabled. 

 

Caution: 
If any of your QuickBooks account names contain more than 50 characters, an 
error will be generated when you attempt to export sales or deposit to 
QuickBooks. 

14. Click Save and Close. 

QuickBooks Configuration Settings 

If multiple ServiceCEO users are going to be exporting information to QuickBooks, you 
will need to enable multi-user mode in QuickBooks. To do so: 

1. Open QuickBooks. 

2. Select File > Switch to Multi-user Mode. 

If you want to export information to QuickBooks when the QuickBooks file is not open, 
you must configure QuickBooks to accept data transfers when it is not open. To do this: 

1. Open QuickBooks. 

2. Select Edit > Preferences. The Preferences dialog box appears. 

3. Click Integrated Applications on the left side of the dialog box. 

4. Click the Company Preferences tab. 
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5. Verify that ServiceCEO is selected in the Application Name column. If not, select 
it now. 

6. Click Properties. The Access Rights tab appears. 

 

7. Select the Allow the application to login automatically check box. 

8. Select the Allow this application to access Social Security Numbers and other 
personal data check box. 

9. Click OK. 

10. Click OK. 
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Configuring XML Integration 
Before you begin, you should know or have access to: 

• The location (folder on your computer or network) to which the ServiceCEO 
XML files should be exported. ServiceCEO Enterprise users can configure one 
directory per branch. 

• Account numbers from the accounting system, such as information about the chart 
of accounts. These account numbers will need to be entered in ServiceCEO. 

To integrate Sales, purchasing and Accounts Receivable with XML: 

1. Select ServiceCEO XML from the Enable Sales, Purchasing, and A/R integration 
with drop-down list.  

2. Click  next to the Save Exported Files in Folder field. The Select Company File 
dialog box appears. 

3. Navigate to the location where you want to save your exported XML files. 

 

Tip: 
If you are running ServiceCEO on a network and want multiple users to be able 
to access the same XML folder location, the export folder must be located on a 
mapped network drive so that it is located on the same path for all ServiceCEO 
users. 

4. Type the name of the file to which you want to export each type of account from 
the appropriate fields lists. These are detailed in step 13 in the Configuring 
QuickBooks Integration section. The name you type here will be the name of the 
XML file generated after the export. 

 

Note: 
No information will appear in these drop-down lists. This functionality is only 
used with QuickBooks integration. Type the name of the XML file directly into 
the field. 

To integrate your payroll with XML: 

1. Select the Enable payroll integration with third-party provider check box.  
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Note: 
You cannot integrate your payroll with QuickBooks, only with XML integration. 
Therefore, you can only select the Use accounting package specified above 
check box if you have selected ServiceCEO XML from the previous Select 
Package drop-down list.  
If the Use accounting package specified above check box  is active, selecting it 
will automatically populate the three fields in this section with the values from 
the section above it.  

2. Select ServiceCEO XML from the Accounting Package drop-down list. 

3. Click  next to the Save Exported Files in Folder field. The Select Company File 
dialog box appears.  

4. Navigate to and select the location where you want to save your exported XML 
files. 

5. Click OK. 

 

Tip: 
If you are running ServiceCEO on a network and want multiple users to be able 
to access the same XML folder location, the export folder must be located on a 
mapped network drive so that it is located on the same path for all ServiceCEO 
users. 

6. Enter the appropriate default account numbers in the Default Payroll Expense 
Account field. 

7. Click Save and Close.  

You have now integrated ServiceCEO with an accounting package using default settings. 
You can define detailed integration settings, as detailed in the following sections: 

• Accounts Receivable and Adjustments information. See the Export Sales topic 
of the ServiceCEO Help System. 

• Payments. See the Export Deposits topic of the ServiceCEO Help System. 

• Purchase Orders. See the Exporting Purchase Orders topic of the ServiceCEO 
Help System.  

• Paychecks. See the Exporting Paychecks topic of the ServiceCEO Help System. 

Integrating Taxes with Accounting 
The final requirement for integrating a GL application with ServiceCEO is to associate 
every tax code with a vendor record. This linking will enable you to export tax liability 
information (via the Export Sales tab) so you can track how much sales tax you owe to 
the government.  



Implementation Checklist 

114 

To deposit ServiceCEO's tax information into an accounting account, you need to map 
every Tax Code in ServiceCEO with a matching account in your accounting application. 
To do this: 

1. Select Tools > Lists > Tax Codes. The Tax Codes dialog box appears.  

2. Click  in the Tax Code List field for the tax type that you want to integrate. The 
Tax Code List dialog box appears. 

 

3. Select an appropriate account from the Vendor drop-down list for every tax code. 
If integrated with QuickBooks, the vendors will be pulled from QuickBooks. If 
integrated with XML, type the name of the vendor into the Accounting Vendor 
field. 

4. Click Close. 

5. Repeat steps 2-5 to integrate the tax codes for each active tax type with GL 
vendors. 

6. Click OK.  

When taxes are exported to a GL application, they will be sent to the Vendor indicated 
here as well as the account as defined in the Company Information dialog box. 

Integrating Specific Areas 

Integrating Master Categories with Accounting 
When you link a master category to an accounting account (be it a QuickBooks or XML 
account), all products and services in the master category will also be linked to the same 
account. This feature is useful because identifying an account for the master category will 
update every product and service to a new account without having to define the account 
for every individual service. However, note that you can define a different account for 
specific products and services; see the Integrating Master Products and Services section. 
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Note: 
Before you can associate a master category with an accounting package, you 
must have first integrated the package with ServiceCEO. 

To configure an accounting account for your Master Categories: 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Click Master Categories. The Service/Product Categories dialog box appears. 

 

3. To link a master category to a GL Account, click the appropriate Income Acct 
field. The General Ledger Account Link dialog box appears. 
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4. Select the account you want to attach to the category from the Account drop-
down list. 

5. Click OK. 

6. Repeat steps 3-5 to link additional master categories to General Ledger accounts. 

7. Click the Commission Account field for the master category for which you want 
to identify a commission account. The Commission Account dialog box appears. 

 

 

Caution: 
There is no default commission account. 

8. Select the account you want to be debited every time an employee is paid 
commissions for any product or service in this category from the Account drop-
down list.  

9. Click OK. 

10. Repeat steps 7-9 to link additional master categories to commission accounts. 

11. Click OK.  

12. Click OK. 
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Integrating Products and Services with Accounting 
You can map any individual product and service to a General Ledger (GL) account.  

Note that if the product or service is part of a master category, and that master category 
has already be integrated with an accounting account, then the product or service will 
already have defined accounts. You can overwrite the default accounts for individual 
products and services at any time; however, if you ever select a new account for the 
master category, any changes you made for individual products and services will be 
overwritten. 

 

Note: 
Before you can associate a master product or service with an accounting account, 
you must have first integrated it with ServiceCEO. 

To link an individual product or service with a GL account: 

1. Perform one of the following actions: 

o Select Tools > Lists > Master Services List or press CTRL+F4. The 
Services tab of the Products and Services page appears. 

o Select Tools > Lists > Master Products List or press CTRL+F5. The 
Products tab of the Products and Services page appears. 

2. Double-click on the service or product that you want to link to a GL package. The 
Product and Service Detail dialog box appears.  

3. Click the Accounting tab. 

 

 

Note: 
The COGS and Inventory Asset accounts will only appear for products for which 
you have Inventory Tracking enabled. 
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4. Click Select for the account you want to add/edit. The accounts are: 

• Income Account. Tracks the income generated by this product/service. 
• COGS Account. The Cost of Goods Sold account. Tracks the cost of all 

inventory products. 
• Inventory Asset Account. The Inventory Asset account. By default, controlled 

by what you defined in the Company Information dialog box. 
• Commission Account. Tracks all commissions paid for the sale of this 

product/service. 

The General Ledger Account Links dialog box appears. 

 

5. Select the account into which you want to export the value from the Account 
drop-down list. 

6. Click OK.   

7. Repeat steps 4-6 to link additional accounts to specific GL accounts. 

8. Click OK.  

9. Repeat steps 2-8 to edit the GL accounts for additional products or services. 

Integrating Time Codes with Accounting 
To help you integrate your payroll with accounting, you can link your time codes to a 
General Ledger (GL) account. To do so: 

1. Open the Time Code Setup dialog box. Depending on the level for which you 
want to define time codes, you access it from different places: 

o For the entire company, select Tools > Lists > Time Codes. 

o For an individual employee, click Time Codes from the employee record. 



Implementation Checklist 

119 

2. To link a time code with a particular accounting account, click  in the General 
Ledger Account column and type the name of the XML account into which this 
data should be exported from the subsequent dialog box. (Note that the General 
Ledger Account column appears only if Accounting Integration is enabled.) 

3. When complete, click OK. 

Once time codes are integrated, payroll will be exported to the defined accounting 
accounts when you create and export paychecks. See the Exporting Paychecks topic of 
the ServiceCEO Help System for details. 

Additional Integration 

Integrating Overtime Rules with Accounting 

To export payroll generated via overtime rules, you must integrate each overtime rule 
with a General Ledger (GL) account. By default, all overtime rules will be integrated 
with the Default Payroll Expense Account as selected in the payroll integration section of 
the Company Information Options dialog box. See the Configuring XML Integration 
section for more details. 

 

Tip: 
For more detail on overtime rules, please see the Defining Overtime Rules topic 
of the ServiceCEO Help System. 
For a detailed explanation of generating payroll with overtime, read the Payroll 
and Overtime topic of the ServiceCEO Help System. 

To integrate an overtime rule with a new accounting account: 

1. Select Tools > Lists > Overtime. The Overtime Setup dialog box appears. 

2. Select the overtime rule you want to integrate with an accounting account. 

3. Click the Accounting tab.  

4. Click Select Payroll Expense/Debit Account.... The General Ledger Account 
Links dialog box appears.  

5. By default, the overtime rule will be integrated with the Default Payroll Expense 
Account as selected in the payroll integration section of the Company Information 
Options dialog box. To change the default value, click in the Account field and 
type the name of the new accounting account.  

6. Click OK.  

7. Repeat steps 2-6 to integrate other overtime rules with accounting accounts. 

8. Click OK. 
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Integrating Payroll Adjustment Types with Accounting 

For a variety of reasons, there are times when you will need to manually adjust an 
employee's payroll. When you do so, you can link these adjustments to an adjustment 
type that you define. Doing so enables you to track particular adjustment types and export 
each adjustment type to a unique account.  

To integrate payroll adjustment types with an accounting account: 

1. Select Tools > Lists > Payroll Adjustment Types. The Payroll Adjustment 
Types dialog box appears. 

2. Click the Accounting Account field for the payroll adjustment type you want to 
integrate. The Payroll Adjustment Account dialog box appears. 

3. By default, this adjustment type will be integrated with the Default Payroll 
Expense Account as selected in the payroll integration section of the Company 
Information Options dialog box. See the Configuring XML Integration section for 
more details.  
To change the default, click in the Account field and type the name of the new 
accounting account. 

4. Click OK. 

5. Repeat steps 2-4 to add additional adjustment types 

6. Click OK. 

Integrating Company Profiles with Accounting 

If you are using multiple profiles in ServiceCEO, you can export data to a different 
accounting application database for each company profile. For example, if you have two 
locations, each one with a unique location, you can export data from each location into a 
separate QuickBooks database (.qbw file).  The one catch is that all vendor and account 
names must have identical names in each accounting database.  

If a profile's data is not explicitly associated with an accounting database, all accounting 
exports will be sent to the account's default company (as configured in the Company 
Information section). See the Configuring Accounting Integration section for details.  

To integrate company profiles with other accounting application databases:  

1. Select Tools > Options or press CTRL+O. The Options dialog box appears. 

2. Click Profiles from the Categories Bar. The Company Profiles Options dialog 
box appears. 

3. Click Edit Profiles. The Admin - Company Profiles dialog box appears. 
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4. Select the company profile that you want to integrate with a accounting 
application database from the Profiles list box.  

5. Scroll down to the bottom of the Details list box. 

6. Select the Use alternate Accounting Company File check box. 

7. Select the accounting package you are using from the Select Accounting drop-
down list.  

8. If you are using ServiceCEO XML, click  next to the Save Exported files in 
Folder field. The Select Company File dialog box appears. Navigate to the 
location where you want to save your XML files. Click OK.  

9. If you are using QuickBooks:  

o Click  next to the Location of QuickBooks Company File field. The 
Select Company File dialog box appears.  

o Navigate to the location where your QuickBooks database is located. The 
default location is C:\Program 
Files\Intuit\QuickBooks\[databasename].qbw.  

o Click Open. A warning dialog box appears, reminding you that you must 
have QuickBooks open.  

o Click OK.  

10. Repeat steps 4-9 to integrate additional profiles with other accounting databases. 

11. Click Save and Close. 

12. Click OK. 

For more on Company Profiles, see the Creating Multiple Company Profiles topic of the 
ServiceCEO Help System. 

Creating a New Customer 
To create a new customer: 

1. Click Customers from the Navigator bar. The Customer List appears. 

2. Click New or select File > New Customer. The General tab of a blank customer 
record appears. Some default information may be populated if the Customer 
Defaults section was filled out. See the Defining Requirements section for details. 
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3. Define all of the necessary fields in the customer record. For more, see the 
appropriate sections: 

o Customers General tab 
o Customers Detail Tab 
o Customers Jobs Tab 
o Customers Notes Tab 
o Customers Links Tab 
o Customers Billing History Tab 
o Customers Equipment Tab 
o Customers Service Contracts Tab 

4. After you've defined all of the customer's information, click Save. 

Importing Data 

Importing Data into ServiceCEO Overview 
Currently, you can import three types of data into ServiceCEO: 

• Customer Records 

• ZIP Codes 

• Inventory Parts/Vendor Catalogs 

While the general importation process is similar for these three types of data, some 
specific changes may be needed to import each type. For details, please see the specific 
sections below, and then click the Next Topic links to read the general sections for details 
on the import process. 

We support importing from five data source formats: 

• Microsoft® Access® databases (*.MDB) 

• Fixed-width text files (*.TXT) 

• Comma-delimited text files (*.CSV) 

• Tab-delimited text files (*.TAB) 

• A previous import configuration file (*.XML) 

For the best results, we recommend using a Microsoft Access file. 

 

Tip: 
Microsoft Excel® data sources are not directly supported; however, you can use 
the “Save As…” option to save an Excel spreadsheet as a CSV file. You can then 
import this CSV file into ServiceCEO. 

For sample import information, please download the ServiceCEO Import Template.xls 
spreadsheet:  
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Caution: 
Date/time stamp values are not imported correctly. The date will be kept, but the 
time stamp will be changed to midnight of that date. 

Importing Customers 
Keep these items in mind when importing customers: 

• The first imported customer location will be set as that customer's Primary and 
Bill To location. All subsequent locations will not be either the Primary nor the 
Bill To location. 

• Do not use the same location name for different locations for a single customer. 

• If there is a value in the Company Name field, the customer record will be marked 
as a Corporate record; if no value appears in the Company Name field, then the 
customer record will be marked as a Residential record. 

• All imported customers will have a status of Prospective. 

• When Mapping Fields, we recommend you configure several (one to three) Key 
fields at the customer, location, and contact levels. See the Mapping Fields topic 
for details. 

Importing ZIP Codes 
Note that if you are mapping the same data field in the source file to all three Tax Codes, 
only the first the Tax code is updated; Tax Code 2 and Tax Code 3 will not updated. 

 

Caution: 
Since Australia does not have a default city for each Post Code, importing 
Australian Post Codes will not automatically setup the auto-population via ZIP 
Code in the Customer Address screen. You will need to map the City, State, tax 
codes and Zones for each imported  code in the Zone Manager. 

Importing Inventory Parts/Vendor Catalogs 
It is very important that you understand the unique relationship between Master Products 
and Vendor Catalog Items before importing inventory data. To that end, we recommend 
that you read the Master Products vs Vendor Catalogs and the Creating New Master 
Products from the Vendor Catalog topics before starting to import inventory. 

Note that before you can import inventory, you must first enable Inventory Tracking. 

When configuring your data file, be sure to provide each column with a clear, self-
descriptive name so that you can easily map the data by column name into the Vendor 
Catalog. 
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Before You Begin 
Before you can import data into ServiceCEO, you need to generate the data file. 
Typically, this involves exporting the data from the CRM product you used before 
ServiceCEO to one of the data source formats listed above. The file that contains your 
data is called the data file. 

Once you have your data file, you many need to tweak the data a little bit in order to 
make sure it imports smoothly into ServiceCEO. To learn how to do this, see the above 
sections, the Select Data Source topic, and the ServiceCEO Import Template.xls 
spreadsheet.   

 

Note: 
Column names in text file data sources should not contain spaces or irregular 
(non-alphanumeric) characters. 

Select Data Source 
The first step of importing data into ServiceCEO is to select the data file that contains the 
information you want to import. Typically, this is  

This is done on the first page of the Data Import Wizard. Accessing the Data Import 
Wizard varies depending on the type of data that you want to import: 

• To import customers, select Tools > Customer Import from the Customer list. 

• To import ZIP Codes, select Tools > Import ZIP Codes from any tab of the 
Zone Manager. 

• To import inventory, open the Parts Catalog tab for the Vendor whose Catalog 
you want to add to or update and click Import Parts.  

Regardless of how you access it, the Data Import Wizard appears. 
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The Data Source Configuration wizard will enable you to choose the file that contains the 
data you want to import and configure it for importation into ServiceCEO.  There are 
three basic types of files: 

1. Importing Data from a Text File 

2. Importing Data from a Microsoft Access file 

3. Importing Data from a Import Configuration File 

Importing Data from a Text File 
The following text file formats can be imported into ServiceCEO:  

• Fixed-width text files (*.TXT). A text file where your values are separated by a 
fixed distance (i.e., five spaces). 

• Comma-delimited text files (*.CSV). Note that CSV files cannot have any spaces 
in the column names. If any column names contain a space, you will receive an 
error message. 

• Tab-delimited text files (*.TAB) 

To configure a TXT, CSV, or TAB file: 

1. Click Configure. The Text File Configuration dialog box appears. 

 

2. Click . The Select File dialog box appears. 

3. Navigate to and select the file you want to use. 
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4. Click OK. The file appears in the Filename field. 

5. Select the option button corresponding to the type of file you are importing. 
Depending on what you select, the name of the check box in section (3) will 
change. 

6. If you are importing a character-delimited file, click the First Row Contains 
Field Names check box if the first row of the file contains the names of the fields 
you are importing. 
If you are importing a fixed-width file, click the Skip First Row check box to 
skip the first row when importing data. Typically this is done if the first row 
contains the names of the import fields. 

7. Click Next. The second page of the Text File Configuration dialog box appears. 
Depending on the option you selected in step 5, the screen will appear differently: 

The second page of the Text File Configuration dialog 
box, if you selected Character-delimited file 

The second page of the Text File Configuration dialog 
box, if you selected Fixed-width 

• Select the option button corresponding to the 
character that separates the values in your file. 

• Click Next. The third page of the Text File 
Configuration dialog box appears, displaying 
the data separated by their fields. 

• Click Add. A new row appears. 

• Type a name for the row. 

• Type the length of the fixed-width segment. 

• Repeat the above steps to define all segments. 

• Click Next. The third page of the Text File 
Configuration dialog box appears, displaying 
the data separated by their fields. 
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10. Review your information. If you are importing a fixed-width file and you need to 
adjust your column widths, click Back and make any necessary adjustments.  

 

Tip: 
Be sure to scroll to the right to view all of the available fields. 
Note that you can edit the column headers by clicking into the header and editing 
the name of the field. 

11. Click Finish. The first page of the Data Import Wizard reappears. 

12. Click Next>. The second page of the Data Import Wizard appears. Continue by 
following the steps in the Mapping Fields section. 

Importing Data from a Microsoft Access file 
To import inventory data from an Access database (a .MDB file): 

1. From the first page of the Inventory Data Import Wizard, select the Import data 
from an Access database option button. 

2. Click Configure. The MS Access Database Configuration dialog box appears. 
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3. Click . The Select File dialog box appears. 

4. Navigate to and select the MS Access database file (*.MDB) you want to import.  

5. Click Open. The file path appears in the Filename field. 

6. Enter the optional security properties, if necessary. 

7. Click Next>. The second page of the MS Access Database Configuration dialog 
box appears. 

 

8. Select the option button corresponding to the query or table you want to use. 

 

Note: 
The table or query you select in this dialog box will control the data that is 
imported from the database. If the database contains more than one table, you 
can select the table you want to import from the drop-down list. If you want to 
limit the data you import, you can select or enter a query. 

9. Select or enter the table or query you want to use. 
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10. Click Next>. The third page of the MS Access Database Configuration dialog box 
appears, previewing your data. 

11. Verify this information is correct. If not, click <Back  to edit your import settings. 

12. Click Finish. The data will be imported. 

Importing Data from a Import Configuration File 
To import inventory from a previous import file (.XML): 

 

Tip: 
See the Preview Import section for details on saving an import file 

1. Click the Load a previous Import Configuration File option button. 

2. Click Load. A Select File dialog box appears. 

3. Navigate to and select the appropriate .XML file. 

4. Click Open. 

5. Click Next>. The second page of the Inventory Data Import Wizard appears. 
Continue by following the steps in the Mapping Fields section. 

Mapping Fields 
The second step of importing data into ServiceCEO is to map the fields from your data 
source (the text, Access, or XML file) to corresponding fields in the ServiceCEO 
database. 

1. Click Next from the first page of the Data Import Wizard to display the second 
page of the wizard. 
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Be sure to read the instructions on this screen of the wizard carefully. 

2. Select the Key check box to mark the field as a Key field if you are updating 
existing data instead of adding new data. Existing records that have matching Key 
Field values will be updated instead of adding new records to the catalog. If the 
Key field's value has no corresponding value in ServiceCEO, a completely new 
record will be created for that part. 
Note that some fields are Key fields by default. A complete description of all 
fields, including the default key fields, is located in the ServiceCEO Import 
Template. 

3. If you are importing customers, you should configure several (one to three) Key 
fields, typically at the customer, location, and contact levels. 

4. Select or type a value in the appropriate Map this Field field. See the ServiceCEO 
Import Template for details.  
A field marked as a Key field must contain a mapped column. Note that this 
column cannot contain any null values; a zero value is acceptable, but a null value 
will generate an error. 
If you have no data that you want to import into a Key field, simply link the Key 
field to a blank column in the import file. 
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Tip: 
When mapping your fields, you can manually enter a field value for all imported 
records. For example, if your data source has no field corresponding to the 
ServiceCEO Credit Problem? and/or CostTaxable field, you can type yes, no, 
true, or false into its corresponding Map This Field field to set all imported 
records to that value. Another good use of this feature is to create a new 
demographic containing all of the customers being imported by typing a name 
for the new demographic in the Map this Field column for the 
NewDemographicName field. 
Warning: This is a powerful feature. Be very sure that you want every imported 
record to be updated to the value you enter before continuing. 

See the Creating New Master Products from the Vendor Catalog topic of the ServiceCEO 
Help System for details about mapping fields for inventory imports.  

Once you've completed mapping the fields, click Next. The next page of the Data Source 
Configuration wizard previews your import using the defined data mapping you just 
created. See the Preview Import section for more. 

Preview Import 
Click Next from the second page of the Data Import Wizard to display the third page of 
the Data Import Wizard. This page previews the results of the import you just created.  

The icons that appear in the Action column are designed to inform you of the action that 
will take place when you click Next. They are: 

• Recycling symbol. Will update all records. For customer imports, will update the 
customer, location, and contact. 

• X symbol. For customer imports, will update the customer and location, inserting 
a contact. 

• Check Mark. For customer imports, will update the customer, inserting the 
location and contact. 

• Arrow. Will insert a new record. For customer imports, will insert the customer, 
location and contact. 
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You can edit any field in the preview grid. Be sure to scroll to the right to view all of the 
fields in the import. 

 

Tip: 
You can use the Tab key to move quickly between fields. 

 

Inventory Note: 
New Master Product entries will only be created when you specify a Master 
Category. For that reason, if you are importing new parts (as opposed to just 
updating vendor pricing) and need to create new Master Products, you will need 
to manually specify a Master Category for each line from the New Mstr Prod 
Category drop-down list. Alternatively, you can use the Use this category for 
all new Master Products drop-down list (located at the bottom right corner) to 
define a default Master Category for all imported items. 
To link imported items to existing Master Products rather than creating new 
ones, select an existing part number from the Master Product Part No column. 
If no values were mapped to this column from your data source, you can 
manually enter existing Master Product Part Numbers or select them from a 
drop-down list. 
Note that the Part No.'s are not filtered by the Master Product Category you 
select. In other words, all part numbers appear regardless of the product category 
you select. Make sure these correspond before continuing. 
Alternatively, you can import the items without creating a new Master Product. 
You can always create a new master product with inventory after the import is 
created - see the Creating Master Products with Inventory topic of the 
ServiceCEO Help System for details. To do this, leave the Master Product field 
empty. 
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1. Select the Include check box to include an item in the import. If this check box is 
deselected, the item will be excluded from this import (it will not be imported or 
updated). Note that the Select All and Select None buttons will select or deselect 
the Include check box for all items. 

2. When you have completed previewing the import, click Next. The fourth page of 
the Data Import Wizard appears. 

 

3. Click the Save Import Configuration check box to save your import 
configuration to an XML file. Doing so provides you with the ability to reload the 
XML file if you need to re-import the information. 

4. Click Finish to complete the import. 

Data Import Wizard Troubleshooting 
The following tips and warnings will help you perform your data imports without errors. 

Text files have the following limitations: 

• Data in text files can't contain irregular, or non-alphanumeric characters. For 
example: &, %, *, / 

• Column headers cannot contain spaces 

• The title of the text file cannot contain periods 

To fix these problems, we recommend you take one or more of these steps: 

• Remove the spaces or irregular characters 

• Replace spaces with underscores or dashes 

• Surround the problematic text with double quotes (") 

• Import the text file into Microsoft® Access® 
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If you find that some data is missing after importing a text file into ServiceCEO, the 
problem may be because the columns and/or fields in the text file have different formats. 
For example, if you have one column where some fields are letter-based but others are 
number-based, some of these values may be dropped when importing into ServiceCEO. 
To fix this issue, put quotes around all of your values. If you have large number of fields 
and/or columns where this problem occurs, we recommend you import this file into 
Microsoft Access, format each field correctly, and then import the Access file into 
ServiceCEO. 

You may encounter problems if you import a text file larger than one megabyte. Please 
either split your file into multiple one megabyte files or import the data into Microsoft 
Access and import the Access file. 

Any nulls (i.e., a field with no value) in the selected key fields will generate errors. 
Replace any null values with either a zero or a space to avoid these errors. 

 

Note: 
For details on formatting fields in Microsoft Access, please review your Access 
documentation.  

Invalid Importation Data 

Customer Importing 

• Time stamp values are not imported correctly. The date will be kept, but specific 
time information will be changed to midnight of that date.  

• Do not use the same location name for two different customer locations.  

• Any nulls (i.e., a field with no value) in the selected key fields will generate 
errors. Replace any null values with either a zero or a space to avoid these errors.  

• You may encounter problems if you import a text file larger than one megabyte. 
Please either split your file into multiple one megabyte files or import the data 
into Microsoft Access and import the Access file. 

If you have customers with identical names but different addresses in your import file 
that you want to import as separate customers (not two locations for the same contact), 
you will need to map an extra customer-level field to the address as a key field on the 
second page of the Data Import Wizard. We recommend you use one of the custom fields 
(one of the "Extra" fields).  

Inventory Importing 

The product description cannot contain more than 255 characters, including spaces, or an 
error will result. 
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Credit Card Processing 
The CC Processing tab of the Office Duties topic of the ServiceCEO Help System 
enables you to process credit cards through ServiceCEO. In order to process credit cards 
within ServiceCEO, you will need to enable integration with one of the Credit Card 
vendors that integrate with ServiceCEO. 

To learn more about ServiceCEO's credit card processing capabilities, please point your 
browser to http://www.insightdirect.com/services/credit-card-processing/. 

To apply for a merchant account and begin processing credit cards, please fill out the Pre-
Application form, located at: http://www.insightdirect.com/accepting-credit-cards/. 

After you have been issued a new activation code containing the Credit Card Integration 
license, but before you install the Credit Card vendor software, you will need to perform 
two steps: 

• Activate Credit Card Integration. Select the Use Integrated credit card 
processing check box and indicate the folder you are using as the transaction 
folder. For details, see the Defining Payment Types section. 

• Provide Users Security Rights. Provide your users the proper rights to process 
credit card payments. See the Managing User Groups section for details. The 
security rights you will need to assign are called "Credit Card Processing". 

 

Caution: 
ServiceCEO only exports the first 20 characters of the first address line, as 
defined in the Address Information dialog box.  

Once you have set up the vendor software, read the Processing Credit Card Payments 
topic. 
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Glossary 
A 

Activation Code: The code - a string of letters and numbers - that validates ServiceCEO 
so it can be used beyond the initial 14-day trial period. 

Active Period: The Active Period defines the date range for visible items within the 
application. In other words, only jobs that occur within this active period will be 
visible. This limitation ensures that the system will maintain a manageable 
volume of active schedule data while sustaining reasonable performance. 

Adjustment: A change to an invoice or customer's account balance. 

API: Shot for Application Programming Interface. The ServiceCEO API is designed so 
that developers can extend ServiceCEO's functionality by writing their own 
programs (or web services) that use the API to integrate with ServiceCEO. 

C 
Campaign: A campaign is a specific marketing activity. You can define its start date, 

end date, budget, and related tasks. 

Charge: A fee that is assessed to a client for a service or product. It is designed to cover 
a single (billable) Product, Service, Entire Service Contract, or miscellaneous 
charge. There are two types of charges: Fixed and Variable. 

Client Computer: Any computer running ServiceCEO that is not hosting the 
ServiceCEO database. All client computers must connect, via a network, to the 
server in order to see the ServiceCEO database. 

Commission: A commission is a rate of pay based upon the percentage of the total sale 
of a the commissionable product\service on a job. The Completion Wizard 
automatically processes commissions during job completion, calculating 
employee’s pay and, if necessary, automatically dividing up the commission 
amongst multiple employees. Note: The method of splitting commissionable 
charges can be changed in the Payroll Options dialog box. 

Cost: The wholesale price of a product. The retail price is called the selling price. 

CPU: Short for Central Processing Unit. 

CSV: Comma Separated Value. 

Customer: Corporations or individuals for whom services or products are provided. 
ServiceCEO tracks customers' address and contact data, billing information, and 
scheduled appointments. 

Customer List: The Customer List is a complete listing of client records - both active 
and inactive records. The list can be sorted by status using a filter. The purpose of 
this list is to assist the user in locating a particular Customer Record. 



Implementation Checklist 

137 

D 
Demographic: A selected group of customers based on characteristics and/or filters you 

define. 

Dispatch Board: The Dispatch Board is a single screen where all users can view and 
manage team assignments for a given day. It displays all of an organization’s 
teams along with all of the employees and jobs assigned to each team. This 
configuration allows users to easily see what is scheduled to take place during the 
selected day. In addition, users can use the Dispatch Board to easily manage their 
teams within ServiceCEO. 

Duration-Based: This method of recording the length of a job displays the length of time 
it takes to complete a job. The duration of each job will be constant; adding and 
removing team members assigned to that job will not alter the duration of that job. 
(It will, however, alter each employee's man-hours.) 

E 
Employee: Default term for people employed to perform work for clients. 

Employee Record: Tracked in the Employee List, an Employee Record is the complete 
set of information for an individual. The record will track the employee's address, 
phone numbers, social security number, e-mail address, emergency contacts, 
payroll history, job performance notes, and more. 

Estimate: An internal record of proposed work for a customer. An estimate is identical to 
a job but, because it records proposed rather than planned work, it does not appear 
on the calendar. Not to be confused with a Quote. 

F 
Filter: A Filter limits what data is displayed on a particular page based on criteria that 

you define. 

Fixed Charge: A charge that is only entered once and will not change as work is 
performed or completed. It will remain the same regardless of the amount of man-
hours or the number of visits in which it takes to complete a job or service. 

G 
General Ledger: The general ledger is the main accounting record of a business which 

uses double-entry bookkeeping. It consists of accounts for fixed assets, current 
assets and liabilities, profit and loss or income and expenditure items, and funds 
or reserves. The general ledger is a summary of all of the transactions that occur 
in the company. 
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H 
HTML: Short for HyperText Markup Language. Much of the web is written in HTML or 

one of its derivatives. 

I 
Idiolect: Idiolect is a unique linguistic pattern unique among speakers of a language or 

dialect. In terms of ServiceCEO, the Idiolect option enables you to customize 
your application based on the country or region in which you are operating. 

Invoice: A detailed list of goods shipped or services rendered, with an account of all 
costs. 

Internet via a modem and browse the Internet. 

J 
Job: A unique service visit. It contains all information about the products and/or services 

that will be provided to a customer. A series of jobs can be created by a schedule 
(a job with a defined frequency). Note that the term Job is customizable. For 
details, see the Defining Vocabulary topic of the ServiceCEO Help System. 

Job Window: The leeway, in hours, for starting the job, as defined in the General tab of 
the job record. For example, if the job is scheduled to start at 2:00 and has a 
window of .5 hours, the job must be started at some point between 1:30 and 2:30. 

K 
Kit: A Kit is a grouping of related services and/or products together in a group so that 

they can be added to a job as a bundle rather than as an individual line-item. 

M 
Man-Hour: This method of recording the length of a job displays the total number of 

hours it takes to complete a job. This number is calculated by multiplying the 
length of the job by the total number of employees assigned to the job. 

Master Category: A user-defined grouping of individual services and products. 

MDB: Short for Microsoft Access database. 

N 
Navigator bar: The Navigator bar is the list of icons on the left side of all ServiceCEO 

pages that links to all of the major sections of the application. 
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O 
ODBC: Short for Open DataBase Connectivity. ODBC is a standard database access 

method developed by Microsoft®. ODBC enables access to any data from any 
application, regardless of which database management system (DBMS) is 
handling the data. 

P 
Price Level: A method of marking up or down the price of products or services on a job 

by a certain percentage. 

Product: A commodity that is sold to a customer. 

Project: A job that consists of multiple visits or days of service. 

Q 
QuickBooks: QuickBooks® is a popular accounting software program with which 

ServiceCEO can integrate, updating QuickBooks' general ledger when financial 
actions are performed within the application (i.e., jobs are closed, deposits are 
made, etc). 

R 
Role: The duties the employee performs on any given job. Depending on which role the 

employee is assigned to when working on a job, the employee may have different 
payroll settings. Payroll for different roles can be defined in the employee's 
Payroll Setup tab. 

RTF: Short for Rich Text Format. RTF is the format used for entering enhanced notes. 
For more about RTF, please point your browser to 
http://en.wikipedia.org/wiki/Rich_Text_Format. 

S 
Sales Representative: An employee who sells the jobs and/or schedules that you service. 

Schedule: A job with a frequency (service plan). Saving a schedule will create a series of 
jobs, depending on the frequency settings. The term Schedule is customizable. For 
details, see the Defining Vocabulary topic of the ServiceCEO Help System. 

Service: A category of work or duties performed for a customer. 

Service Unit: A Service Unit is a method of breaking down or measuring a service, 
usually for payment purposes. 
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ServiceCEO Enterprise: ServiceCEO Enterprise is an expanded version of ServiceCEO 
with enhanced functionality designed to help you to manage an organization with 
multiple locations. The main difference between ServiceCEO and ServiceCEO 
Enterprise is the company structure - ServiceCEO Enterprise has a hierarchical 
organization model, starting at the top with the Organization, and then moving 
down into Regions, Branches, and Zones. Each organization can have an 
unlimited number of regions or branches. 

Skills: The abilities that a particular employee possesses, as defined on their Skills tab. 

SmartList: Enabling the SmartList feature (located on the Schedule General tab when 
creating new schedules) displays only teams or employees working in the 
customer's specific branch and/or zone. 

Status: The condition of a customer or employee record in the system. Status cannot be 
controlled by users; it depends on the condition of various items, including active 
jobs, estimates and account balance. 

Substatus: A code that further expands existing job, task, and estimate statuses. 

T 
Task: An action that needs to be performed outside of the scope of a job or schedule. 

Team: The default term for a group of employees that work together. Teams as assigned 
to jobs, so all employees assigned to team will be work on that job. If you are 
tracking inventory, a team can also be a stock location. 

Time Block: A block of time that indicates the employee's status for that time. Each time 
block is associated with one time code. 

Time Code: Time codes contain attributes that can apply to a particular block of time: 
Employee Availability, Payroll Eligibility, and General Ledger Account 
integration. See the Defining Time Codes topic of the ServiceCEO Help System 
for details. 

Transaction: A financial transaction not directly related to a job 

TXT: Short for text file. 

V 
Variable Charge: A charge that is incurred incrementally as work is completed. When 

defined, the charge will be scheduled and will appear on the invoice as Projected, 
but the charge will not be applied against the customer's account until the service 
is completed or the product is delivered. 

W 
Window Time: The proposed length of time during which the employee or team of 

employees will be arriving to complete the job or deliver a product. 
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Work Order: A grouping of job tickets what can be printed and sent with the employee 
or team as a statement of work. A work order can include directions to the 
customer, the customer's billing information, and other miscellaneous 
instructions. 

Z 
ZIP Code: A series of numbers added to an address to help deliver the mail in the United 

States. Known as Postal Code outside of the United States. 

Zone: A user-defined geographic territory. Zones enable you to strategically associate 
teams of employees in a particular zone with customers in the same zone to 
facilitate easy and efficient dispatching. 

Zone Pricing: A method of controlling the pricing of products and services based on 
location.

 


